B&R Windows CE 4.1/4.2

Startseite

Nächstes Thema >>
Spezifikation


Spezifikation

B&R Windows CE 4.1/4.2 für B&R Power Panels 100/200 und B&R Mobile Panels 100/200

Merkmal | Wert
Bildschirmauflösung | QVGA - LCD, QVGA - TFT, VGA - TFT, SVGA - TFT, XGA - TFT.
Farbtiefe | 16Bit/65536 Farben*.
Grafikkartentreiber | AMD Geode Grafikkartentreiber mit Screenrotation ohne DirectX**.
RAM | Automatische Erkennung und Verwendung von bis zu 512 MByte RAM .
Bootuptime | Ca. 20 Sekunden.
Screenrotation | Der Desktop kann in 90° Schritten gedreht werden.
Webbrowser | Internet Explorer für Windows CE.
.Net | Wird unterstützt.
Imagegröße | Ca. 23 MByte.
Kundenspezifische Tasten | Wird unterstützt.
PVI | Wird unterstützt.

*)B&R Windows CE Images, welche auf Microsoft Windows CE 4.1 basieren, können bei einer QVGA Auflösung nur 256 Farben darstellen.
**) B&R Windows CE Images, welche auf Microsoft Windows CE 4.1 basieren, verwenden für die QVGA Auflösungen den Microsoft Framebuffertreiber mit Screenrotation.

B&R Power Panel
Beispiel eines B&R Power Panels 100/200
B&R Mobile Panel
Beispiel eines B&R Mobile Panels 100/200

<< Vorheriges Thema
B&R Windows CE 4.1/4.2

Startseite

Nächstes Thema >>
Komponenten/Funktionen/Treiber

Kapitelanfang


Komponenten/Funktionen/Treiber

Allgemein

In diesem Kapitel finden Sie die Komponenten und Treiber, welche in den verschiedenen B&R Windows CE 4.1/4.2 Images integriert sind. Detailierte Beschreibungen der Komponenten entnehmen Sie bitte der Platform Builder Hilfe, oder dem Microsoft Authoring Kit.

In diesem Abschnitt werden folgende Themen behandelt:

Komponenten/Funktionen/Treiber

Power Panel 100/200

Mobile Panel 100/200

<< Vorheriges Thema
Spezifikation

Startseite

Nächstes Thema >>
Power Panel 100/200


Power Panel 100/200

In diesem Abschnitt werden folgende Themen behandelt:

Power Panel 100/200

V1.0

V1.1

V1.2

V1.3

V1.4

V1.5

V2.0

V2.1

V3.0

<< Vorheriges Thema
Komponenten/Funktionen/Treiber

Startseite

Nächstes Thema >>
V1.0


V1.0

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • Geode/MediaGX (Rotation Support)
  • VGA Linear (Flat) Framebuffer (Rotation Support)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

PCI Bus Treiber

  • PCI Bus

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver
  • Compact Flash / PC Card Storage (ATADISK)

USB Host

  • OHCI

Printer Devices

  • PCL Printer Driver

Application & Service Development

  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Applications End - User

  • ActiveSync
  • Microsoft Excel Viewer
  • Microsoft Image Viewer
  • Microsoft PDF Viewer
  • Microsoft PowerPoint Viewer
  • Help
  • Remote Desktop Protocol (RDP)
  • WordPad

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Security

  • Authentication Services (SSPI)
  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider
  • NTLM
  • Schannel (SSL/TLS)
  • Certificates (CryptoAPI 2.0)

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager

<< Vorheriges Thema
Power Panel 100/200

Startseite

Nächstes Thema >>
V1.1


V1.1

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • Geode/MediaGX (Rotation Support)
  • VGA Linear (Flat) Framebuffer (Rotation Support)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

PCI Bus Treiber

  • PCI Bus

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver
  • Compact Flash / PC Card Storage (ATADISK)

USB Host

  • OHCI

Printer Devices

  • PCL Printer Driver

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Applications End - User

  • ActiveSync
  • Microsoft Excel Viewer
  • Microsoft Image Viewer
  • Microsoft PDF Viewer
  • Microsoft PowerPoint Viewer
  • Help
  • Remote Desktop Protocol (RDP)
  • WordPad

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Security

  • Authentication Services (SSPI)
  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider
  • NTLM
  • Schannel (SSL/TLS)
  • Certificates (CryptoAPI 2.0)

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager

<< Vorheriges Thema
V1.0

Startseite

Nächstes Thema >>
V1.2


V1.2

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • VGA Linear (Flat) Framebuffer (Rotation Support)
  • Geode/MediaGX (Rotation Support)

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

PCI Bus Treiber

  • PCI Bus

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver
  • Compact Flash / PC Card Storage (ATADISK)

USB Host

  • OHCI

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Security

  • Authentication Services (SSPI)
  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider
  • NTLM
  • Schannel (SSL/TLS)
  • Certificates (CryptoAPI 2.0)

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)
  • FTP Server
  • RAS Server / PPTP Server (incoming)
  • Telnet Server
  • Web Server Administration ISAPI
  • Active Server Pages (ASP) Support
  • Device Management ISAPI Extension

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

Applications End - User

  • ActiveSync
  • Microsoft Excel Viewer
  • Microsoft Image Viewer
  • Microsoft PDF Viewer
  • Microsoft PowerPoint Viewer
  • Help
  • Remote Desktop Protocol (RDP)
  • WordPad

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Printer Devices

  • PCL Printer Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • SNTP Client
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager

<< Vorheriges Thema
V1.1

Startseite

Nächstes Thema >>
V1.3


V1.3

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • VGA Linear (Flat) Framebuffer (Rotation Support)
  • Geode/MediaGX (Rotation Support)

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

PCI Bus Treiber

  • PCI Bus

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver
  • Compact Flash / PC Card Storage (ATADISK)

USB Host

  • OHCI

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Security

  • Authentication Services (SSPI)
  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider
  • NTLM
  • Schannel (SSL/TLS)
  • Certificates (CryptoAPI 2.0)

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)
  • FTP Server
  • RAS Server / PPTP Server (incoming)
  • Telnet Server
  • Web Server Administration ISAPI
  • Active Server Pages (ASP) Support
  • Device Management ISAPI Extension

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

Applications End - User

  • ActiveSync
  • Help
  • Remote Desktop Protocol (RDP)

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Printer Devices

  • PCL Printer Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • SNTP Client
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager
  • Power Panel Control Center
  • B&R Notepad
  • Power Panel System DLL

<< Vorheriges Thema
V1.2

Startseite

Nächstes Thema >>
V1.4


V1.4

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • VGA Linear (Flat) Framebuffer (Rotation Support)
  • Geode/MediaGX (Rotation Support)

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

PCI Bus Treiber

  • PCI Bus

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver
  • Compact Flash / PC Card Storage (ATADISK)

USB Host

  • OHCI

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)
  • FTP Server
  • RAS Server / PPTP Server (incoming)
  • Telnet Server
  • Web Server Administration ISAPI
  • Active Server Pages (ASP) Support
  • Device Management ISAPI Extension

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Times New Roman (Subset 1_30)
  • Symbol
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

Applications End - User

  • ActiveSync
  • Help
  • Remote Desktop Protocol (RDP)

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Printer Devices

  • PCL Printer Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • SNTP Client
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager
  • Power Panel Control Center
  • B&R Notepad
  • Power Panel System DLL
  • Server Applet

<< Vorheriges Thema
V1.3

Startseite

Nächstes Thema >>
V1.5


V1.5

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • VGA Linear (Flat) Framebuffer (Rotation Support)
  • Geode/MediaGX (Rotation Support)

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

PCI Bus Treiber

  • PCI Bus

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver

USB Host

  • OHCI

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)
  • FTP Server
  • RAS Server / PPTP Server (incoming)
  • Telnet Server
  • Web Server Administration ISAPI
  • Active Server Pages (ASP) Support
  • Device Management ISAPI Extension

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Times New Roman (Subset 1_30)
  • Symbol
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

Applications End - User

  • ActiveSync
  • Help
  • Remote Desktop Protocol (RDP)

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Printer Devices

  • PCL Printer Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • SNTP Client
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager
  • Power Panel Control Center
  • Mobile Panel Control Center
  • B&R Notepad
  • Power Panel System DLL
  • Mobile Panel System DLL
  • Server Applet
  • MXC - Treiber

<< Vorheriges Thema
V1.4

Startseite

Nächstes Thema >>
V2.0


V2.0

Basisbetriebssystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Power Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX

  • .NET Compact Framework

    • .NET Compact Framework 1.0 - SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • ActiveSync

    • File Sync

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Exenstions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • MXC

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Power Panel Default ActiveSync Connection

    • Power Panel Desktop Style

  • Display

    • Power Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Power Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Power Panel Touchcontroller

  • Storage Devices

    • Power Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Power Panel AutoRun

  • Power Panel Control Center

  • Power Panel System DLL

  • Power Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Power Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V1.5

Startseite

Nächstes Thema >>
V2.1


V2.1

Basisbetriebssystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Power Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX

  • .NET Compact Framework

    • .NET Compact Framework 1.0 - SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • ActiveSync

    • File Sync

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection
      • Smart Card Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Exenstions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • MXC

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Power Panel Default ActiveSync Connection

    • Power Panel Desktop Style

  • Display

    • Power Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Power Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Power Panel Touchcontroller

  • Storage Devices

    • Power Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Power Panel AutoRun

  • Power Panel Control Center

  • Power Panel System DLL

  • Power Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Power Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V2.0

Startseite

Nächstes Thema >>
V3.0


V3.0

Baseoperatingsystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Power Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX
    • XML HTTP
    • XML Query Languages (XQL)
    • XML Stylesheet Language Transformation (XSLT)

  • .NET Compact Framework

    • .NET Compact Framework 1.0 - SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • ActiveSync

    • File Sync

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection
      • Smart Card Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Extensions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • Automation Device Interface

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Power Panel Default ActiveSync Connection

    • Power Panel Desktop Style

  • Display

    • Power Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Power Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Power Panel Touchcontroller

  • Storage Devices

    • Power Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Power Panel AutoRun

  • Power Panel Control Center

  • Power Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Power Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V2.1

Startseite

Nächstes Thema >>
Mobile Panel 100/200


Mobile Panel 100/200

In diesem Abschnitt werden folgende Themen behandelt:

Mobile Panel 100/200

V1.5

V2.0

V2.1

V3.0

<< Vorheriges Thema
V3.0

Startseite

Nächstes Thema >>
V1.5


V1.5

Basisbetriebssystem

  • Microsoft Windows CE 4.1

Displaytreiber

  • VGA Linear (Flat) Framebuffer (Rotation Support)
  • Geode/MediaGX (Rotation Support)

Serielle Schnittstellen

  • Com16550 (COM 1, zur freien Verwendung)
  • Com16550 (COM 2, intern Touchcontroller)
  • Com16550 (COM 3, intern Matrixcontroller)

Eingabegeräte

  • NOP (Stub) Keyboard/Mouse German
  • NOP (Stub) Keyboard/Mouse English

PCI Bus Treiber

  • PCI Bus

Storage Devices

  • ATAPI PCI/IDE Storage Block Driver

USB Host

  • OHCI

Netzwerkkartentreiber

  • National Semiconductor DP83815 (MacPhyter)

Multimedia Technologies

  • Waveform Audio
  • DirectDraw
  • WMA Codec
  • DirectShow Core
  • DMO Wrapper Filter
  • AVI Filter
  • MPEG-1 Parser/Splitter
  • Cinepak Video Codec
  • DirectShow Video Renderer
  • MPEG-1 Video Codec
  • MS RLE Video Codec
  • QuickTime V2 Video Codec
  • WMV / MPEG-4 Video Codec
  • Windows Media Player Application
  • Windows Media Player OCX
  • Windows Media Technologies

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)

Shell and User Interface

  • Command Processor
  • Console Window
  • Landscape (480x240 and larger)
  • Standard Shell
  • Mouse
  • Network User Interface
  • Software-based Input Panel Driver
  • SIP for Large Screens
  • SIP for Small Screens
  • Windows XP-like Sample Skin

Application & Service Development

  • .Net Compact Framework V1.0
  • Active Template Library (ATL)
  • C++ Exception Handling
  • Run-Time Type Information
  • Standard IO (STDIO)
  • Standard IO ASCII (STDIOA)
  • DCOM
  • Microsoft Foundation Classes (MFC)
  • XML Core Services and Document Object Model (DOM)
  • XML SAX

Internet Client Services

  • Internet Explorer 5.5 for Windows CE - Standard Components
  • Internet Explorer 5.5 Sample Browser
  • JScript 5.5
  • VBScript 5.5
  • Internet Explorer Browser Control Host
  • Internet Explorer HTML/DHTML API
  • Internet Explorer Multiple-Language API
  • URL Moniker Services
  • Windows Internet Services
  • Pocket Internet Explorer HTML View (WEBVIEW)
  • Sample IE 5.5 Internet Options Control Panel

Communication Services and Networking

  • Wired Local Area Network (802.3, 802.5)
  • Dial Up Networking (RAS/PPP)
  • AutoDial
  • Point-to-Point Protocol over Ethernet (PPPoE)
  • Telephony API (TAPI 2.0)
  • Virtual Private Networking (PPTP)
  • Unimodem Support
  • Network Utilities (IpConfig, Ping, Route)
  • Control Point API
  • Windows Networking API/Redirector (SMB/CIFS)
  • Winsock Support
  • Core Server Support
  • Web Server (HTTPD)
  • FTP Server
  • RAS Server / PPTP Server (incoming)
  • Telnet Server
  • Web Server Administration ISAPI
  • Active Server Pages (ASP) Support
  • Device Management ISAPI Extension

Core OS Service

  • LmemDebug memory debugging hooks
  • Toolhelp API
  • Fiber API
  • FormatMessage APIHelp
  • Power Management (Minimal)
  • Serial Port Support
  • USB Host Support
  • USB Human Input Device (HID) Class Driver
  • USB Printer Class Driver
  • USB Remote NDIS Class Driver
  • USB Storage Class Driver

Fonts

  • Arial (Subset 1_30)
  • Arial Black
  • Arial Italic
  • Impact
  • Times New Roman Italic
  • Times New Roman (Subset 1_30)
  • Symbol
  • Verdana
  • Comic Sans MS
  • Wingding
  • Tahoma (Subset 1_07)
  • Courier New (Subset 1_30)

Filesystems and Datastore

  • Bit - based
  • Hive-based Registry
  • RAM & ROM File System
  • Storage Manager
  • FAT File System
  • CD / UDFS File System

Applications End - User

  • ActiveSync
  • Help
  • Remote Desktop Protocol (RDP)

International

  • National Language Support (NLS)
  • Input Method Selector Sample Application

Platform Manager

  • Base Engine
  • Transports
  • ActiveSync
  • TCP/IP

Printer Devices

  • PCL Printer Driver

Zusätzliche B&R Tools und Treibers

  • PVI
  • Treiber für 5IF760.9 aPCI Modul
  • Fullscreenwebbrowser
  • B&R RegistryEditor
  • SNTP Client
  • Tool zum Registrieren von ActiveX's
  • Tool zum Drehen des Desktops
  • Start.dat Parser
  • Settings.reg Parser
  • Configuration Manager
  • Power Panel Control Center
  • Mobile Panel Control Center
  • B&R Notepad
  • Power Panel System DLL
  • Mobile Panel System DLL
  • Server Applet
  • MXC - Treiber

<< Vorheriges Thema
Mobile Panel 100/200

Startseite

Nächstes Thema >>
V2.0


V2.0

Basisbetriebssystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Mobile Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX

  • .NET Compact Framework

    • .NET Compact Framework 1.0 SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Exenstions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • MXC

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Mobile Panel Desktop Style

  • Display

    • Mobile Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Mobile Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Mobile Panel Touchcontroller

  • Storage Devices

    • Mobile Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Mobile Panel AutoRun

  • Mobile Panel Control Center

  • Mobile Panel System DLL

  • Mobile Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Mobile Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V1.5

Startseite

Nächstes Thema >>
V2.1


V2.1

Basisbetriebssystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Mobile Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX

  • .NET Compact Framework

    • .NET Compact Framework 1.0 SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection
      • Smart Card Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Exenstions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • MXC

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Mobile Panel Desktop Style

  • Display

    • Mobile Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Mobile Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Mobile Panel Touchcontroller

  • Storage Devices

    • Mobile Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Mobile Panel AutoRun

  • Mobile Panel Control Center

  • Mobile Panel System DLL

  • Mobile Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Mobile Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V2.0

Startseite

Nächstes Thema >>
V3.0


V3.0

Basisbetriebssystem

  • Microsoft Windows CE 4.2

Displaytreiber

  • Mobile Panel Geode Graphiccard Driver with Rotation Support

Security

  • Authentication Services (SSPI)

    • NTLM
    • Schannel (SSL/TLS)
    • Kerberos

  • Cryptography Services (CryptoAPI 1.0) with High Encryption Provider

    • Certificates (CryptoAPI 2.0)
    • Diffie-Hellman/DSS Provider

Shell and User Interface

  • Shell

    • Command Shell

      • Command Processor
      • Console Window
      • Standard Shell

  • User Interface

    • Mouse

    • Network User Interface

    • Customizable UI

      • Windows XP-like Sample Skin

    • Software Input Panel

      • Software-based Input Panel Driver
      • SIP for Large Screens
      • SIP for Small Screens

Applications and Services Development

  • XML

    • XML Core Services and Document Object Model (DOM)
    • XML SAX
    • XML HTTP
    • XML Query Languages (XQL)
    • XML Stylesheet Language Transformations (XSLT)

  • .NET Compact Framework

    • .NET Compact Framework 1.0 SP2
    • OS Dependencies for .NET Compact Framework 1.0
    • Smart Device Authentication Utility

  • Active Template Library (ATL)

  • Component Services (COM and DCOM)

    • DCOM
    • COM Storage
    • DCOM Remote Access

  • Microsoft Foundation Classes (MFC)

  • C Libraries and Runtimes

    • C++ Exception Handling
    • Run-Time Type Information
    • Standard I/O (STDIO)
    • Standard I/O ASCII (STDIOA)

Communication Services and Networking

  • Networking Features

    • Network Utilities (IpConfig, Ping, Route)
    • TCP/IP
    • IP Helper API
    • Windows Networking API/Redirector (SMB/CIFS)
    • Winsock Support

  • Universal Plug and Play (UPnP)

    • Control Point API
    • Device Host API

  • Networking - Local Area Network (LAN)

    • Wired Local Area Network (802.3, 802.5)

  • Servers

    • Core Server Support
    • File Server
    • FTP Server
    • RAS Server/PPTP Server (Incoming)
    • Simple Network Time Protocol (SNTP) Service
    • Telnet Server
    • Web Server (HTTPD)
      • Active Server Pages (ASP) Support
      • Device Management ISAPI Extension
      • Web Server Administration ISAPI

  • Networking - Wide Area Network (WAN)

    • Dial Up Networking (RAS/PPP)
      • AutoDial

    • Point-to-Point Protocol over Ethernet (PPPoE)

    • Telephony API (TAPI 2.0)
      • Unimodem Support

    • Virtual Private Networking
      • PPTP

Core OS Services

  • Power Management (Minimal)

  • Serial Port Support

  • USB Host Support

    • USB Human Input Device (HID) Class Driver

      • USB HID Keyboard and Mouse
      • USB HID Keyboard Only
      • USB HID Mouse Only

    • USB Printer Class Driver

    • USB Storage Class Driver

    • USB Remote NDIS Class Driver

  • Debugging Tools

    • LMemDebug Memory Debugging Hooks

    • Toolhelp API

  • Kernel Features

    • Fiber API

    • Parallel Port Support

Internet Client Services

  • Internet Explorer 6.0 for Windows CE Components

    • Internet Explorer Browser Control Host

    • Internet Explorer HTML/DHTML API

    • Internet Explorer Multiple-Language Base API

    • URL Moniker Services

    • Windows Internet Services

    • Sample Internet Explorer 6.0 Internet Options Control Panel

  • Internet Explorer 6.0 for Windows CE - Standard Components

    • Internet Explorer 6.0 Sample Browser

  • Scripting

    • JScript 5.5
    • VBScript 5.5

Applications - End User

  • CAB File Installer/Uninstaller

  • Help

  • WordPad

  • Remote Desktop Connection

    • Remote Desktop Protocol (RDP)

      • User Interface Dialog Boxes
      • Cut/Copy/Paste Clipboard Redirection
      • File Storage Redirection
      • Printer Redirection
      • Serial and Parallel Port Redirection
      • Smart Card Redirection

Fonts

  • Arial

    • Arial (Subset 1_30)

    • Arial Black

    • Arial Italic

  • Verdana

  • Comic Sans MS

  • Georgia

  • Symbol

  • Times New Roman

    • Times New Roman (Subset 1_30)

    • Times New Roman Italic

  • Wingding

  • Tahoma (Subset 1_07)

  • Courier New (Subset 1_30)

Multimedia Technologies

  • Multimedia Components

    • DirectDraw

    • Windows Media Player

      • Windows Media Player Application
      • Windows Media Player OCX

    • Windows Media Technologies

      • DirectShow

        • DirectShow Core
        • DMO Wrapper Filter
        • Media Formats
          • AVI Filter
          • MPEG-1 Parser/Splitter
        • Video Codecs and Renderers
          • DirectShow Video Renderer
          • MPEG-1 Video Codec
          • MS RLE Video Codec
          • Video/Image Compression Manager
          • WMV/MPEG-4 Video Codec
        • Audio Codecs and Renderers
          • WMA Codec
      • Audio
        • Waveform Audio

File Systems and Data Store

  • Bit-based

  • Hive-based Registry

  • RAM and ROM File System

  • Storage Manager

    • FAT File System

    • CD/UDFS File System

    • Transaction-Safe FAT File System (TFAT)

Bernecker + Rainer specific Tools

  • Configuration Settings

    • File Extensions

    • Run History

  • Control Panel Applets

    • Server Applet

    • Configuration Manager

  • Driver

    • aPCI Modul 5IF760.9

    • Automation Device Interface

  • Programs

    • Registry Editor

    • RegSvrCE

    • Fullscreen Webbrowser

    • DCOMCnfg

    • PVI

  • SCADA Package Support

    • COPA-DATA zenOn

International

  • National Language Support (NLS)

Device Drivers

  • Configuration Settings

    • Mobile Panel Desktop Style

  • Display

    • Mobile Panel Geode Graphiccard Driver with Rotation Support (WinCE4.1)

  • Networking

    • Local Area Networking (LAN) devices

      • Mobile Panel DP83815/DP83816 Network Card

  • PCI Bus

  • Mobile Panel Touchcontroller

  • Storage Devices

    • Mobile Panel ATAPI Driver Update

      • Storage Devices

      • ATAPI PCI/IDE Storage Block Driver

  • Input Devices

    • NOP (Stub) Keyboard/Mouse English

  • Mobile Panel AutoRun

  • Mobile Panel Control Center

  • Mobile Panel Touch Calibration Utility

  • Printer Devices

    • PCL Printer Driver

  • Serial

    • Mobile Panel 3 Serial Communication Ports

  • USB Host

    • OHCI

Platform Manager

  • Base Engine

    • Transports

      • ActiveSync
      • TCP/IP

<< Vorheriges Thema
V2.1

Startseite

Nächstes Thema >>
Inbetriebnahme


Inbetriebnahme

In diesem Abschnitt werden folgende Themen behandelt:

Inbetriebnahme

Konfiguration

Manuelle Installation

Duplizieren

<< Vorheriges Thema
V3.0

Startseite

Nächstes Thema >>
Konfiguration


Konfiguration

In diesem Abschnitt werden folgende Themen behandelt:

Konfiguration

Erstellung eines Bootlogos

Bearbeiten der Registry

Kalibrierung des Touch

Einstellen von Helligkeit und Kontrast

Parametrierung der Tasten

Speichern der Registry

<< Vorheriges Thema
Inbetriebnahme

Startseite

Nächstes Thema >>
Erstellung eines Bootlogos


Erstellung eines Bootlogos

In diesem Beispiel wird ein Bootlogo für das B&R Windows CE 4.1/4.2 Gerät erstellt. Es wird dazu das Programm Corel Photopaint Version 9 verwendet.

Hinweis:
Das Bootlogo muss folgendes Format haben:
640x480 Pixel, 8 Bit Farbpalette, Standard VGA, 72DPI Auflösung, Windows Bitmap Format, Unkomprimiert

Das Bootlogo kann mit jedem besseren Malprogramm (nicht Microsoft Paint!) erstellt werden.

Schritt 1: Ein neues Bild erstellen

Wählen Sie im Menü Datei den Befehl Neu.

Ein neues Bild wird angelegt
Ein neues Bild wird angelegt

Weisen Sie den Parametern folgende Werte zu:

Parameter | Wert
Farbmodus | 8 Bit Palette
Breite | 640 Pixel
Höhe | 480 Pixel
Auflösung | 72 DPI

Schritt 2: Farbpalette definieren

Die Farbpalette ändern Sie zu diesem Zeitpunkt nicht. Dialog ohne Änderung mit OK bestätigen.

Die Farbpalette wird nicht geändert
Die Farbpalette wird nicht geändert

Schritt 3: Bild erstellen

Malen Sie nun ihr Bootlogo.

Malen sie nun ihr Bootlogo
Malen sie nun ihr Bootlogo

Hinweis:
Wenn Sie ein Logo für QVGA Geräte erstellen wollen, teilen Sie das Bitmap in 4 gleich große Rechtecke mit der Größe 320x200.
Füllen Sie jedes Rechteck mit dem gewünschten QVGA Logo.

Bootlogo für ein QVGA Gerät
Beispiel: Bootlogo für ein QVGA Gerät

Schritt 4: Bild spiegeln

Damit das Bitmap korrekt angezeigt wird, muss es gespiegelt werden. Wählen Sie dazu im Menü Bild->Wenden den Befehl Vertikal.

Das Bild muss gespiegelt werden
Das Bild muss gespiegelt werden

Siehe auch: Warum muss ich das Bootlogo spiegeln?

Schritt 4: Bild speichern bzw. exportieren

Wählen Sie aus dem Menü Datei den Befehl Exportieren.

Das Bitmap wird gespeichert
Das Bitmap wird gespeichert

Im Dialog Bild auf Diskette exportieren müssen Sie folgende Einstellungen durchführen:

Eigenschaft | Wert
Dateiname für B&R Windows CE 4.1/4.2 Geräte mit einer QVGA Auflösung | LogoQVGA.bmp
Dateiname für B&R Windows CE 4.1/4.2 Geräte mit einer Auflösung größer QVGA | LogoXRes.bmp
Dateityp | BMP - Windows Bitmap
Komprimierungstyp | Unkomprimiert

Bestätigen Sie den Dialog mit OK.

Sie können nun beide Dateien "LogoXRes.bmp" und "LogoQVGA.bmp" in das Hauptverzeichnis Ihrer CF - Karte kopieren. Der Bootloader wird in Abhängigkeit der verwendeten Auflösung das korrekte Bootlogo anzeigen.

Hinweis:
Die Farbe mit dem Index 30 wird für den Prozessbalken, der während des Bootvorganges sichtbar ist, verwendet.

<< Vorheriges Thema
Konfiguration

Startseite

Nächstes Thema >>
Bearbeiten der Registry


Bearbeiten der Registry

Allgemein

B&R Windows CE 4.1/4.2 bietet mehrere Methoden um die Registry zu editieren:

B&R Registry Editor

Der integrierte B&R Registry Editor ist die einfachste Methode um die Registry direkt am CE-Gerät zu bearbeiten.

So starten Sie den B&R Registry Editor

  • Wählen Sie Start > Accessories > B&R Registry Editor und doppelklicken Sie dann auf das B&R Registry Editor Icon.

B&R Registry Editor im Menü Accessories
B&R Registry Editor im Menü Accessories (Mobile Panel)

Der B&R Windows CE 4.1 Registry Editor "RegEdit"
B&R Registry Editor

Mehr Informationen finden Sie im Kapitel B&R Registry Editor.

Windows CE Remote Registry Editor

Wenn Sie eMbedded Visual C++ 4.0 verwenden, so ist der Windows CE Remote Registry Editor von Microsoft zu empfehlen.

So starten Sie den Windows CE Remote Registry Editor

  • Stellen Sie eine Verbindung zum CE - Gerät her (ActiveSync oder Manuelle TCPIP Verbindung).
  • Wählen Sie Tools > Remote Registry Editor im Menü von Microsoft eMbedded Visual C++.

Remote Registry Editor Link im Menü Tools von eVC4
Windows CE Remote Registry Editor Link im Menü Tools von eVC4

Microsoft Remote Registry Editor
Windows CE Remote Registry Editor

Mehr Informationen finden Sie im Kapitel Benötigte Software.

Konfigurationsdatei - Settings.reg

Eine weitere Methode ist die Verwendung der Konfigurationsdatei Settings.reg. Mehr Informationen finden Sie im Kapitel Settings.reg.

Hinweis:
Vergessen Sie nicht das Speichern der Registry!

Siehe auch:

  • Settings.reg
  • Benötigte Software
  • B&R Registry Editor

<< Vorheriges Thema
Erstellung eines Bootlogos

Startseite

Nächstes Thema >>
Kalibrierung des Touch


Kalibrierung des Touch

Allgemein

In der Standardkonfiguration/Auslieferungsstand startet B&R Windows CE 4.1/4.2 während des ersten Bootens die Touchkalibrierung. Somit wird eine korrekte Kalibrierung des Touchscreens sichergestellt. Sollte es trotzdem nötig sein den Touch zu rekalibrieren, so können Sie dies in der Systemsteuerung durchführen.

Hinweis:
Ist in der Konfigurationsdatei Start.dat das Keyword TOUCHCAL eingetragen, so prüft Windows CE bei jedem Booten ob der Touch bereits kalibriert wurde. Ist dies nicht der Fall, so wird die Kalibrierung gestartet.

So starten sie die Kalibrierung

Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf das Touchscreen Icon.

Touchscreen Applet in der Systemsteuerung
Touchscreen Applet in der Systemsteuerung

Das Applet zur Kalibrierung des Touchscreens wird geöffnet, bestätigen Sie dieses mit Return.

Das Touchscreenapplet
Das Touchscreenapplet

Folgen Sie nun den Anweisungen am Bildschirm.

Die Kalibrierung des Touch
Die Kalibrierung des Touch

Eine weitere Methode der Touchkalibrierung ist die Mode/Node Schalter auf 0 - 0 zu stellen (Aktivierung des Service Mode) und das Windows CE Gerät zu rebooten. Ist in der Konfigurationsdatei Start.dat das Keyword TOUCHCAL vorhanden so wird während des Bootens die Stellung der Mode/Node Schalter überprüft, wenn diese in Stellung 0 - 0 sind, wird die Kalibrierung gestartet.

Die Mode / Node Schalter am Power Panel
Die Mode/Node Schalter am Power Panel

Die Mode/Node Schalter am Mobile Panel
Die Mode/Node Schalter am Mobile Panel

Diese Funktion wird meistens dann verwendet, wenn der Touch nicht mehr bedienbar ist (Falsche Kalibrierung, Verlust der Kalibrationsdaten etc.).

Weitere Informationen zu den Mode/Node Schaltern finden Sie in den Anwenderhandbüchern Power Panel 100/200 und Mobile Panel, welche Sie von der B&R Homepage downloaden können.

Siehe auch:

  • Start.dat
  • Touchscreen Applet

<< Vorheriges Thema
Bearbeiten der Registry

Startseite

Nächstes Thema >>
Einstellen von Helligkeit und Kontrast


Einstellen von Helligkeit und Kontrast

Allgemein

B&R Windows CE 4.1/4.2 stellt während des ersten Bootens die werksseitig vorgegebenen Helligkeits - und Kontrastwerte (Factory Settings) für das verwendete Display ein. Da diese Werte nur Mittelwerte sind, müssen Sie die Helligkeit und Kontrast meistens an Ihre eigenen Anforderungen anpassen.

So können Sie Helligkeit und Kontrast verändern

  • Power Panel 100/200

    Je nach verwendeter Version des B&R Windows CE Images, finden Sie in der Systemsteuerung ein Applet mit dem Namen B&R Control Center oder Power Panel Control Center.

    So öffnen Sie das entsprechende Applet:

    Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie auf Power Panel Control Center oder,
    Wählen Sie Start > Settings > Control Panel und doppelklicken Sie auf B&R Control Center.

  • Mobile Panel 100/200

    Je nach verwendeter Version des B&R Windows CE Images, finden Sie in der Systemsteuerung ein Applet mit dem Namen B&R Control Center oder Mobile Panel Control Center.

    So öffnen Sie das entsprechende Applet:

    Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie auf Mobile Panel Control Center oder,
    Wählen Sie Start > Settings > Control Panel und doppelklicken Sie auf B&R Control Center.

Doppelklicken Sie das Power Panel Control Center Icon

Mobile Panel Control Center

  • Wechseln Sie auf die Registerkarte Display.

  • Deaktivieren Sie im Frame Brightness das Kontrollkästchen Auto.

  • Stellen Sie den Schieberegler auf den Helligkeitswert ein, mit dem das Display betrieben werden soll.

  • Deaktivieren Sie im Frame Contrast das Kontrollkästchen Auto.

Hinweis:
Der Kontrast kann nur bei einem passiven Display eingestellt werden. Bei einem aktiven Display (TFT) haben Kontraständerungen keine Auswirkung.
  • Stellen Sie den Schieberegler auf den Kontrastwert ein, mit dem das Display betrieben werden soll.

  • Beenden Sie den Dialog mit OK.

    Hinweis    :
    Wenn Sie Helligkeit und Kontrast derart parametriert haben, dass Sie am Display nichts mehr erkennen können, so besteht die Möglichkeit das Windows CE Gerät mit der Mode/Node Schalterstellung 0-0 (Service Mode) zu booten. In dieser Konfiguration verwendet B&R Windows CE 4.1/4.2 anstatt der von ihnen gewählten Einstellungen die Factory Settings.

<< Vorheriges Thema
Kalibrierung des Touch

Startseite

Nächstes Thema >>
Parametrierung der Tasten


Parametrierung der Tasten

Allgemein

Verfügt Ihr Windows CE-Gerät über Tasten (z.B. Mobile Panel 5MP181.0843-07), so können diesen Tasten beliebige Funktionen zugewiesen werden. Zur Parametrierung benötigen Sie lediglich das Programm B&R Key Editor, welches Sie von der B&R Homepage downloaden können.

So parametrieren Sie die Tasten eines Mobile Panels

  • Installieren Sie B&R Key Editor auf Ihrem Desktop PC.

  • Verbinden Sie das Mobile Panel per ActiveSync mit Ihrem Desktop PC.

  • Starten Sie B&R Key Editor und überprüfen Sie, ob das Programm eine Verbindung zum CE-Gerät herstellen konnte.

  • Erstellen Sie ein neues Projekt für Ihr Windows CE-Gerät. Wählen Sie als Zielsystem Mobile Panel 100,200.

  • Verwenden Sie ein Windows CE-Gerät, welches das Automation Device Interface unterstützt (B&R Windows CE 4.X V3.0 oder höher), so aktivieren Sie die Checkbox Automation Device Interface.

  • Wählen Sie nun das verwendete Windows CE-Gerät aus.

  • Ihr Projekt wurde erfolgreich erstellt!

  • Parametrieren Sie nun die gewünschten Tasten, wie es in der Dokumentation zu B&R Key Editor beschrieben ist.

  • Speichern und Erstellen Sie Ihr Projekt.

  • Zum Abschluss müssen Sie die erstellte Ausgabedatei (*.kcf oder *.cod) auf das Windows CE-Gerät übertragen.

    Dazu gibt es mehrere Methoden:

    1. Ist Ihr Windows CE Gerät per ActiveSync mit B&R Key Editor verbunden, so können Sie per Befehl Übertragen das Projekt installieren.
    2. Sie erstellen eine Installationsdiskette mit B&R Key Editor und booten Ihr Windows CE-Gerät damit.

Anforderungen

B&R Windows CE Version: V1.5 und höher

<< Vorheriges Thema
Einstellen von Helligkeit und Kontrast

Startseite

Nächstes Thema >>
Speichern der Registry


Speichern der Registry

Allgemein

Windows CE wurde für Geräte entworfen, die nie vom Netz getrennt werden (PDA's verwenden eine Batterie, um diese Anforderung zu erfüllen).
Somit konnte man sich das zeitraubende Speichern der Registry auf einen Massenspeicher sparen und die Registry ausschließlich im RAM verwalten.

Typische HMI Geräte wie z.B. das B&R Power Panel verfügen nicht über diese Batteriepufferung. Somit ist es manchmal notwendig, die Registry auf die Festplatte zu speichern, damit die Einstellungen nach einem Power-Down nicht verloren gehen.

Configuration Manager

Das Speichern der Registry erfolgt am B&R Windows CE 4.1/4.2 Gerät durch den Configuration Manager. Dieses Controlapplet finden Sie in der Systemsteuerung ihres CE-Gerätes.

So starten Sie den Configuration Manager

Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf das Configuration Manager Icon

Der "Configuration Manager" in der Systemsteuerung
Der Configuration Manager in der Systemsteuerung

So speichern Sie die Registry

  • Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf das Configuration Manager Icon.
  • Wählen Sie die Registerkarte Save und klicken Sie auf Save Settings.

    Speichern der Registry
    Speichern der Registry

Siehe auch:
  • Regsave
  • Configuration Manager

<< Vorheriges Thema
Parametrierung der Tasten

Startseite

Nächstes Thema >>
Manuelle Installation


Manuelle Installation

In diesem Abschnitt werden folgende Themen behandelt:

Manuelle Installation

Windows basierend

MS-DOS basierend

Erstes Booten von B&R Windows CE 4.1/4.2

<< Vorheriges Thema
Speichern der Registry

Startseite

Nächstes Thema >>
Windows basierend


Windows basierend

In diesem Abschnitt werden folgende Themen behandelt:

Windows basierend

Was sie für die Installation von B&R Windows CE 4.1/4.2 per Windows XP/2000 benötigen

B&R eMbedded OS Installer

<< Vorheriges Thema
Manuelle Installation

Startseite

Nächstes Thema >>
Was sie für die Installation von B&R Windows CE 4.1/4.2 per Windows XP/2000 benötigen


Was sie für die Installation von B&R Windows CE 4.1 per Windows XP/2000 benötigen

Was sie für die Installation von B&R Windows CE 4.1/4.2 per Windows XP/2000 benötigen

Benötigte Vorkenntnisse

Teil | Beschreibung
Verwendung von USB Geräten | Beachten Sie bitte, dass USB Laufwerke bevor diese abgesteckt werden, deaktiviert werden müssen (Siehe Windows Bedienungsanleitung).

Benötigte Hardware

Teil | Beschreibung
B&R BIOS Power Panel, B&R BIOS Mobile Panel | Automation Runtime Panels (Embedded Panels) werden nicht unterstützt!
RAM | Das Windows CE Gerät muss mindestenes 64 MByte RAM besitzen.
Compact Flash Karte | Die Compact Flash Karte muss mindestens 32 MByte groß sein.
USB Compact Flash Adapter | Mit diesem Adapter beschreiben Sie die Compact Flash Karte.

Benötigte Software

Teil | Beschreibung
Datei NK.BIN | B&R Windows CE 4.1/4.2 Image.
Datei BLDR | B&R Windows CE 4.1/4.2 Bootloader.
Datei LogoQVGA.bmp | Bootlogo für QVGA Geräte.
Datei LogoXRes.bmp | Bootlogo für Geräte mit einer Auflösung größer als QVGA.
Programm B&R eMbedded OS Installer | Windows XP/2000 Programm, welches B&R Windows CE 4.1/4.2 installiert. Dieses Programm können sie kostenlos von der B&R Homepage downloaden.
Windows 2000 oder Windows XP | Diese beiden Betriebssysteme werden von B&R eMbedded OS Installer unterstützt.

Hinweis:
NK.BIN, BLDR, LogoQVGA.bmp und LogoXRes.bmp können Sie nicht von der B&R Homepage downloaden.
Sie müssen diese Dateien von einer bereits funktionierenden B&R Windows CE 4.1/4.2 Installation sichern!

Siehe auch:

  • Erstellung eines Bootlogos

<< Vorheriges Thema
Windows basierend

Startseite

Nächstes Thema >>
B&R eMbedded OS Installer


B&R eMbedded OS Installer

Allgemein

Mit B&R eMbedded OS Installer ist es möglich B&R Windows CE 4.1/4.2 unter Windows XP oder Windows 2000 zu installieren. Dabei wird das Windows CE Image direkt auf die Compact Flash geschrieben. Weiters besteht die Möglichkeit, dass man mehrere Partitionen erstellt oder die Kundenapplikation schon während der Installation auf die Compact Flash kopiert.

B&R eMbedded OS Installer
B&R eMbedded OS Installer

Hinweis:
Erst ab Version V1.10 des B&R eMbedded OS Installers können Sie B&R Windows CE Images installieren, welche auf Microsoft Windows CE 4.2 basieren.

Eine detailierte Anleitung, wie Sie mit B&R eMbedded OS Installer B&R Windows CE 4.1/4.2 installieren, finden Sie in der Online Hilfe von B&R eMbedded OS Installer. Das Programm können Sie von der B&R Homepage downloaden (http://www.br-automation.com).

<< Vorheriges Thema
Was sie für die Installation von B&R Windows CE 4.1/4.2 per Windows XP/2000 benötigen

Startseite

Nächstes Thema >>
MS-DOS basierend


MS-DOS basierend

In diesem Abschnitt werden folgende Themen behandelt:

MS-DOS basierend

Was Sie für die Installation von B&R Windows CE 4.1/4.2 per MS-DOS benötigen

Erstellung der "B&R Windows CE 4.X Bootdiskette"

Partitionieren und Formatieren der CF - Karte

Installation von Bootsektor und Bootloader

Kopieren der Imagedateien

<< Vorheriges Thema
B&R eMbedded OS Installer

Startseite

Nächstes Thema >>
Was Sie für die Installation von B&R Windows CE 4.1/4.2 per MS-DOS benötigen


Was Sie für die Installation von B&R Windows CE 4.1 per MS-DOS benötigen

Was Sie für die Installation von B&R Windows CE 4.1/4.2 per MS-DOS benötigen

Benötigte Vorkenntnisse

Teil | Beschreibung
Verwendung von FDISK.EXE | Sie müssen mit dem Programm FDISK.EXE und den Begriffen Partition, FAT und "Partition aktiv schalten" vertraut sein.
Verwendung von FORMAT.COM | Sie müssen mit dem Programm FORMAT.COM vertraut sein.
Bedienung des BIOS | Sie müssen das BIOS ihres Gerätes bedienen können.
BIOS Update | Sie müssen in der Lage sein ein Update des BIOS durchzuführen.
Verwendung von USB Geräten | Beachten Sie bitte, dass USB Laufwerke bevor diese abgesteckt werden, deaktiviert sein müssen (Siehe Windows Bedienungsanleitung).

Benötigte Hardware

Teil | Beschreibung
B&R BIOS Power Panel, B&R BIOS Mobile Panel | Automation Runtime Panels (Embedded Panels) werden nicht unterstützt.
RAM | Das Panel muss mindestenes 64 MByte RAM besitzen.
Compact Flash Karte | Die Compact Flash Karte muss mindestens 32 MByte groß sein.
USB Compact Flash Adapter | Mit diesem Adapter beschreiben Sie die Compact Flash Karte.

Benötigte Software

Teil | Beschreibung
Datei NK.BIN | B&R Windows CE 4.1/4.2 Image.
Datei BLDR | B&R Windows CE 4.1/4.2 Bootloader.
Datei LogoQVGA.bmp | Bootlogo für QVGA Geräte.
Datei LogoXRes.bmp | Bootlogo für Geräte mit einer Auflösung größer als QVGA.
B&R Windows CE 4.X Utilities | Eine Sammlung von nützlichen Programmen zur Konfiguration und Administration von B&R Windows CE 4.1/4.2. Sie können dieses Programmpaket von der B&R Homepage downloaden.

Hinweis:
NK.BIN, BLDR, LogoQVGA.bmp und LogoXRes.bmp können Sie nicht von der B&R Homepage downloaden.
Sie müssen diese Dateien von einer bereits funktionierenden B&R Windows CE 4.1/4.2 Installation sichern!

Siehe auch:

  • B&R Windows CE 4.1 Utilities
  • Erstellung der B&R Windows CE 4.X Bootdiskette
  • Erstellung eines Bootlogos

<< Vorheriges Thema
MS-DOS basierend

Startseite

Nächstes Thema >>
Erstellung der "B&R Windows CE 4.X Bootdiskette"


Erstellung der "B&R Windows CE 4.1 Bootdiskette"

Erstellung der "B&R Windows CE 4.X Bootdiskette"

Allgemein

Für die Erstellung der B&R Windows CE 4.X Bootdiskette benötigen Sie folgende Komponenten:

  • B&R Windows CE 4.X Utilities

    Dieses Softwarepaket können Sie von der B&R Homepage downloaden (Siehe B&R Windows CE 4.X Utilities).

  • Desktop PC mit Betriebssystem Windows 98 oder MS-DOS

    In diesem Beispiel wird Windows 98 verwendet.

    Hinweis    :
    Das Power Panel kann MS-DOS Bootdisketten (welche mit MS-DOS 6.22 erstellt worden sind) erst ab BIOS - Version 1.02 lesen!

  • Eine 1,44MByte Diskette

Erstellung einer MS-DOS Bootdiskette mit Windows 98

  1. Starten Sie die MS-DOS Eingabeaufforderung von Windows 98.

    MS-DOS Eingabeaufforderung von Windows 98
    MS-DOS Eingabeaufforderung von Windows 98

  2. Legen Sie ihre Diskette in Laufwerk a: ein.

  3. Erstellen Sie die MS-DOS Bootdiskette mit dem Befehl sys a:.

    Mit sys a: wird eine Bootdiskette erstellt
    Mit sys a: wird eine Bootdiskette erstellt

  4. Anschließend kopieren Sie die Tools Format.com, Fdisk.exe und Attrib.exe in die Root der soeben erstellten Diskette.

    Hinweis    :
    Diese Programme finden sie im Verzeichnis C:\Windows\Command ihrer Windows 98 Installation.

Kopieren von Programmen aus den B&R Windows CE 4.X Utilities

Kopieren Sie die Files bldr, bsect.img, mkdisk.bat und cesys.exe, aus den B&R Windows CE 4.X Utilities, in die Root der Diskette.

Hinweis:
Verwenden Sie dazu jenen Dateien, welche speziell für die verwendete Microsoft Windows CE Version erstellt worden sind (4.1 oder 4.2).

Beschriften Sie die Diskette mit "B&R Windows CE 4.X Bootdiskette"

Siehe auch:

  • B&R Windows CE 4.X Utilities

<< Vorheriges Thema
Was Sie für die Installation von B&R Windows CE 4.1/4.2 per MS-DOS benötigen

Startseite

Nächstes Thema >>
Partitionieren und Formatieren der CF - Karte


Partitionieren und Formatieren der CF - Karte

Am Power Panel / Mobile Panel

Verbinden Sie nun das USB Diskettenlaufwerk mit USB Port 1 und die USB Tastatur mit USB Port 2, des Power Panels. Verwenden Sie ein Mobile Panel, so müssen Sie die USB-Geräte per USB-Hub verbinden!

Danach stecken Sie die CF - Karte in den CF-Slot des Panels. Booten Sie nun ihr CE-Gerät, mit der erstellten B&R Windows CE 4.X Bootdiskette (muss sich im Diskettenlaufwerk befinden) und führen Sie folgende Schritte durch:

  • Starten Sie fdisk.exe und löschen Sie alle existierenden Partitionen auf der CF - Karte.

  • Gerät neu booten.

  • Starten Sie fdisk.exe und erstellen Sie eine primäre Partition auf der CF - Karte.

  • Gerät neu booten.

  • Starten Sie fdisk.exe und schalten Sie die primäre Partition aktiv.

  • Geräte neu booten.

  • Formatieren Sie die CF - Karte und geben Sie der Partition einen beliebigen Namen.

  • Gerät neu booten.

Am IPC5X00

Stecken Sie die CF - Karte in den CF-Kartenadapter und booten Sie den IPC mit Ihrer B&R Windows CE 4.X Bootdiskette. Führen Sie nun folgende Arbeiten aus:

  • Stellen Sie im BIOS für die CF - Karte den Modus CHS ein.

    Hinweis    :
    Bei älteren IPC5X00 BIOS Versionen wird dieser Modus mit "Standard" bezeichnet

  • Gerät neu booten.

  • Überprüfen Sie beim Booten ob im BIOS Summary Screen der verwendete Modus der CF Karte gleich CHS ist.

  • Starten Sie fdisk.exe und löschen Sie alle existierenden Partitionen auf der CF - Karte.

  • Gerät neu booten.

  • Starten Sie fdisk.exe und erstellen Sie eine primäre Partition auf der CF - Karte.

  • Gerät neu booten.

  • Starten Sie fdisk.exe und schalten Sie die primäre Partition aktiv.

  • Geräte neu booten.

  • Formatieren Sie die CF - Karte und geben Sie der Partition einen beliebigen Namen.

  • Gerät neu booten.

Tips & Tricks

    Problem | Lösung
Gerät bleibt mit der Meldung "No boot device present. Halting" stehen. | Überprüfen Sie, ob Sie die CF - Karte eingesetzt haben. Überprüfen Sie, ob das Diskettenlaufwerk angeschlossen wurde. Überprüfen Sie, ob sie die Diskette "B&R Windows CE 4.X Bootdiskette" eingelegt haben. Überprüfen Sie die "Boot Order" im BIOS
Das B&R CE-Gerät bootet nicht obwohl alle Geräte korrekt installiert wurden | Vertauschen Sie die beiden USB Geräte (Tastatur, Diskettenlaufwerk) an den USB Slots und starten Sie das Gerät neu.
Die USB Tastatur am B&R CE-Gerät funktioniert nicht | Vertauschen Sie die beiden USB Geräte (Tastatur, Diskettenlaufwerk) an den USB Slots und starten Sie das Gerät neu.

Siehe auch:

  • Erstellung der "B&R Windows CE 4.X Bootdiskette"

<< Vorheriges Thema
Erstellung der "B&R Windows CE 4.X Bootdiskette"

Startseite

Nächstes Thema >>
Installation von Bootsektor und Bootloader


Installation von Bootsektor und Bootloader

Installation

Nachdem Sie die CF - Karte partitioniert und formatiert haben, booten Sie das Gerät mit der B&R Windows CE 4.1Bootdiskette neu.
Danach geben Sie folgendes Kommando am MS-DOS Kommandoprompt ein:

mkdisk c:

Dieser Befehl startet die Batchdatei mkdisk.bat. Diese Batchdatei installiert zuerst den Bootsektor (Bsect.img) und kopiert anschließend eine einfache Version des Bootloaders (BLDR) auf ihre CF - Karte.

Hinweis:
Stellen Sie sicher, dass die B&R Windows CE 4.X Bootdiskette nicht schreibgeschützt ist.
Stellen Sie sicher, dass die Dateiattribute der Dateien BLDR und Bsect.img nicht auf Read-Only gesetzt sind.

Hinweis:
Wenn Sie diesen Schritt auf einem IPC5X00 ausführen, so stellen Sie bitte sicher, dass die CF-Karte im CHS Modus angesprochen wird.

Test ob der Bootloader korrekt installiert worden ist

Hinweis:
Wurde die CF-Karte nicht im Power Panel/Mobile Panel konfiguriert, so stecken Sie diese nun in das Power Panel/Mobile Panel.

Starten Sie das PowerPanel bzw. Mobile Panel.

Wurde der Bootloader erfolgreich installiert, so löscht das CE-Gerät nach der Anzeige des BIOS Summary Screen das Display und bleibt stehen (Display ist dunkel). Dies ist das korrekte Verhalten, da der Bootloader (BLDR) das B&R Windows CE 4.1 Image (NK.BIN) und die Bootlogos (LogoQVGA.bmp, LogoXRes.bmp) nicht finden kann!

Wurde der Bootloader nicht korrekt installiert so erscheint der Schriftzug Can not load Bootloader.

Can not load Bootloader

Can not load Bootloader tritt meistens dann auf, wenn:

  • Während der Phase Partitionieren und Formatieren nicht neugestartet wurde (Siehe Kapitel Partitionieren und formatieren).
  • Die CF-Karte nicht am Power Panel/Mobile Panel formatiert und partitioniert wurde und deshalb nicht im CHS Modus betrieben wird.
  • Wenn eine der Dateien BLDR und Bsect.img schreibgeschützt sind.

Siehe auch:

  • B&R Windows CE 4.X Utilities
  • Erstellung der Windows CE Bootdiskette
  • Partitionieren und formatieren

<< Vorheriges Thema
Partitionieren und Formatieren der CF - Karte

Startseite

Nächstes Thema >>
Kopieren der Imagedateien


Kopieren der Imagedateien

Schalten Sie das CE-Gerät aus und entfernen Sie die CF - Karte. Diese Karte müssen Sie nun in ein Lesegerät stecken, welches an einen PC mit Zugang zu den Betriebssystemfiles (NK.BIN, BLDR, LogoQVGA.bmp, LogoXRes.bmp) von B&R Windows CE 4.1/4.2 angeschlossen ist.

Hinweis:
Sie können als Lesegerät einen der IDE /CF - Karten Adapter (z.B. Silicon Disk Adapter 5A002.03, 5A5002.02) von B&R , oder ein handelsübliches USB CF-Kartenlesegerät verwenden.

Kopieren Sie nun die Dateien des B&R Windows CE 4.1/4.2 Images in die Root der CF - Karte.

Folgende Dateien müssen kopiert werden:

  • NK.BIN - Image
  • BLDR - Bootloader
  • LogoQVGA.bmp - Bootlogo für QVGA CE-Geräte
  • LogoXRes.bmp - Bootlogo für CE-Geräte mit einer Auflösung größer QVGA

Eine einfache Version des Bootloaders BLDR ist bereits vorhanden, diese müssen Sie überschreiben!

Hinweis:
Bitte achten Sie beim Kopieren von Files auf Wechselmedien darauf, das Sie das Wechselmedium vor dem Entfernen deaktivieren! Ansonsten kann es passieren, das die Files nicht korrekt kopiert werden!

Doppelklicken sie auf dieses Icon im Systemtray um Wechselmeiden zu deaktivieren
Doppelklicken Sie auf dieses Icon im Systemtray um das Wechselmedium zu deaktivieren

Markieren sie zuerst das gewünschte Laufwerk und bestätigen sie mit "Deaktivieren"
Markieren Sie zuerst das gewünschte Laufwerk und bestätigen Sie mit Deaktivieren

Siehe auch:

  • B&R Windows CE 4.X Utilities

<< Vorheriges Thema
Installation von Bootsektor und Bootloader

Startseite

Nächstes Thema >>
Erstes Booten von B&R Windows CE 4.1/4.2


Erstes Booten von Windows CE 4.1

Erstes Booten von B&R Windows CE 4.1/4.2

Nach dem erfolgreichen Erstellen der Compact Flash (Per Windows CE 4.X Bootdiskette oder B&R eMbedded OS Installer), stecken Sie die Compact Flash Karte in das Windows CE Gerät und schalten dieses ein.

Nach dem BIOS Summary Screen erscheint das B&R Windows CE 4.1/4.2 Bootlogo:

Windows CE 4.1 Bootlogo
Standard B&R Windows CE 4.1/4.2 Bootlogo

Während der Bootloader (BLDR) das Image (NK.BIN) in das RAM kopiert, wandert ein Prozessbalken von links nach rechts unten.

Prozessbalken
Prozessbalken

Wurde das Image erfolgreich ins RAM kopiert, so wird dieses aktiviert.

Beim ersten Booten werden zusätzlich zum normalen Bootvorgang folgende Funktionen ausgeführt:

  1. Erstellen der Registry

    Während der Bildschirm dunkel ist, wird die Registry erstellt. Dabei werden die einzelnen Hives der Registry generiert und in einen neu erstellen Ordner Dokumente und Einstellungen (deutsches Image) in die Root der Compact Flash kopiert.

  2. Automatische Erkennung der Bildschirmauflösung

  3. Einstellen des SIP (nur am Power Panel)

  4. Starten der Touchscreenkalibrierung (Wenn dies per Start.dat konfiguriert wurde)

Hinweis:
Durch diese zusätzlichen Funktionen, welche nur beim ersten Booten durchgeführt werden, dauert der erste Bootvorgang etwas länger!

Wird das Image auf einem Windows CE - Gerät mit Touchcontroller gestartet und in der Start.dat ist das Keyword TOUCHCAL vorhanden, so erscheint die Kalibrierung des Touchscreens:

Die Kalibrierungssoftware für den Touch startet automatisch
Die Kalibrierungssoftware für den Touch startet automatisch

Hinweis:

  • Erfolgt innerhalb von 15 Sekunden keine Touchberührung, so beendet sich die Kalibrierung automatisch (Defaulteinstellung).
  • Die Touchkalibrierung wird bei jedem Bootvorgang gestartet, solange der Touch nicht einmal korrekt kalibriert wurde.

Nach der erfolgten Kalibrierung erscheint der Standarddesktop von B&R Windows CE 4.1/4.2.

      Standard CE Desktop
      Standard B&R Windows CE 4.1/4.2 Desktop

Siehe auch:

  • Kalibierung des Touch
  • Configuration
  • Calibration

<< Vorheriges Thema
Kopieren der Imagedateien

Startseite

Nächstes Thema >>
Duplizieren


Klonen eines Images

In diesem Abschnitt werden folgende Themen behandelt:

Duplizieren

Erstellen eines Images

Wiederherstellen eines Images

<< Vorheriges Thema
Erstes Booten von B&R Windows CE 4.1/4.2

Startseite

Nächstes Thema >>
Erstellen eines Images


Erstellen eines Images

Allgemein

In diesem Kapitel erfahren Sie, welche Punkte Sie bei der Erstellung eines Images von B&R Windows CE 4.1/4.2 beachten müssen.

Komponenten

Mit den Komponenten aus der folgenden Tabelle wurden Images erfolgreich erstellt.

    Komponente | Beschreibung
B&R IPC 5600C | Zur Erstellung von Images wird der IPC5600C verwendet. Dieser verfügt über 2 IDE Slots, in welche man CF und Festplatte stecken kann.
CF - Karte mit installiertem B&R Windows CE 4.1/4.2 | Die zu klonende CF - Karte mit funktionierendem B&R Windows CE 4.1/4.2.
Silikon Disk Adapter | Mit diesem Adapter kann man eine CF am IDE Bus betreiben.
PowerQuest Drive Image 4.0 (PQDI) | Gut funktionierende Software zum Erstellen von Images. Dieses Programm können Sie nicht bei B&R bestellen, Sie müssen dieses direkt beim Hersteller erwerben.
Festplatte | Dient zur Aufnahme des neuen Images.

CF an IDE

PQDI kann nur Images von IDE Devices erstellen. Das heißt, Sie müssen ihre CF per CF Adapter (Silicon Disk Adapter CF 1Slot, 5A5002.03) an den IDE Bus des IPC anschließen. Stecken Sie somit die CF in den Adapter und diesen wiederum, in eine der beiden IDE Schnittstellen.

Harddisk, CF und CF-Adapter
Festplatte, CF und CF-Adapter

In die zweite IDE Schnittstelle stecken Sie die Festplatte. Die Reihenfolge (Master/Slave) ist ohne Bedeutung.

IDE Schnittstellen des IPC5600
IDE Schnittstellen des IPC5600

CHS Modus für CF

Die B&R Power Panels und die B&R Mobile Panels können nur CF lesen, die im CHS Modus partitioniert und formatiert wurden. Damit der IPC5600C den CHS Modus verwendet, muss dieser im BIOS für das entsprechende IDE Device festgelegt werden. Öffnen Sie im BIOS die Setuppage Standard CMOS Features und stellen Sie den Modus auf Normal (bzw. CHS).

Rebooten Sie den IPC und beobachten Sie während dieses Vorganges den BIOS Summary Screen. Für die CF muss nun der verwendete Modus auf Normal (bzw. CHS) eingestellt sein.

Hinweis:
Mehr Informationen zu diesem Thema finden Sie im Anwenderhandbuch Provit 5000 Anwenderhandbuch MAPRV5000-0.
Dieses können Sie von der B&R Homepage downloaden.

Power Quest Drive Image (PQDI)

Booten Sie den IPC5600C mit der ersten Diskette von PQDI. Nach dem Booten wählen Sie den Menüpunkt C reate Image um den Vorgang der Erstellung zu beginnen. Da Sie die Standardeinstellungen verwenden können, müssen Sie nur noch den Anweisungen am Bildschirm folgen, um das Image erfolgreich herzustellen.

Screenshot von Power Quest Drive Image
Screenshot von PowerQuest Drive Image

Siehe auch:

  • Wiederherstellen eines Images
  • Webpage der Firma PowerQuest - Hersteller von PQDI
  • Provit 5000 Anwenderhandbuch - Download von der B&R Homepage

<< Vorheriges Thema
Duplizieren

Startseite

Nächstes Thema >>
Wiederherstellen eines Images


Wiederherstellen eines Images

Allgemein

In diesem Kapitel erfahren Sie, welche Punkte Sie beim Wiederherstellen eines Images von B&R Windows CE 4.1/4.2 beachten müssen.

Komponenten

Mit den Komponenten aus der folgenden Tabelle wurden Images erfolgreich wiederhergestellt.

    Komponente | Beschreibung
B&R IPC 5600C | Zum Wiederherstellen von Images wird der IPC5600C verwendet. Dieser verfügt über 2 IDE Slots, in welche man CF und Festplatte stecken kann.
Silikon Disk Adapter | Mit diesem Apdapter kann man eine CF am IDE Bus betreiben.
PowerQuest Drive Image 4.0 (PQDI) | Gut funktionierende Software zum Erstellen/Wiederherstellen von Images. Dieses Programm können Sie nicht bei B&R bestellen, Sie müssen dieses direkt beim Hersteller erwerben.
Festplatte | Dient zur Aufnahme des neuen Images.

CF an IDE

PQDI kann nur Images auf IDE Devices wiederherstellen. Das heisst, Sie müssen ihre leere CF per CF Adapter (Silicon Disk Adapter CF 1Slot, 5A5002.03) an den IDE Bus des IPC anschließen. Stecken Sie somit die CF in den Adapter und diesen wiederum, in eine der beiden IDE Schnittstellen.

Harddisk, CF und CF-Adapter
Festplatte, CF und CF-Adapter

In die zweite IDE Schnittstelle stecken Sie die Festplatte welche das Image (*.pqi Datei) enthält. Die Reihenfolge (Master/Slave) ist ohne Bedeutung.

IDE Schnittstellen des IPC5600
IDE Schnittstellen des IPC5600

CHS Modus für CF

Die B&R Power Panels und die B&R Mobile Panels können nur CF lesen, welcheim CHS Modus partitioniert und formatiert wurden. Damit der IPC5600C den CHS Modus verwendet, muss dieser im BIOS für das entsprechende IDE Device festgelegt werden. Öffnen Sie im BIOS die Setuppage Standard CMOS Features und stellen Sie den Modus auf Normal (bzw. CHS).

Rebooten Sie den IPC und beobachten Sie während dieses Vorganges den BIOS Summary Screen. Für die CF muss nun der verwendete Modus auf Normal(bzw. CHS) eingestellt sein.

Hinweis:
Stellen Sie sicher, dass Ihr verwendetes Image bereits im CHS Modus erstellt worden ist!
Siehe Kapitel Erstellen eines Images.

Hinweis:
Mehr Informationen zu diesem Thema finden Sie im Anwenderhandbuch Provit 5000 Anwenderhandbuch MAPRV5000-0.
Dieses können Sie von der B&R Homepage downloaden.

Power Quest Drive Image (PQDI)

Booten Sie den IPC5600C mit der ersten Diskette von PQDI. Nach dem Booten wählen Sie den Menüpunkt R estore Image um den Vorgang der Wiederherstellung zu beginnen. Da Sie die Standardeinstellungen verwenden können, müssen Sie nur noch den Anweisungen am Bildschirm folgen, um das Image erfolgreich auf die CF zu kopieren.

Screenshot von Power Quest Drive Image
Screenshot von PowerQuest Drive Image

Siehe auch:

  • Erstellen eines Images
  • Webpage der Firma PowerQuest - Hersteller von PQDI
  • Provit 5000 Anwenderhandbuch - Download von der B&R Homepage

<< Vorheriges Thema
Erstellen eines Images

Startseite

Nächstes Thema >>
Softwareentwicklung


Softwareentwicklung

In diesem Abschnitt werden folgende Themen behandelt:

Softwareentwicklung

.NET Compact Framework (Managed Code Development)

eMbedded Visual C++ 4.0 (Native Code Development)

<< Vorheriges Thema
Wiederherstellen eines Images

Startseite

Nächstes Thema >>
.NET Compact Framework (Managed Code Development)


.NET Compact Framework

In diesem Abschnitt werden folgende Themen behandelt:

.NET Compact Framework (Managed Code Development)

Benötigte Software

"Hello World"

<< Vorheriges Thema
Softwareentwicklung

Startseite

Nächstes Thema >>
Benötigte Software


Benötigte Software .NET Compactframework

Benötigte Software

Zur Entwicklung einer .NET Applikation, für das B&R Windows CE 4.1/4.2 Gerät, benötigen Sie folgende Softwarekomponenten:

B&R Windows CE 4.1/4.2 - V1.1 oder höher

Ab Version V1.1 ist das .NET Compact Framework im Image enthalten. Frühere Versionen von B&R Windows CE 4.1/4.2 unterstützen .NET nicht!
(Siehe dazu das Kapitel "Komponenten/Funktionen/Treiber"). Eine neue Version von B&R Windows CE 4.1/4.2 erhalten Sie von ihrem zuständigen B&R Vertriebsmann.

Visual Studio.Net 2003

Microsoft Visual Studio.Net 2003 bekommen Sie kostenpflichtig bei Microsoft.

Hinweis:
Erst die Version Visual Studio.Net 2003 Final Beta unterstützt die Entwicklung von Smart Device Projekten ausreichend.

Windows CE Utilities for Visual Studio .NET 2003 Add-on Pack

Microsoft Visual Studio.NET 2003 hat Probleme bei der Verbindungsherstellung zu Geräten die nicht Pocket PC konform sind. Durch dieses Add-on Pack werden diese Probleme behoben. Sie können dieses Softwarepaket von der Microsoft Homepage kostenlos downloaden.

Microsoft ActiveSync

Wollen Sie ihr Programm auf das CE-Gerät übertragen, so benötigen Sie die Software Microsoft ActiveSync. Mehr Informationen zum Thema Installation und Aufnehmen einer Verbindung finden Sie im Kapitel "ActiveSync"

SDK

Bitte beachten Sie, dass Sie das korrekte SDK für ihr installiertes Image verwenden:

    Version des Windows CE Images | Version des SDK's | Dateiname des SDK's
V1.0 | - | -
V1.1 | V1.1 | X86BR410_NET_SDK.msi
V1.2 | V1.2 | X86BR410_NET_V12_SDK.msi
V1.3 | V1.3 | X86BR410_NET_V13_SDK.msi
V1.4 | V1.4 | X86BR410_NET_V14_SDK.msi
V1.5 | V1.5 | X86BR410_NET_V15_SDK.msi
V2.0 | V2.0 | BR Power Panel (100,200) CE4.20 V2.0 SDK.msi, BR Mobile Panel (100,200) CE4.20 V2.0 SDK.msi
V2.1 | V2.1 | BR Power Panel (100,200) CE4.20 V2.1 SDK.msi, BR Mobile Panel (100,200) CE4.20 V2.1 SDK.msi
V3.0 | V3.0 | BR Power Panel (100,200) CE4.20 V3.0 SDK.msi, BR Mobile Panel (100,200) CE4.20 V3.0 SDK.msi

Hinweis:

Ab Version V2.0 des SDKs ist kein Emulator mehr enthalten.

Die Version eines bereits installierten SDK's, können Sie mit Hilfe des Applet Software in der Systemsteuerung ablesen:

Die Versionsnummer eine installierten B&R (.NET) SDK's
Die Versionsnummer eine installierten B&R (.NET) SDK's

Bevor Sie ein neues SDK installieren, deinstallieren Sie bitte ein bereits existierendes SDK.

Siehe auch:

  • Komponenten/Funktionen/Treiber
  • ActiveSync

<< Vorheriges Thema
.NET Compact Framework (Managed Code Development)

Startseite

Nächstes Thema >>
"Hello World"


"Hello World" in .NET

"Hello World"

Allgemein

In diesem Beispiel lernen sie, wie man eine einfache Visual Basic.Net Applikation für B&R Windows CE 4.1/4.2 erstellt.

Welche Hard - und Softwarekomponenten sie für dieses Beispiel benötigen, finden sie in Kapitel "Benötigte Software".

Schritt 1: ActiveSync Verbindung aufbauen

Für dieses Beispiel verwenden wir als Transportprovider ActiveSync.

Wie sie diese Verbindung erfolgreich herstellen, erfahren sie in Kapitel "ActiveSync".

Schritt 2: Erstellen eines neuen Projektes

Um ein neues Projekt mit Visual Studio.Net zu erstellen, wählen sie bitte den Befehl New->Project aus dem Menü File.

Ein neues Projekt mit Visual Studio.Net erzeugen
Ein neues Projekt mit Visual Studio.Net erzeugen

Im nächsten Dialog wählen sie aus den Visual Basic Projekten bitte den Typ Smart Device Application aus. Geben sie ihrem Projekt einen Namen (in unserem Beispiel wird "EinTest" verwendet) und wählen sie einen Ordner aus.

Typ, Name und Verzeichnis werden festgelegt
Typ, Name und Verzeichnis werden festgelegt

Nun definieren sie ihre Platform - Windows CE. Als Projekttyp verwenden sie bitte Windows Application.

Die Platform und der Projekttyp werden festgelegt
Die Platform und der Projekttyp werden festgelegt

Schritt 2: Platzieren und konfigurieren eines Labels

Nun platzieren sie ein Labelcontrol auf der soeben erstellten Form. Doppelklicken sie dazu das Label Element in der Toolbox.

Ein Label platzieren
Ein Label platzieren

Das neu erstellte Label
Das neu erstellte Label

Nun weisen sie der Eigenschaft Caption des Label Controls den Wert Hello World zu.

Der Eigenschaften Dialog des Label Controls
Der Eigenschaften Dialog des Label Controls

Schritt 3: Verbindung mit dem Target aufnehmen

Hinweis:
Dieser Schritt setzt voraus, dass sie die Windows CE Utilities for Visual Studio .NET 2003 Add-on Pack installiert haben. Siehe Benötigte Software.

Sie müssen nun Visual Studio.Net 2003 auf das Compact Framework für x86 CPUs umstellen. Öffnen sie dazu den Dialog Select Windows CE Device CPU aus dem Menü Tools. Wählen sie in der Dropdown Box den CPU Typ X86 aus und bestätigen sie dies mit Configure.

Der Dialog Select Windows CE CPU
Der Dialog Select Windows CE CPU

Nach dem Ändern der Device architecture müssen sie die Registry am B&R CE-Gerät speichern. Nun können sie durch einen Klick auf Connect to Device eine Verbindung mit dem B&R CE-Gerät herstellen.

Connect to Device
Connect to Device

Hinweis:
Das erste Verbinden kann mehrere Minuten dauern!

Wurde die Verbindung erfolgreich aufgebaut, so erhalten sie in der Statusbar die Meldung Device Connected.

Das B&R CE4.1 Gerät wurde erfolgreich verbunden.
Das B&R CE4.1 Gerät wurde erfolgreich verbunden.

Schritt 4: Erstellen des Deployments und übertragen auf das Target

Nun müssen sie das Deployment erstellen. Dies geschieht durch den Klick auf das Schranksymbol in der Taskleiste.

Erstellen des Deployments
Erstellen des Deployments

Wurde das Deployment erstellt, so können sie das Projekt mit "F5" auf das B&R Windows CE 4.1/4.2 Gerät übertragen. Als Deploymentarget müssen sie noch das Windows CE.NET Device auswählen.

Wählen sie ihr Target aus!
Wählen sie ihr Target aus!

Fertig!

Hello World!
Hello World!

Siehe auch:

  • Benötigte Software
  • ActiveSync

<< Vorheriges Thema
Benötigte Software

Startseite

Nächstes Thema >>
eMbedded Visual C++ 4.0 (Native Code Development)


eMbedded Visual C++ 4.0 (Native Code Development)

In diesem Abschnitt werden folgende Themen behandelt:

eMbedded Visual C++ 4.0 (Native Code Development)

Benötigte Software

"Hello World"

<< Vorheriges Thema
"Hello World"

Startseite

Nächstes Thema >>
Benötigte Software


Benötigte Software (Native Code Development)

Benötigte Software

Desktop Betriebssystem

Um Programme für B&R Windows CE 4.1/4.2 schreiben zu können, müssen Sie ein Desktopbetriebssystem wie Windows 2000 oder Windows XP installiert haben.

Compiler

Als Compiler steht eMbedded Visual C++ 4.0 zur Verfügung. Dieses Softwarepaket enthält alle wichtigen Tools, die Sie zur Entwicklung von C++ Programmen für B&R Windows CE 4.1/4.2 benötigen. Dazu zählen die Remotetools, wie Remote RegistryEditor, Remote ProcessViewer oder auch Remote ZoomIn, eine IDE wie Sie von Visual Studio 6.0 bekannt ist und eine Anbindung an den Platform Manager.

eMbedded Visual C++ 4.0 können Sie gratis von der Homepage www.microsoft.com downloaden.

Hinweis:
Stellen Sie sicher, dass Sie das aktuellste Service Pack für Microsoft eMbedded Visual C++ 4.0 installiert haben. Damit Sie z.B. für Microsoft Windows CE 4.2 basierende Images Software entwickeln können, muss mindestens Service Pack 2 von Microsoft eMbedded Visual C++ 4.0 installiert sein!

Platform Manager

Der Platform Manager stellt die Verbindung zwischen den Programmiertools und dem Windows CE Target her. Dieser verwendet dazu Verbindungen wie ActiveSync oder auch die Manuelle TCPIP Verbindung. Der Platform Manager wird zusammen mit eMbedded Visual C++ 4.0 installiert.

SDK

Bitte beachten Sie, dass Sie das korrekte SDK für ihr installiertes Image verwenden:

    Version des Windows CE Images | Version des SDK's | Dateiname des SDK's
V1.0 | V1.0 | X86BR410_SDK.msi
V1.1 | V1.1 | X86BR410_EVC4_SDK.msi
V1.2 | V1.2 | X86BR410_EVC4_V12_SDK.msi
V1.3 | V1.3 | X86BR410_EVC4_V13_SDK.msi
V1.4 | V1.4 | X86BR410_EVC4_V14_SDK.msi
V1.5 | V1.5 | X86BR410_EVC4_V15_SDK.msi
V2.0 | V2.0 | BR Power Panel (100,200) CE4.20 V2.0 SDK.msi, BR Mobile Panel (100,200) CE4.20 V2.0 SDK.msi
V2.1 | V2.1 | BR Power Panel (100,200) CE4.20 V2.1 SDK.msi, BR Mobile Panel (100,200) CE4.20 V2.1 SDK.msi
V3.0 | V3.0 | BR Power Panel (100,200) CE4.20 V3.0 SDK.msi, BR Mobile Panel (100,200) CE4.20 V3.0 SDK.msi

    Hinweis    :

    • Ab Version V2.0 des SDKs ist kein Emulator mehr enthalten.
    • Für auf Microsoft Windows CE 4.2 basierende Images, wird nur mehr ein SDK für die .Net und die eVC4 Entwicklung benötigt.

Die Version eines bereits installierten SDK's, können Sie mit Hilfe des Applet Software in der Systemsteuerung ablesen:

Die Versionsnummer eine installierten B&R (eMbedded Visual C++) SDK's
Die Versionsnummer eine installierten B&R (eMbedded Visual C++) SDK's

Bevor Sie ein neues SDK installieren, deinstallieren Sie bitte ein bereits existierendes SDK.

ActiveSync

Wollen Sie ihr Programm per ActiveSync auf das CE-Gerät übertragen, so benötigen Sie auch die Software ActiveSync. Mehr Informationen zum Thema Installation und Aufnehmen einer Verbindung finden Sie im Kapitel "ActiveSync"

Siehe auch:

  • FAQ - Wo ist eMbedded Visual Basic?
  • ActiveSync

<< Vorheriges Thema
eMbedded Visual C++ 4.0 (Native Code Development)

Startseite

Nächstes Thema >>
"Hello World"


"Hello World" (Native Code Development)

"Hello World"

Allgemein

In diesem Beispiel lernen Sie wie man eine einfache eMbedded Visual C++ 4.0 Applikation für B&R Windows CE 4.1/4.2 erstellt.

Welche Hard - und Softwarekomponenten Sie für dieses Beispiel benötigen finden Sie in Kapitel "Benötigte Software".

Schritt 1: ActiveSync Verbindung aufbauen

Für dieses Beispiel verwenden wir als Transportprovider ActiveSync.

Wie Sie diese Verbindung erfolgreich herstellen, erfahren Sie in Kapitel "ActiveSync".

Schritt 2: Erstellen eines neuen Projektes mit dem "WCE MFC AppWizard"

Um ein neues Projekt mit eMbedded Visual C++ 4.0 zu erstellen, wählen Sie bitte den Befehl "New" aus dem Menü "File".

File->New erstellt ein neues Projekt
File->New erstellt ein neues Projekt

Im nächsten Dialog, wählen Sie bitte als Projekttyp "WCE MFC AppWizard (exe)" aus. Geben Sie dem Projekt einen Namen (in unserem Beispiel wird "EinTest" verwendet) und wählen Sie ein Verzeichnis für das Projekt aus.

Typ, Name und Verzeichnis werden festgelegt
Typ, Name und Verzeichnis werden festgelegt

Im Dialog "Step 1 of 4" müssen Sie den Typ der Applikation auf "Dialog based" ändern.

Wählen sie "Dialog Based" aus.
Wählen sie "Dialog Based" aus.

Bestätigen Sie den Dialog "Step 1 of 4" mit "Next >", Dialog "Step 2 of 4" wird geöffnet.

Ändern sie in diesem Dialog keine Einstellung
Ändern sie in diesem Dialog keine Einstellung

Lassen Sie die Einstellungen des Dialoges "Step 2 of 4" unverändert und bestätigen Sie diesen mit "Next >", der Dialog "Step 3 of 4 " wird geöffnet.

Ändern sie in diesem Dialog keine Einstellung
Ändern sie in diesem Dialog keine Einstellung

Lassen Sie auch diesen Dialog unverändert. Nach dem Bestätigen mit "Next >" öffnet sich der Dialog "Step 4 of 4".

Klicken sie auf "Finish" um das Projekt anzulegen
Klicken sie auf "Finish" um das Projekt anzulegen

Klicken Sie nun auf "Finish" um das Projekt anzulegen!

Schritt 3: Ändern des Static Elements

Wechseln Sie in die "RessourceView" und öffnen Sie den Dialog "IDD_EINTEST_DIALOG".

Der geöffnete Dialog "IDD_EINTEST_DIALOG"
Der geöffnete Dialog "IDD_EINTEST_DIALOG"

Markieren Sie das Static Element mit der Caption "ZU ERLED.: Dialogfeld - Steuerelem. hier".

Das Static Element wurde markiert
Das Static Element wurde markiert

Öffnen Sie den Eigenschaftendialog des Elementes und ändern Sie die Caption auf "Hello World!".

Die Eigenschaft Caption wurde geändert.
Die Eigenschaft Caption wurde geändert.

Schritt 4: Konfiguration des Platform Managers

Den Konfigurationsdialog des Platform Managers öffnen Sie mit dem Menübefehl Tools/Configure Platform Manager.

Der Konfigurationsdialog des Platform Managers wird geöffnet

Wählen Sie nun das B&R Device X86BR410 Device aus.

Das B&R Device wurde markiert
Das B&R Device wurde markiert

Öffnen Sie die "Properties" des Devices.

Wählen sie zweimal ActiveSync aus
Wählen sie zweimal ActiveSync aus

In diesem Dialog müssen Sie als Transport und als Startup Server "Microsoft ActiveSync" auswählen.

Schritt 5: Übertragen des Projektes

Nun müssen Sie die aktive Konfiguration, das SDK und das Device festlegen. Stellen Sie die Konfiguration auf "Win32 (WCE x86) Debug", als SDK wählen Sie X86BR410 und als Device "X86BR410 Device".

Konfiguration, SDK und Device festlegen
Konfiguration, SDK und Device festlegen

Nun ist es an der Zeit das Projekt zu kompilieren. Starten Sie den Build-Vorgang mit dem Befehl "Rebuild All".

Starten sie den "Rebuild All"
Starten sie den "Rebuild All"

Nun sind Sie in der Lage das Projekt zu übertragen. Drücken sie F5 um das Debugging zu starten. Bestätigen Sie die "Find Local Module" Dialoge mit Cancel.

"Find Local Module" Dialoge mit Cancel abbrechen
"Find Local Module" Dialoge mit Cancel abbrechen

Fertig! Am B&R CE-Gerät erscheint die "Hello World!" Applikation.

Eine eVC 4.0 MFC "Hello World" Applikation!
Eine eVC 4.0 MFC "Hello World" Applikation!

Siehe auch:

  • Benötigte Software
  • ActiveSync

<< Vorheriges Thema
Benötigte Software

Startseite

Nächstes Thema >>
Verbindung mit dem CE-Gerät aufnehmen


Verbindung mit dem CE-Gerät aufnehmen

In diesem Abschnitt werden folgende Themen behandelt:

Verbindung mit dem CE-Gerät aufnehmen

Manuelle TCPIP Verbindung

ActiveSync

<< Vorheriges Thema
"Hello World"

Startseite

Nächstes Thema >>
Manuelle TCPIP Verbindung


Manuelle TCP/IP Verbindung

Allgemein

Die Manuelle TCP/IP - Verbindung ist die simpleste Form, um mit einem B&R Windows CE-Gerät zu kommunizieren. Alle B&R Geräte (Power Panel, Mobile Panel etc.) unterstützen diese Art der Kommunikation, welche hauptsächlich bei der Entwicklung von eMbedded Visual C++ 4.0 Applikationen (Native Code Development) eingesetzt wird.

So konfigurieren Sie die Manuelle TCP/IP Verbindung

Die Manuelle TCP/IP Verbindung können Sie ausschließlich über den Windows CE Platform Manager starten. Um eine erfolgreiche Verbindung herstellen zu können, müssen Sie den Windows CE Platform Manager zuerst konfiguieren. Starten Sie dazu die Windows CE Platform Manager Configuration.

Hinweis!

Bevor Sie mit diesem Tutorial beginnen, müssen folgende Voraussetzungen erfüllt sein:

  1. Microsoft eMbedded Visual C++ 4.0 muss installiert sein.
  2. Ein B&R Windows CE 4.1/4.2 (eMbedded Visual C++ 4.0) SDK installiert sein.
  3. Das Windows CE Gerät und der Desktop PC müssen per Ethernet/LAN verbunden sein (Ping).
  • Öffnen Sie eMbedded Visual C++ 4.0.
  • Wählen Sie im Tools > Configure Platform Manager.

Menüpunkt Configure Platform Manager im Tools Menü von eVC4
Menüpunkt Configure Platform Manager im Tools Menü von eVC4

  • Markieren Sie X86BR410 Device und klicken Sie auf Properties ...

Der Platform Manager wird konfiguriert
Der Platform Manager listet alle unterstützen Platformen auf.

  • Wählen Sie als Transport TCP/IP Transport for Windows CE.
  • Wählen Sie als Startup Server Manual Server.

    Konfiguration der Manuellen TCPIP Verbindung
    Konfiguration der Manuellen TCP/IP Verbindung

So testen Sie die Manuelle TCP/IP Verbindung

Für den Test der Manuellen TCP/IP Verbindung, wählen wir das Programm Remote Zoom-in. Mit diesem Programm werden Screenshots des Windows CE Targets erstellt.

  • Öffnen Sie Microsoft eMbedded Visual C++ 4.0.
  • Wählen Sie Tools > Remote Zoomin.

Menüpunkt Remote Zoomin im Tools Menü von eVC4

  • Markieren Sie X86BR410 Device und klicken Sie auf OK.

Der Select a Windows CE Device Dialog von Remote Zoomin
Der Select a Windows CE Device Dialog von Remote Zoomin

Die Kommunikation wurde gestartet
Die Kommunikation wurde gestartet

Hinweis:
Startet Remote Zoomin die Verbindung nicht automatisch, so klicken Sie auf dieses Icon [image].
  • Öffen Sie den Ausführen Dialog am Windows CE Gerät.
  • Geben Sie den rot umrahmten Text (Fenster Manual Server -Action) in den Ausführen Dialog ein.

Hinweis:
Sie finden den Aufruf auch in der History der Ausführen - Dropdownbox!

Starten von CEMGRC.EXE am CE Gerät
Starten von CEMGRC.EXE am CE-Gerät

  • Bestätigen Sie den Dialog Manual Server - Action am Desktop PC.
  • Bestätigen Sie den Dialog Ausführen am Windows CE Gerät.

Remote Zoomin hat erfolgreich einen Screenshot erstellt
Remote Zoomin hat erfolgreich einen Screenshot erstellt

  • Nach kurzer Zeit wird Remote Zoomin einen Snapshot vom CE-Gerät anzeigen.
    Somit ist die Verbindung zum Windows CE Target hergestellt. Sie können nun z.B. mit eVC4 ihr Projekt downloaden und debuggen, mit dem Remote Registry Editor die Registry des Targets bearbeiten oder mit dem Remote Fileviewer Dateien zwischen dem PC und dem Target austauschen.

Mehr Informationen zur Konfiguration der Manuellen TCP/IP Verbindung finden Sie in der Hilfe zu jenem Tool, welches den Platfom Manager verwendet.

Siehe auch:

  • Benötigte Software
  • ActiveSync Verbindung

<< Vorheriges Thema
Verbindung mit dem CE-Gerät aufnehmen

Startseite

Nächstes Thema >>
ActiveSync


ActiveSync

Allgemein

Microsoft stellt mit ActiveSync ein Programm zur Verfügung, mit dem Sie Ihren PC mit einem beliebigen Windows CE Gerät (welches ActiveSync unterstützt wie z.B. das B&R Power Panel) verbinden können. Mit ActiveSync ist es möglich z.B. Dateien zu kopieren, Verzeichnisse zu synchronisieren oder auch Programme zu übertragen und zu debuggen.

Der Vorteil von ActiveSync gegenüber z.b. der Manuellen TCP/IP Verbindung ist die nahtlose Integration des mobilen Gerätes in die Windowsoberfläche.

Direkter Zugriff auf das mobile Gerät über den Windows Explorer
Direkter Zugriff auf das mobile Gerät über den Windows Explorer

ActiveSync wird kostenlos von Microsoft zum Download angeboten. Sie finden das Programm auf der Microsoft Homepage www.microsoft.com am einfachsten wenn Sie nach ActiveSync Download suchen.

Hinweis:
Bitte verwenden sie ActiveSync ab einer Version >= 3.5

Wichtig!

Microsoft ActiveSync verursacht Probleme, wenn 2 LAN-Verbindungen aktiv sind. Treten bei der Kommunikation Probleme auf, so deaktivieren sie bitte alle überflüssigen LAN-Verbindungen.

ActiveSync verursacht Probleme wenn mehr als eine LAN-Verbindung aktiv ist
ActiveSync verursacht Probleme, wenn mehr als eine LAN-Verbindung aktiv ist.

Folgende Verbindungstypen sind verfügbar:

  • Seriell
  • Ethernet

In diesem Abschnitt werden folgende Themen behandelt:

ActiveSync

Seriell

Ethernet

<< Vorheriges Thema
Manuelle TCPIP Verbindung

Startseite

Nächstes Thema >>
Seriell


Seriell

Allgemein

Um eine serielle ActiveSync Verbindung zwischen Ihrem CE-Gerät und Ihrem Desktop PC herstellen zu können, benötigen Sie ein serielles RS232 Kabel. Dazu werden verschiedene Pinbelegungen in Abhängigkeit vom verwenden CE-Gerät benötigt.

Pinbelegung Power Panel 100/200

9 PIN D-SUB FEMALE (Computer 1) |  | 9 PIN D-SUB FEMALE (Computer 2)
Name | Pin | Pin | Name
Receive Data | 2 | 3 | Transmit Data
Transmit Data | 3 | 2 | Receive Data
Data Terminal Ready | 4 | 6+1 | Data Set Ready + Data Carrier Detect
System Ground | 5 | 5 | System Ground
Data Set Ready + Carrier Detect | 6+1 | 4 | Data Terminal Ready
Request to Send | 7 | 8 | Clear to Send
Clear to Send | 8 | 7 | Request to Send

B&R bietet für das Power Panel 100/200 folgendes passende RS232 DB9 Nullmodem Kabel an:

Nullmodemkabel 9A0017.0x

RS232 DB9 Nullmodem Kabel | 9A0017.01 | 9A0017.02
Länge | 0,6 Meter | 1,8 Meter

Pinbelegung Mobile Panel 100/200

Schaltschrankkabel RS232 | 9 PIN D-SUB FEMALE
- | Pin | Name
Receive Data (Rosa) | 3 | Transmit Data
Transmit Data (Grau) | 2 | Receive Data
System Ground (Weiß-Gelb) | 5 | System Ground
- | 6+1+4 | Data Set Ready + Data Carrier Detect + Data Terminal Ready
 | 7+8 | Clear to Send + Request to Send

So stellen Sie eine ActiveSync Verbindung her:

  • Verbinden mit dem oben beschriebenen seriellen Kabel, die COM1 Ihres CE-Gerätes mit der COM1 Ihres Desktop PCs. Danach starten Sie das Programm Microsoft ActiveSync mit einem Doppelklick auf das Icon.

  • Nun wählen Sie den Menüpunkt Verbindung herstellen ... aus dem Menü Datei an.

Eine Verbindung mit dem CE - Gerät herstellen

  • Den Dialog Verbindung herstellen beenden Sie mit Weiter >.

Überspringen Sie diesen Dialog mit einem Klick auf "Weiter >"

  • ActiveSync versucht nun das CE-Gerät an einer Kommunikationsschnittstelle Ihres Dekstop PCs zu finden.

Das CE-Gerät wird gesucht

  • Während ActiveSync das CE-Gerät sucht, müssen Sie am CE-Gerät den ActiveSync Server Repllog.exe starten.
    Dieses Programm versucht nun seinerseits, eine Verbindung mit dem Desktop PC per ActiveSync herzustellen.
    Sie können dieses Programm sehr einfach mit dem Shortcut Start > Programs> Accessories > ActiveSync Connection Default starten.

  • Wurde das CE-Gerät gefunden, bietet Ihnen ActiveSync an, eine Partnerschaft festzulegen. Markieren Sie die Option Ja und beenden Sie diesen Dialog mit einem Klick auf Weiter >.

Dialog zum festlegen einer Partnerschaft mit dem CE-Gerät

Hinweis:
Es ist nicht unbedingt notwendig eine Partnerschaft anzulegen, da am B&R CE-Gerät keine Programme installiert sind die diese Funktion zwingend benötigen. Wollen Sie jedoch ActiveSync über Ethernet (wird bei der Programmierung von .Net Applikationen verwendet) verwenden, so müssen Sie eine Partnerschaft festlegen.
  • Im nächsten Dialog können Sie definieren, welche Komponenten zwischen Ihrem Windows CE-Gerät und Ihrem Desktop PC synchronisiert werden sollen.

  • Wurde die Verbindung erfolgreich aufgebaut, so erscheint der Schriftzug Connected oder Verbunden im Fenster von ActiveSync.

Sie wurden als "Gast" mit ihrem CE-Gerät verbunden

  • Am CE-Gerät erkennen Sie eine aktive ActiveSync Verbindung an diesem Icon im Systemtray.

Trayicon einer aktiven ActiveSyncverbindung am CE-Gerät

  • Ein Doppelklick auf das Systemtrayicon öffnet einen weiteren Dialog, welcher Ihnen die Möglichkeit bietet, die ActiveSync-Verbindung zu deaktivieren.

CE Dialog zum Trennen einer ActiveSync Verbindung

  • Zum Abschluss müssen Sie noch die Registry auf dem CE-Gerät speichern. Öffnen Sie dazu den Configuration Manager über Start > Settings > Control Panel > Configuration Manager und klicken Sie auf den Button Save Settings der Registerkarte Save.

Siehe auch:

  • ActiveSync Allgemein
  • ActiveSync Ethernet

<< Vorheriges Thema
ActiveSync

Startseite

Nächstes Thema >>
Ethernet


Ethernet

Wichtig!

Um eine Ethernet Verbindung mit ActiveSync aufzubauen ist es zwingend notwendig, dass sie bereits eine Partnerschaft mit dem CE-Gerät angelegt haben. Ansonsten ist ActiveSync über Ethernet nicht in der Lage, das CE-Gerät zu finden.

Wie Sie eine serielle Verbindung mit Partnerschaft anlegen, können Sie hier nachlesen.

So erstellen Sie eine ActiveSync Verbindung per Ethernet:

  • Überprüfen Sie, ob Ihre Ethernetverbindung funktioniert. Dies können Sie am folgenden Systemtray Icon erkennen:

  • Wurde bereits eine Partnerschaft mit einem Desktop PC angelegt, so können Sie ActiveSync über Ethernet mit dem Befehl repllog.exe /remote oder mit dem Shortcut Start > Programs > Accessories > ActiveSync Connection Remote am CE-Gerät starten.

Starten der ActiveSync - Ethernet Verbindung mit dem Shortcut aus dem Startmenü

  • Wählen sie im nächsten Dialog jenen Computer aus, mit welchem Sie sich verbinden wollen.

  • Nach erfolgreicher Verbindung erscheint dieser Dialog am CE-Gerät:

Die Ethernet Verbindung wurde erfolgreich aufgenommen

Siehe auch:

  • ActiveSync Allgemein
  • ActiveSync Seriell

<< Vorheriges Thema
Seriell

Startseite

Nächstes Thema >>
B&R spezifische Erweiterungen


B&R Windows CE Tools

B&R spezifische Erweiterungen

In diesem Abschnitt werden folgende Themen behandelt:

B&R spezifische Erweiterungen

Bibliotheken

Konfigurationsdateien

Tools

<< Vorheriges Thema
Ethernet

Startseite

Nächstes Thema >>
Bibliotheken


Bibliotheken

In diesem Abschnitt werden folgende Themen behandelt:

Bibliotheken

Mobile Panel System DLL

Power Panel System DLL

<< Vorheriges Thema
B&R spezifische Erweiterungen

Startseite

Nächstes Thema >>
Mobile Panel System DLL


Mobile Panel System DLL

Allgemein

Die Mobile Panel System DLL (MpSys.dll) stellt hardwarespezifische Funktionen zur Verfügung. Sie können z.B. die BIOS Version auslesen oder die Helligkeit des Displays verändern.

In Zusätzliche Informationen finden Sie weitere Hinweise für die Anwendung der DLL Funktionen.

Voraussetzungen

Die Mobile Panel System DLL - MpSys.dll ist ab Version V1.0 von B&R Windows CE 4.1 in das Image integriert. Ältere Versionen des Images unterstützen dieses Feature nicht. Wenn Sie eine neue Version des Images benötigen, kontaktieren Sie bitte Ihren B&R Vertriebsmann.

Weiters benötigen Sie noch die MpSys.h Definitionsdatei und die MpSys.lib Library. Diese Dateien können Sie mit dem Software Paket Windows CE Utilities von der B&R Homepage downloaden (http://www.br-automation.com).

<< Vorheriges Thema
Bibliotheken

Startseite

Nächstes Thema >>
Funktionen


Funktionen

Hinweis:
Rufen Sie Mobile Panel spezifische Funktionen nur auf einem Mobile Panel auf!

Allgemeine Funktionen

    Name | Beschreibung
MpCheckPlatform | Überprüft, ob die verwendete Plattform ein Mobile Panel ist.

Funktionen zum Auslesen von Versionen

    Name | Beschreibung
MpGetBiosVersion | Gibt die Version des verwendeten BIOS zurück.
MpGetDllVersion | Gibt die Version der Mobile Panel System DLL zurück.
MpGetSmcVersion | Gibt die Version des SMC zurück.
MpGetMxcDrvVersion | Gibt die Version des MXC Treibers zurück.
MpGetMxcVersion | Gibt die Version des MXC zurück.

Funktionen, die allgemeine Informationen liefern

    Name | Beschreibung
MpGetModeNode | Liefert die aktuelle Stellung der Mode/Node Schalter.
MpGetFwInfo | Liefert Informationen über die Firmware im Flash des Mobile Panel.
MpGetFwInfoEx | Liefert erweiterte Informationen über die Firmware im Flash des Mobile Panel.
MpGetFwBootStatus | Liefert den Bootstatus der Firmware im Flash des Mobile Panel.
MpGetTemperatureBoard | Gibt die Motherboard Temperatur des Mobile Panel zurück.
MpGetTemperatureCPU | Gibt die CPU Temperatur des Mobile Panel zurück.
MpGetUserBootLogoInfo | Gibt Informationen über ein über ein eventuell vorhandenes User Boot Logo im Flash zurück.

MKey LED Funktionen

    Name | Beschreibung
MpGetMKeyLed | Liefert den aktuellen Status einer MKey LED.
MpSetMKeyLed | Setzt den Status einer MKey LED.
MpSetMKeyLeds | Setzt/löscht alle MKey LEDs.

Funktionen zum Auslesen der Factory Settings

    Name | Beschreibung
MpGetFsVersion | Liefert die Version der Factory Settings.
MpGetFsDisplayId | Liest die ID des verwendeten Displays aus den Factory Settings.
MpGetFsDeviceId | Liest die ID des verwendeten Mobile Panel aus den Factory Settings.
MpGetFsCompatibilityId | Liest die Kompatibilitäts ID des Gerätes aus den Factory Settings.
MpGetFsBrightnessMin | Liest den minimalen Grenzwert der Helligkeit aus den Factory Settings.
MpGetFsBrightnessDef | Liest den Standardwert der Helligkeit aus den Factory Settings.
MpGetFsBrightnessMax | Liest den maximalen Grenzwert der Helligkeit aus den Factory Settings.
MpGetFsContrastMin | Liest den minimalen Grenzwert des Kontrastes aus den Factory Settings.
MpGetFsContrastDef | Liest den Standardwert des Kontrastes aus den Factory Settings.
MpGetFsContrastMax | Liest den maximalen Grenzwert des Kontrastes aus den Factory Settings.

Displayfunktionen

    Name | Beschreibung
MpSetBacklightOn | Schaltet die Hintergrundbeleuchtung des Displays ein.
MpSetBacklightOff | Schaltet die Hintergrundbeleuchtung des Displays aus.
MpGetDisplayType | Liefert den Typ des verwendeten Displays.
MpCheckBrightnessAuto | Überprüft, ob die aktuelle Helligkeit des Displays mit dem Standardwert aus den Factory Settings identisch ist.
MpSetBrightnessAuto | Setzt die Helligkeit auf den Standardwert, welcher in den Factory Settings definiert ist.
MpGetBrightness | Liefert die aktuelle Helligkeit.
MpSetBrightness | Setzt die Helligkeit des Displays.
MpCheckContrastAuto | Überprüft, ob der aktuelle Kontrast des Displays mit dem Standardwert aus den Factory Settings identisch ist.
MpSetContrastAuto | Setzt den Kontrast auf den Standardwert, welcher in den Factory Settings definiert ist.
MpGetContrast | Liefert den aktuellen Kontrast.
MpSetContrast | Setzt den Kontrast des Displays.

Allgemeine System Funktionen

    Name | Beschreibung
MpReboot | Löst einen Neustart (Reboot) des Mobile Panel aus.

<< Vorheriges Thema
Mobile Panel System DLL

Startseite

Nächstes Thema >>
MpCheckBrightnessAuto


MpCheckBrightnessAuto

MpCheckBrightnessAuto

Überprüft, ob die aktuelle Helligkeit des Displays mit dem Standardwert aus den Factory Settings identisch ist.

BOOL MpCheckBrightnessAuto(
BOOL* bAuto);

Parameter

bAuto

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf TRUE oder FALSE ist.
TRUE zeigt an, dass die aktuelle Helligkeit mit dem Standardwert aus den Factory Settings identisch ist.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Funktion erfolgreich durchgeführt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetBrightnessAuto

<< Vorheriges Thema
Funktionen

Startseite

Nächstes Thema >>
MpCheckContrastAuto


MpCheckContrastAuto

MpCheckContrastAuto

Überprüft, ob der aktuelle Kontrast des Displays mit dem Standardwert aus den Factory Settings identisch ist.

BOOL MpCheckContrastAuto(
BOOL* bAuto);

Parameter

bAuto

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf TRUE oder FALSE ist.
TRUE zeigt an, dass der aktuelle Kontrast mit dem Standardwert aus den Factory Settings identisch ist.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Funktion erfolgreich durchgeführt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays ausgelesen werden.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetContrastAuto

<< Vorheriges Thema
MpCheckBrightnessAuto

Startseite

Nächstes Thema >>
MpCheckPlatform


MpCheckPlatform

MpCheckPlatform

Überprüft, ob die verwendete Plattform ein Mobile Panel ist.

BOOL MpCheckPlatform(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die verwendete Plattform ein Mobile Panel ist. Wurde kein Mobile Panel erkannt, so wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpCheckContrastAuto

Startseite

Nächstes Thema >>
MpGetBiosVersion


MpGetBiosVersion

MpGetBiosVersion

Gibt die Version des verwendeten BIOS zurück.

BOOL MpGetBiosVersion(
TCHAR* BiosVersion);

Parameter

BiosVersion

[out] Zeigt auf einen Puffer für den BIOS Versionsstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die BIOS Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpCheckPlatform

Startseite

Nächstes Thema >>
MpGetBrightness


MpGetBrightness

MpGetBrightness

Liefert die aktuelle Helligkeit.

BOOL MpGetBrightness(
PUCHAR Percent);

Parameter

Percent

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Wert der aktuellen Helligkeit in Prozent beinhaltet: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Helligkeit erfolgreich ausgelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetBrightness

<< Vorheriges Thema
MpGetBiosVersion

Startseite

Nächstes Thema >>
MpGetContrast


MpGetContrast

MpGetContrast

Liefert den aktuellen Kontrast.

BOOL MpGetContrast(
PUCHAR Percent);

Parameter

Percent

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den aktuellen Wert des Kontrastes in Prozent enthält: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrast erfolgreich ausgelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays ausgelesen werden.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetContrast

<< Vorheriges Thema
MpGetBrightness

Startseite

Nächstes Thema >>
MpGetDisplayType


MpGetDisplayType

MpGetDisplayType

Liefert den Typ des verwendeten Displays.

BOOL MpGetDisplayType(
PUCHAR DisplayType);

Parameter

DisplayType

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Displaytyp enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Displaytyp erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Normalerweise liefert diese Funktion den selben Wert wie MpGetFsDisplayID. Da die Factory Settings in der Version 0 fehlerhafte Displaytypen enthalten, ist diese Funktion zum Bestimmen der Display ID zu bevorzugen.

Eine Liste aller möglichen Display IDs finden Sie unter Displaykennungen.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsDisplayID , Displaykennungen

<< Vorheriges Thema
MpGetContrast

Startseite

Nächstes Thema >>
MpGetDLLVersion


MpGetDllVersion

MpGetDllVersion

Gibt die Version der Mobile Panel System DLL zurück.

BOOL MpGetDllVersion(
TCHAR* DllVersion,
int Count);

Parameter

DllVersion

[out] Zeigt auf einen Puffer für den DLL Versionstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer DllVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die DLL Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetDisplayType

Startseite

Nächstes Thema >>
MpGetFsBrightnessDef


MpGetFsBrightnessDef

MpGetFsBrightnessDef

Liest den Standardwert der Helligkeit aus den Factory Settings.

BOOL MpGetFsBrightnessDef(
PUCHAR FsBrightnessDef);

Parameter

FsBrightnessDef

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Standardwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Helligkeitswert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Dieser Wert wird verwendet, wenn Sie im Mobile Panel Control Center die Checkbox "Auto" der Helligkeit aktivieren.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsBrightnessMin, MpGetFsBrightnessMax

<< Vorheriges Thema
MpGetDLLVersion

Startseite

Nächstes Thema >>
MpGetFsBrightnessMax


MpGetFsBrightnessMax

MpGetFsBrightnessMax

Liest den maximalen Grenzwert der Helligkeit aus den Factory Settings.

BOOL MpGetFsBrightnessMax(
PUCHAR FsBrightnessMax);

Parameter

FsBrightnessMax

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den maximalen Grenzwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der maximale Grenzwert kann niedriger sein als der minimale Grenzwert. Somit benötigt das Display inverse Werte => größter Wert = kleinste Helligkeit.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsBrightnessMin , MpGetFsBrightnessDef

<< Vorheriges Thema
MpGetFsBrightnessDef

Startseite

Nächstes Thema >>
MpGetFsBrightnessMin


MpGetFsBrightnessMin

MpGetFsBrightnessMin

Liest den minimalen Grenzwert der Helligkeit aus den Factory Settings.

BOOL MpGetFsBrightnessMin(
PUCHAR FsBrightnessMin);

Parameter

FsBrightnessMin

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den minimalen Grenzwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der minimale Grenzwert kann höher sein als der maximale Grenzwert. Somit benötigt das Display inverse Werte => kleinster Wert = größte Helligkeit.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsBrightnessMax , MpGetFsBrightnessDef

<< Vorheriges Thema
MpGetFsBrightnessMax

Startseite

Nächstes Thema >>
MpGetFsCompatibilityId


MpGetFsCompatibilityId

MpGetFsCompatibilityId

Liest die Kompatibilitäts ID des Gerätes aus den Factory Settings

BOOL MpGetFsCompatibilityId(
PUCHAR FsCompId);

Parameter

FsCompId

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Kompatibilitäts ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Kompatibilitäts ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFsBrightnessMin

Startseite

Nächstes Thema >>
MpGetFsContrastDef


MpGetFsContrastDef

MpGetFsContrastDef

Liest den Standardwert des Kontrastes aus den Factory Settings.

BOOL MpGetFsContrastDef(
PUCHAR FsContrastDef);

Parameter

FsContrastDef

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Standardwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrastwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Dieser Wert wird verwendet, wenn Sie im Mobile Panel Control Center die Checkbox "Auto" des Kontrastes aktivieren.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsContrastMin, MpGetFsContrastMax

<< Vorheriges Thema
MpGetFsCompatibilityId

Startseite

Nächstes Thema >>
MpGetFsContrastMax


MpGetFsContrastMax

MpGetFsContrastMax

Liest den maximalen Grenzwert des Kontrastes aus den Factory Settings.

BOOL MpGetFsContrastMax(
PUCHAR FsContrastMax);

Parameter

FsContrastMax

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den maximalen Grenzwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der maximale Grenzwert kann niedriger sein als der minimale Grenzwert. Somit benötigt das Display inverse Werte => größter Wert = kleinster Kontrast.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsContrastMin , MpGetFsContrastDef

<< Vorheriges Thema
MpGetFsContrastDef

Startseite

Nächstes Thema >>
MpGetFsContrastMin


MpGetFsContrastMin

MpGetFsContrastMin

Liest den minimalen Grenzwert des Kontrastes aus den Factory Settings.

BOOL MpGetFsContrastMin(
PUCHAR FsContrastMin);

Parameter

FsContrastMin

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den minimalen Grenzwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der minimale Grenzwert kann höher sein als der maximale Grenzwert. Somit benötigt das Display inverse Werte => kleinster Wert = größter Kontrast.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetFsContrastMax , MpGetFsContrastDef

<< Vorheriges Thema
MpGetFsContrastMax

Startseite

Nächstes Thema >>
MpGetFsDeviceId


MpGetFsDeviceId

MpGetFsDeviceId

Liest die ID des verwendeten Mobile Panel aus den Factory Settings.

BOOL MpGetFsDeviceId(
PUSHORT FsDeviceId);

Parameter

FsDeviceId

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Device ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Device ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFsContrastMin

Startseite

Nächstes Thema >>
MpGetFsDisplayId


MpGetFsDisplayId

MpGetFsDisplayId

Liest die ID des verwendeten Displays aus den Factory Settings.

BOOL MpGetFsDisplayId(
PUCHAR FsDisplayId);

Parameter

FsDisplayId

[out] Zeigt auf eine Variable, welche nach dem Aufruf die Display ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Display ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Die Display ID definiert welches Display am Mobile Panel verwendet wird. Zum Beispiel verwendet das BIOS diese ID, um das Display korrekt zu initialisieren.

Eine Liste aller möglichen Display IDs finden Sie unter Displaykennungen.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

Displaykennungen

<< Vorheriges Thema
MpGetFsDeviceId

Startseite

Nächstes Thema >>
MpGetFsVersion


MpGetFsVersion

MpGetFsVersion

Liefert die Version der Factory Settings.

BOOL MpGetFsVersion(
PUCHAR FsVersion);

Parameter

FsVersion

[out] Zeigt auf eine Variable für die Version der Factory Settings.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Version der Factory Settings erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFsDisplayId

Startseite

Nächstes Thema >>
MpGetFwBootStatus


MpGetFwBootStatus

MpGetFwBootStatus

Liefert den Bootstatus der (optionalen) Firmware, die im Flash des Mobile Panel abgelegt ist.

BOOL MpGetFwBootStatus(
int Slot,
PUCHAR Status);

Parameter

Slot

[in] Definiert die Firmware: 0 für das erste eingebaute FPGA, 3 für das zweite eingebaute FPGA.

Status

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den aktuellen Bootstatus enthält.
Mögliche Werte:

Wert
Konstante
Beschreibung
0
STATUS_FPGA_FILE_NFOUND
Keine FPGA Datei vorhanden.
1
STATUS_FPGA_FILE_SIZE
Falsche Größe der FPGA Datei.
2
STATUS_FPGA_NFOUND
Kein FPGA vorhanden.
3
STATUS_FPGA_BOOT_NINIT
Der Bootmodus konnte nicht aktiviert werden.
4
STATUS_FPGA_BOOT_NDONE
Booten ist fehlgeschlagen.
5
STATUS_FPGA_BOOT_OK
Booten OK.
6
STATUS_FPGA_FILE_OLD
Alte FPGA Datei.
7
STATUS_FPGA_MISMATCH
Falsche FPGA Datei (für anderes Gerät).
8
STATUS_FPGA_DISABLED
Das Booten ist ausgeschaltet (im BIOS Setup).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Bootstatus der Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFsVersion

Startseite

Nächstes Thema >>
MpGetFwInfo


MpGetFwInfo

MpGetFwInfo

Liefert Informationen über die (optionale) Firmware, die im Flash des Mobile Panel abgelegt ist.

BOOL MpGetFwInfo(
int Slot,
TCHAR* FwInfo,
int Count);

Parameter

Slot

[in] Definiert die Firmware: 0 für das erste eingebaute FPGA, 3 für das zweite eingebaute FPGA.

FwInfo

[out] Zeigt auf einen Puffer für die Firmwareinfo. Der Puffer soll mindestens 33 Elemente groß sein.

Beispiel einer Firmwareinfo: "Mpx00.ncd 2004/01/13 15:03:52".

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer FwInfo kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen über die Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn keine Firmware gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFwBootStatus

Startseite

Nächstes Thema >>
MpGetFwInfoEx


MpGetFwInfoEx

MpGetFwInfoEx

Liefert erweiterte Informationen über die (optionale) Firmware, die im Flash des Mobile Panel abgelegt ist.

BOOL MpGetFwInfoEx(
int Slot,
TCHAR* Header,
int Count,
DWORD* Size);

Parameter

Slot

[in] Definiert die Firmware: 0 für das erste eingebaute FPGA, 3 für das zweite eingebaute FPGA.

Header

[out] Zeigt auf einen Puffer, welcher nach dem Funktionsaufruf den XML Header der FPGA Datei enthält.

Wird Header auf NULL gesetzt, so wird kein XML Header zurückgeliefert.

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer Header kopiert werden (ohne abschließende 0).

Size

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Größe der Firmware in Bytes enthält.

Wird Size auf NULL gesetzt, so wird kein Größe zurückgeliefert.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen über die Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn keine Firmware gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetFwInfo

Startseite

Nächstes Thema >>
MpGetMKeyLed


MpGetMKeyLed

MpGetMKeyLed

Liefert den aktuellen Status einer MKey LED.

BOOL MpGetMKeyLed(
int KeyNumber,
int Keylayer,
int* LedState);

Parameter

KeyNumber

[in] Definiert die MKey Nummer der LED: 0 bis 127.

KeyLayer

[in] Definiert den MKey Layer der LED: 0 bis 3.

LedState

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Status der LED beinhaltet: 0 = LED aus, 1 = LED blinkt langsam, 2 = LED blinkt schnell, 3 = LED ein.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

MpSetMKeyLed, MpSetMKeyLeds

<< Vorheriges Thema
MpGetFwInfoEx

Startseite

Nächstes Thema >>
MpGetModeNode


MpGetModeNode

MpGetModeNode

Liefert die aktuelle Stellung der Mode/Node Schalter.

BOOL MpGetModeNode(
PUCHAR ModeNode);

Parameter

ModeNode

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die aktuelle Stellung der Mode/Node Schalter beinhaltet: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Stellung der Mode/Node Schalter erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetMKeyLed

Startseite

Nächstes Thema >>
MpGetMxcDrvVersion


MpGetMxcDrvVersion

MpGetMxcDrvVersion

Gibt die Version des (optionalen) Matrix Controller (MXC) Treibers zurück.

BOOL MpGetMxcVersion(
TCHAR* DrvVersion, int Count);

Parameter

DrvVersion

[out] Zeigt auf einen Puffer für den MXC Treiber Versionsstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer DrvVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die MXC Treiber Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

MpGetMxcVersion

<< Vorheriges Thema
MpGetModeNode

Startseite

Nächstes Thema >>
MpGetMxcVersion


MpGetMxcVersion

MpGetMxcVersion

Gibt die Version des (optionalen) Matrix Controller (MXC) zurück.

BOOL MpGetMxcVersion(
TCHAR* MxcVersion, int Count);

Parameter

MxcVersion

[out] Zeigt auf einen Puffer für den MXC Versionsstring. Der Puffer soll mindestens 4 Elemente groß sein. Der zurückgegebene String hat das Format "v.y" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer MxcVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die MXC Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

MpGetMxcDrvVersion

<< Vorheriges Thema
MpGetMxcDrvVersion

Startseite

Nächstes Thema >>
MpGetSmcVersion


MpGetSmcVersion

MpGetSmcVersion

Gibt die Version des (optionalen) System Management Controller (SMC) zurück.

BOOL MpGetSmcVersion(
TCHAR* SmcVersion,
int Count);

Parameter

SmcVersion

[out] Zeigt auf einen Puffer für den SMC Versionsstring. Der Puffer soll mindestens 4 Elemente groß sein. Der zurückgegebene String hat das Format "x.x" (hexadezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer SmcVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die SMC Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetMxcVersion

Startseite

Nächstes Thema >>
MpGetTemperatureBoard


MpGetTemperatureBoard

MpGetTemperatureBoard

Gibt die Motherboard Temperatur des Mobile Panel zurück.

BOOL MpGetTemperatureBoard(
PCHAR Temperature);

Parameter

Temperature

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Temperatur in Celsius enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Temperatur erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetSmcVersion

Startseite

Nächstes Thema >>
MpGetTemperatureCpu


MpGetTemperatureCpu

MpGetTemperatureCpu

Gibt die CPU Temperatur des Mobile Panel zurück.

BOOL MpGetTemperatureCpu(
PCHAR Temperature);

Parameter

Temperature

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Temperatur in Celsius enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Temperatur erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetTemperatureBoard

Startseite

Nächstes Thema >>
MpGetUserBootLogoInfo


MpGetUserBootLogoInfo

MpGetUserBootLogoInfo

Gibt Informationen über ein eventuell vorhandenes User Boot Logo im Flash des Mobile Panel zurück.

BOOL MpGetUserBootLogoInfo(
TCHAR* Comment,
int Count,
WORD* VgaMode,
DWORD* Size);

Parameter

Comment

[out] Zeigt auf einen Puffer, welcher nach dem Funktionsaufruf Informationen über das Boot Logo enthält. Der Puffer sollte mindestens 33 Elemente groß sein. Wird NULL übergeben, so wird keine Information geliefert.

Beispiel: "mp640.bmp 2003/08/21 15:03:52"

Wurde das User Boot Logo nicht mit USERLOGO.EXE erstellt, so wird ein Leerstring zurückgegeben!

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer Comment kopiert werden (ohne abschließende 0).

VgaMode

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den verwendeten VGA Modus des User Boot Logo enthält.

Diese Modi werden unterstützt (siehe Konstanten in Definitionsdatei MpSys.h):

Wert

Auflösung in Pixel

Konstante
0x0121 | 320 x 240 (QVGA) | VGA_MODE_320_240
0x0101 | 640 x 480 (VGA) | VGA_MODE_640_480
0x0103 | 800 x 600 (SVGA) | VGA_MODE_800_600
0x0105 | 1024 x 768 (XGA) | VGA_MODE_1024_768

Wird VgaMode auf NULL gesetzt, so wird kein Modus zurückgeliefert.

Size

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Größe des User Boot Logo in Bytes enthält.

Wird Size auf NULL gesetzt, so wird keine Größe zurückgeliefert.

Die Größe kann 0 sein, wenn das User Boot Logo nicht mit USERLOGO.EXE erstellt worden ist!

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen des User Boot Logo erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn kein User Boot Logo gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetTemperatureCpu

Startseite

Nächstes Thema >>
MpReboot


MpReboot

MpReboot

Löst einen Neustart (Reboot) des Mobile Panel aus.

void MpReboot(void);

Parameter

-

Rückgabewerte

Diese Funktion kehrt nicht zurück.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

-

<< Vorheriges Thema
MpGetUserBootLogoInfo

Startseite

Nächstes Thema >>
MpSetBacklightOff


MpSetBacklightOff

MpSetBacklightOff

Schaltet die Hintergrundbeleuchtung (das Backlight) des Displays aus.

BOOL MpSetBacklightOff(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Hintergrundbeleuchtung des Displays ausgeschaltet wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetBacklightOn

<< Vorheriges Thema
MpReboot

Startseite

Nächstes Thema >>
MpSetBacklightOn


MpSetBacklightOn

MpSetBacklightOn

Schaltet die Hintergrundbeleuchtung (das Backlight) des Displays ein.

BOOL MpSetBacklightOn(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Hintergrundbeleuchtung des Displays eingeschaltet wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpSetBacklightOff

<< Vorheriges Thema
MpSetBacklightOff

Startseite

Nächstes Thema >>
MpSetBrightness


MpSetBrightness

MpSetBrightness

Setzt die Helligkeit des Displays.

BOOL MpSetBrightness(
UCHAR Percent);

Parameter

Percent

[in] Definiert die gewünschte Helligkeit in Prozent: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Helligkeit erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetBrightness

<< Vorheriges Thema
MpSetBacklightOn

Startseite

Nächstes Thema >>
MpSetBrightnessAuto


MpSetBrightnessAuto

MpSetBrightnessAuto

Setzt die Helligkeit auf den Standardwert, der in den Factory Settings definiert ist.

BOOL MpSetBrightnessAuto(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Helligkeitswert erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpCheckBrightnessAuto

<< Vorheriges Thema
MpSetBrightness

Startseite

Nächstes Thema >>
MpSetContrast


MpSetContrast

MpSetContrast

Setzt den Kontrast des Displays.

BOOL MpSetContrast(
UCHAR Percent);

Parameter

Percent

[in] Definiert den gewünschten Kontrast in Prozent: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrastwert erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays gesetzt werden.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpGetContrast

<< Vorheriges Thema
MpSetBrightnessAuto

Startseite

Nächstes Thema >>
MpSetContrastAuto


MpSetContrastAuto

MpSetContrastAuto

Setzt den Kontrast auf den Standardwert, der in den Factory Settings definiert ist.

BOOL MpSetContrastAuto(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrast gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays gesetzt werden.

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib

Siehe auch

MpCheckContrastAuto

<< Vorheriges Thema
MpSetContrast

Startseite

Nächstes Thema >>
MpSetMKeyLed


MpSetMKeyLed

MpSetMKeyLed

Setzt den Status einer MKey LED.

BOOL MpSetMKeyLed(
int KeyNumber,
int Keylayer,
int LedState);

Parameter

KeyNumber

[in] Definiert die MKey Nummer der LED: 0 bis 127.

KeyLayer

[in] Definiert den MKey Layer der LED: 0 bis 3.

LedState

[in] Definiert den Status der LED: 0 = LED aus, 1 = LED blinkt langsam, 2 = LED blinkt schnell, 3 = LED ein.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

MpGetMKeyLed, MpSetMKeyLeds

<< Vorheriges Thema
MpSetContrastAuto

Startseite

Nächstes Thema >>
MpSetMKeyLeds


MpSetMKeyLeds

MpSetMKeyLeds

Setzt oder löscht alle MKey LEDs in allen MKey Layer.

BOOL MpSetMKeyLeds(
BOOL bOn);

Parameter

bOn

[in] Definiert, ob die LEDs eingeschaltet (TRUE) oder ausgeschaltet (FALSE) werden.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die LEDs erfolgreich gesetzt bzw gelöscht wurden. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Mobile Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.0 und höher
Header File: MpSys.h
Library: MpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

MpGetMKeyLed, MpSetMKeyLed

<< Vorheriges Thema
MpSetMKeyLed

Startseite

Nächstes Thema >>
Zusätzliche Informationen


Zusätzliche Informationen

In diesem Abschnitt werden folgende Themen behandelt:

Zusätzliche Informationen

Mobile Panel Erkennung

Displaykennungen

Fehlercodes

<< Vorheriges Thema
MpSetMKeyLeds

Startseite

Nächstes Thema >>
Mobile Panel Erkennung


Mobile Panel Erkennung

Um zu überprüfen, ob ihr Programm auf einem B&R Mobile Panel läuft, verwenden Sie die Funktion MpCheckPlatform.

Nur auf einem B&R Mobile Panel wird die Funktion ohne Fehler ausgeführt. Auf anderen Geräten bricht die Funktion mit dem Rückgabewert FALSE ab bzw. ist die Mobile Panel System DLL - und damit die Funktion - nicht vorhanden.

<< Vorheriges Thema
Zusätzliche Informationen

Startseite

Nächstes Thema >>
Displaykennungen


Displaykennung

Displaykennungen

Die folgende Tabelle enthält die Displaykennung, die von MpGetDisplayType und MpGetFsDisplayId geliefert werden.

    ID | Beschreibung
00h | Displayparameter kommen nicht aus der Tabelle in den Factory Settings.
10h | Passive Displays (STN)
11h | LCD B/W QVGA
12h | LCD COL QVGA
20h | Aktive Displays (TFT) mit QVGA Auflösung
30h | Aktive Displays (TFT) mit VGA Auflösung
40h | Aktive Displays (TFT) mit SVGA Auflösung
50h | Aktive Displays (TFT) mit XVGA Auflösung
... | Frei
F0h | Frei

<< Vorheriges Thema
Mobile Panel Erkennung

Startseite

Nächstes Thema >>
Fehlercodes


Fehlercodes

Alle Funktionen dieser DLL liefern Standard Windows System Fehler:

  • ERROR_INVALID_PARAMETER wenn ein falscher Parameter übergeben worden ist.
  • ERROR_IO_DEVICE wenn der Zugriff auf ein Gerät (z.B. ACCESS.bus) fehlgeschlagen ist.
  • ERROR_INVALID_HANDLE wenn ein Synchronisationsobjekt nicht angelegt werden konnte.
  • ERROR_OUTOFMEMORY wenn die Anforderung von Speicher fehlgeschlagen ist.
  • ERROR_CALL_NOT_IMPLEMENTED wenn das BIOS diese Funktion nicht unterstützt (die BIOS Version zu alt ist) oder wenn die verwendete Plattform kein Mobile Panel ist.
  • ERROR_NOT_SUPPORTED wenn die verwendete Plattform diese Funktion nicht unterstützt (z.B. weil kein Matrix Controller vorhanden ist).
  • ERROR_FILE_NOT_FOUND wenn eine Datei nicht gefunden wurde (z.B. Firmware oder User Boot Logo).

<< Vorheriges Thema
Displaykennungen

Startseite

Nächstes Thema >>
Power Panel System DLL


Power Panel System DLL

Allgemein

Die Power Panel System DLL (PpSys.dll) stellt hardwarespezifische Funktionen zur Verfügung. Sie können z.B. die BIOS Version auslesen, die User LED setzen oder die Helligkeit des Displays verändern.

In Zusätzliche Informationen finden Sie weitere Hinweise für die Anwendung der DLL Funktionen.

Voraussetzungen

Die Power Panel System DLL - PpSys.dll ist ab Version V1.3 von B&R Windows CE 4.1 in das Image integriert. Ältere Versionen des Images unterstützen dieses Feature nicht. Wenn Sie eine neue Version des Images benötigen, kontaktieren Sie bitte Ihren B&R Vertriebsmann.

Weiters benötigen Sie noch die PpSys.h Definitionsdatei und die PpSys.lib Library. Diese Dateien können Sie mit dem Software Paket Windows CE Utilities von der B&R Homepage downloaden (http://www.br-automation.com).

<< Vorheriges Thema
Fehlercodes

Startseite

Nächstes Thema >>
Funktionen


Funktionen

Hinweis:
Rufen Sie Power Panel spezifische Funktionen nur auf einem Power Panel auf!

Allgemeine Funktionen

    Name | Beschreibung
PpCheckPlatform | Überprüft, ob die verwendete Plattform ein Power Panel ist.

Funktionen zum Auslesen von Versionen

    Name | Beschreibung
PpGetBiosVersion | Gibt die Version des verwendeten BIOS zurück.
PpGetDllVersion | Gibt die Version der Power Panel System DLL zurück.
PpGetSmcVersion | Gibt die Version des SMC zurück.
PpGetMxcDrvVersion | Gibt die Version des MXC Treibers zurück.
PpGetMxcVersion | Gibt die Version des MXC zurück.

Funktionen, die allgemeine Informationen liefern

    Name | Beschreibung
PpGetModeNode | Liefert die aktuelle Stellung der Mode/Node Schalter.
PpGetApciId | Liefert die ID eines (optionalen) aPCI Moduls in Slot 1 oder 2 des Power Panel.
PpGetFwInfo | Liefert Informationen über die Firmware im Flash des Power Panel.
PpGetFwInfoEx | Liefert erweiterte Informationen über die Firmware im Flash des Power Panel.
PpGetFwBootStatus | Liefert den Bootstatus der Firmware im Flash des Power Panel.
PpGetTemperatureBoard | Gibt die Motherboard Temperatur des Power Panel zurück.
PpGetTemperatureCPU | Gibt die CPU Temperatur des Power Panel zurück.
PpGetUserBootLogoInfo | Gibt Informationen über ein über ein eventuell vorhandenes User Boot Logo im Flash zurück.

User LED Funktionen

    Name | Beschreibung
PpGetUserLed | Liefert den aktuellen Status der User LED.
PpSetUserLed | Setzt den Status der User LED.

MKey LED Funktionen

    Name | Beschreibung
PpGetMKeyLed | Liefert den aktuellen Status einer MKey LED.
PpSetMKeyLed | Setzt den Status einer MKey LED.
PpSetMKeyLeds | Setzt/löscht alle MKey LEDs.

Funktionen zum Auslesen der Factory Settings

    Name | Beschreibung
PpGetFsVersion | Liefert die Version der Factory Settings.
PpGetFsDisplayId | Liest die ID des verwendeten Displays aus den Factory Settings.
PpGetFsDeviceId | Liest die ID des verwendeten Power Panel aus den Factory Settings.
PpGetFsCompatibilityId | Liest die Kompatibilitäts ID des Gerätes aus den Factory Settings.
PpGetFsBrightnessMin | Liest den minimalen Grenzwert der Helligkeit aus den Factory Settings.
PpGetFsBrightnessDef | Liest den Standardwert der Helligkeit aus den Factory Settings.
PpGetFsBrightnessMax | Liest den maximalen Grenzwert der Helligkeit aus den Factory Settings.
PpGetFsContrastMin | Liest den minimalen Grenzwert des Kontrastes aus den Factory Settings.
PpGetFsContrastDef | Liest den Standardwert des Kontrastes aus den Factory Settings.
PpGetFsContrastMax | Liest den maximalen Grenzwert des Kontrastes aus den Factory Settings.

Displayfunktionen

    Name | Beschreibung
PpSetBacklightOn | Schaltet die Hintergrundbeleuchtung des Displays ein.
PpSetBacklightOff | Schaltet die Hintergrundbeleuchtung des Displays aus.
PpGetDisplayType | Liefert den Typ des verwendeten Displays.
PpCheckBrightnessAuto | Überprüft, ob die aktuelle Helligkeit des Displays mit dem Standardwert aus den Factory Settings identisch ist.
PpSetBrightnessAuto | Setzt die Helligkeit auf den Standardwert, welcher in den Factory Settings definiert ist.
PpGetBrightness | Liefert die aktuelle Helligkeit.
PpSetBrightness | Setzt die Helligkeit des Displays.
PpCheckContrastAuto | Überprüft, ob der aktuelle Kontrast des Displays mit dem Standardwert aus den Factory Settings identisch ist.
PpSetContrastAuto | Setzt den Kontrast auf den Standardwert, welcher in den Factory Settings definiert ist.
PpGetContrast | Liefert den aktuellen Kontrast.
PpSetContrast | Setzt den Kontrast des Displays.

Allgemeine System Funktionen

    Name | Beschreibung
PpReboot | Löst einen Neustart (Reboot) des Power Panel aus.

<< Vorheriges Thema
Power Panel System DLL

Startseite

Nächstes Thema >>
PpCheckBrightnessAuto


PpCheckBrightnessAuto

PpCheckBrightnessAuto

Überprüft, ob die aktuelle Helligkeit des Displays mit dem Standardwert aus den Factory Settings identisch ist.

BOOL PpCheckBrightnessAuto(
BOOL* bAuto);

Parameter

bAuto

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf TRUE oder FALSE ist.
TRUE zeigt an, dass die aktuelle Helligkeit mit dem Standardwert aus den Factory Settings identisch ist.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Funktion erfolgreich durchgeführt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpSetBrightnessAuto

<< Vorheriges Thema
Funktionen

Startseite

Nächstes Thema >>
PpCheckContrastAuto


PpCheckContrastAuto

PpCheckContrastAuto

Überprüft, ob der aktuelle Kontrast des Displays mit dem Standardwert aus den Factory Settings identisch ist.

BOOL PpCheckContrastAuto(
BOOL* bAuto);

Parameter

bAuto

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf TRUE oder FALSE ist.
TRUE zeigt an, dass der aktuelle Kontrast mit dem Standardwert aus den Factory Settings identisch ist.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Funktion erfolgreich durchgeführt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays ausgelesen werden.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpSetContrastAuto

<< Vorheriges Thema
PpCheckBrightnessAuto

Startseite

Nächstes Thema >>
PpCheckPlatform


PpCheckPlatform

PpCheckPlatform

Überprüft, ob die verwendete Plattform ein Power Panel ist.

BOOL PpCheckPlatform(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die verwendete Plattform ein Power Panel ist. Wurde kein Power Panel erkannt, so wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpCheckContrastAuto

Startseite

Nächstes Thema >>
PpGetApciId


PpGetApciId

PpGetApciId

Liefert die ID eines (optionalen) aPCI Moduls in Slot 1 oder 2 des Power Panels.

BOOL PpGetApciId(
int Slot,
TCHAR* ApciId,
int Count);

Parameter

Slot

[in] Definiert die Nummer des aPCI Slots: 1 oder 2

ApciId

[out] Zeigt auf einen Puffer für die aPCI Modul ID. Der Puffer soll mindestens 9 Elemente groß sein.

Beispiel einer aPCI ID : "3IF786.9". Ein leerer String zeigt an, dass kein Modul vorhanden ist.

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer ApciId kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die aPCI ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V0.70

Siehe auch

PpGetFwInfo

<< Vorheriges Thema
PpCheckPlatform

Startseite

Nächstes Thema >>
PpGetBiosVersion


PpGetBiosVersion

PpGetBiosVersion

Gibt die Version des verwendeten BIOS zurück.

BOOL PpGetBiosVersion(
TCHAR* BiosVersion);

Parameter

BiosVersion

[out] Zeigt auf einen Puffer für den BIOS Versionsstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die BIOS Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetApciId

Startseite

Nächstes Thema >>
PpGetBrightness


PpGetBrightness

PpGetBrightness

Liefert die aktuelle Helligkeit.

BOOL PpGetBrightness(
PUCHAR Percent);

Parameter

Percent

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Wert der aktuellen Helligkeit in Prozent beinhaltet: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Helligkeit erfolgreich ausgelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpSetBrightness

<< Vorheriges Thema
PpGetBiosVersion

Startseite

Nächstes Thema >>
PpGetContrast


PpGetContrast

PpGetContrast

Liefert den aktuellen Kontrast.

BOOL PpGetContrast(
PUCHAR Percent);

Parameter

Percent

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den aktuellen Wert des Kontrastes in Prozent enthält: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrast erfolgreich ausgelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays ausgelesen werden.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpSetContrast

<< Vorheriges Thema
PpGetBrightness

Startseite

Nächstes Thema >>
PpGetDisplayType


PpGetDisplayType

PpGetDisplayType

Liefert den Typ des verwendeten Displays.

BOOL PpGetDisplayType(
PUCHAR DisplayType);

Parameter

DisplayType

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Displaytyp enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Displaytyp erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Normalerweise liefert diese Funktion den selben Wert wie PpGetFsDisplayID. Da die Factory Settings in der Version 0 fehlerhafte Displaytypen enthalten, ist diese Funktion zum Bestimmen der Display ID zu bevorzugen.

Eine Liste aller möglichen Display IDs finden Sie unter Displaykennungen.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpGetFsDisplayID , Displaykennungen

<< Vorheriges Thema
PpGetContrast

Startseite

Nächstes Thema >>
PpGetDLLVersion


PpGetDllVersion

PpGetDllVersion

Gibt die Version der Power Panel System DLL zurück.

BOOL PpGetDllVersion(
TCHAR* DllVersion,
int Count);

Parameter

DllVersion

[out] Zeigt auf einen Puffer für den DLL Versionstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer DllVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die DLL Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetDisplayType

Startseite

Nächstes Thema >>
PpGetFsBrightnessDef


PpGetFsBrightnessDef

PpGetFsBrightnessDef

Liest den Standardwert der Helligkeit aus den Factory Settings.

BOOL PpGetFsBrightnessDef(
PUCHAR FsBrightnessDef);

Parameter

FsBrightnessDef

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Standardwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Helligkeitswert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Dieser Wert wird verwendet, wenn Sie im Power Panel Control Center die Checkbox "Auto" der Helligkeit aktivieren.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsBrightnessMin, PpGetFsBrightnessMax

<< Vorheriges Thema
PpGetDLLVersion

Startseite

Nächstes Thema >>
PpGetFsBrightnessMax


PpGetFsBrightnessMax

PpGetFsBrightnessMax

Liest den maximalen Grenzwert der Helligkeit aus den Factory Settings.

BOOL PpGetFsBrightnessMax(
PUCHAR FsBrightnessMax);

Parameter

FsBrightnessMax

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den maximalen Grenzwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der maximale Grenzwert kann niedriger sein als der minimale Grenzwert. Somit benötigt das Display inverse Werte => größter Wert = kleinste Helligkeit.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsBrightnessMin , PpGetFsBrightnessDef

<< Vorheriges Thema
PpGetFsBrightnessDef

Startseite

Nächstes Thema >>
PpGetFsBrightnessMin


PpGetFsBrightnessMin

PpGetFsBrightnessMin

Liest den minimalen Grenzwert der Helligkeit aus den Factory Settings.

BOOL PpGetFsBrightnessMin(
PUCHAR FsBrightnessMin);

Parameter

FsBrightnessMin

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den minimalen Grenzwert der Helligkeit enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der minimale Grenzwert kann höher sein als der maximale Grenzwert. Somit benötigt das Display inverse Werte => kleinster Wert = größte Helligkeit.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsBrightnessMax , PpGetFsBrightnessDef

<< Vorheriges Thema
PpGetFsBrightnessMax

Startseite

Nächstes Thema >>
PpGetFsCompatibilityId


PpGetFsCompatibilityId

PpGetFsCompatibilityId

Liest die Kompatibilitäts ID des Gerätes aus den Factory Settings

BOOL PpGetFsCompatibilityId(
PUCHAR FsCompId);

Parameter

FsCompId

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Kompatibilitäts ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Kompatibilitäts ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetFsBrightnessMin

Startseite

Nächstes Thema >>
PpGetFsContrastDef


PpGetFsContrastDef

PpGetFsContrastDef

Liest den Standardwert des Kontrastes aus den Factory Settings.

BOOL PpGetFsContrastDef(
PUCHAR FsContrastDef);

Parameter

FsContrastDef

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Standardwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrastwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Dieser Wert wird verwendet, wenn Sie im Power Panel Control Center die Checkbox "Auto" des Kontrastes aktivieren.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsContrastMin, PpGetFsContrastMax

<< Vorheriges Thema
PpGetFsCompatibilityId

Startseite

Nächstes Thema >>
PpGetFsContrastMax


PpGetFsContrastMax

PpGetFsContrastMax

Liest den maximalen Grenzwert des Kontrastes aus den Factory Settings.

BOOL PpGetFsContrastMax(
PUCHAR FsContrastMax);

Parameter

FsContrastMax

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den maximalen Grenzwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der maximale Grenzwert kann niedriger sein als der minimale Grenzwert. Somit benötigt das Display inverse Werte => größter Wert = kleinster Kontrast.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsContrastMin , PpGetFsContrastDef

<< Vorheriges Thema
PpGetFsContrastDef

Startseite

Nächstes Thema >>
PpGetFsContrastMin


PpGetFsContrastMin

PpGetFsContrastMin

Liest den minimalen Grenzwert des Kontrastes aus den Factory Settings.

BOOL PpGetFsContrastMin(
PUCHAR FsContrastMin);

Parameter

FsContrastMin

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den minimalen Grenzwert des Kontrastes enthält: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Grenzwert erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der minimale Grenzwert kann höher sein als der maximale Grenzwert. Somit benötigt das Display inverse Werte => kleinster Wert = größter Kontrast.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetFsContrastMax , PpGetFsContrastDef

<< Vorheriges Thema
PpGetFsContrastMax

Startseite

Nächstes Thema >>
PpGetFsDeviceId


PpGetFsDeviceId

PpGetFsDeviceId

Liest die ID des verwendeten Power Panel aus den Factory Settings.

BOOL PpGetFsDeviceId(
PUSHORT FsDeviceId);

Parameter

FsDeviceId

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Device ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Device ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetFsContrastMin

Startseite

Nächstes Thema >>
PpGetFsDisplayId


PpGetFsDisplayId

PpGetFsDisplayId

Liest die ID des verwendeten Displays aus den Factory Settings.

BOOL PpGetFsDisplayId(
PUCHAR FsDisplayId);

Parameter

FsDisplayId

[out] Zeigt auf eine Variable, welche nach dem Aufruf die Display ID enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Display ID erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Die Display ID definiert welches Display am Power Panel verwendet wird. Zum Beispiel verwendet das BIOS diese ID, um das Display korrekt zu initialisieren.

Eine Liste aller möglichen Display IDs finden Sie unter Displaykennungen.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

Displaykennungen

<< Vorheriges Thema
PpGetFsDeviceId

Startseite

Nächstes Thema >>
PpGetFsVersion


PpGetFsVersion

PpGetFsVersion

Liefert die Version der Factory Settings.

BOOL PpGetFsVersion(
PUCHAR FsVersion);

Parameter

FsVersion

[out] Zeigt auf eine Variable für die Version der Factory Settings.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Version der Factory Settings erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetFsDisplayId

Startseite

Nächstes Thema >>
PpGetFwBootStatus


PpGetFwBootStatus

PpGetFwBootStatus

Liefert den Bootstatus der (optionalen) Firmware, die im Flash des Power Panel abgelegt ist.

BOOL PpGetFwBootStatus(
int Slot,
PUCHAR Status);

Parameter

Slot

[in] Definiert die Firmware: 0 für das eingebaute FPGA, 1 oder 2 für aPCI Slot 1 oder 2.

Status

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den aktuellen Bootstatus enthält.

Mögliche Werte:

Wert
Konstante
Beschreibung
0
STATUS_FPGA_FILE_NFOUND
Keine FPGA Datei vorhanden.
1
STATUS_FPGA_FILE_SIZE
Falsche Größe der FPGA Datei.
2
STATUS_FPGA_NFOUND
Kein FPGA oder aPCI Modul vorhanden.
3
STATUS_FPGA_BOOT_NINIT
Der Bootmodus konnte nicht aktiviert werden.
4
STATUS_FPGA_BOOT_NDONE
Booten ist fehlgeschlagen.
5
STATUS_FPGA_BOOT_OK
Booten OK.
6
STATUS_FPGA_FILE_OLD
Alte FPGA Datei.
7
STATUS_FPGA_MISMATCH
Falsche FPGA Datei (für anderes Gerät).
8
STATUS_FPGA_DISABLED
Booten ist ausgeschaltet (im BIOS Setup).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Bootstatus der Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.04 und höher

Siehe auch

-

<< Vorheriges Thema
PpGetFsVersion

Startseite

Nächstes Thema >>
PpGetFwInfo


PpGetFwInfo

PpGetFwInfo

Liefert Informationen über die (optionale) Firmware, die im Flash des Power Panel abgelegt ist.

BOOL PpGetFwInfo(
int Slot,
TCHAR* FwInfo,
int Count);

Parameter

Slot

[in] Definiert die Firmware: 0 für das eingebaute FPGA, 1 oder 2 für aPCI Slot 1 oder 2.

FwInfo

[out] Zeigt auf einen Puffer für die Firmwareinfo. Der Puffer soll mindestens 33 Elemente groß sein.

Beispiel einer Firmwareinfo: "Ppx00.ncd 2003/01/13 15:03:52".

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer FwInfo kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen über die Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn keine Firmware gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V0.70 und höher

Siehe auch

-

<< Vorheriges Thema
PpGetFwBootStatus

Startseite

Nächstes Thema >>
PpGetFwInfoEx


PpGetFwInfoEx

PpGetFwInfoEx

Liefert erweiterte Informationen über die (optional) Firmware, die im Flash des Power Panel abgelegt ist.

BOOL PpGetFwInfoEx(
int Slot,
TCHAR* Header,
int Count,
DWORD* Size);

Parameter

Slot

[in] Definiert die Firmware: 0 für das eingebaute FPGA, 1 oder 2 für aPCI Slot 1 oder 2.

Header

[out] Zeigt auf einen Puffer, welcher nach dem Funktionsaufruf den XML Header der FPGA Datei enthält.

Wird Header auf NULL gesetzt, so wird kein XML Header zurückgeliefert.

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer Header kopiert werden (ohne abschließende 0).

Size

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Größe der Firmware in Bytes enthält.

Wird Size auf NULL gesetzt, so wird kein Größe zurückgeliefert.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen über die Firmware erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn keine Firmware gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.04 und höher

Siehe auch

-

<< Vorheriges Thema
PpGetFwInfo

Startseite

Nächstes Thema >>
PpGetMKeyLed


PpGetMKeyLed

PpGetMKeyLed

Liefert den aktuellen Status einer MKey LED.

BOOL PpGetMKeyLed(
int KeyNumber,
int Keylayer,
int* LedState);

Parameter

KeyNumber

[in] Definiert die MKey Nummer der LED: 0 bis 127.

KeyLayer

[in] Definiert den MKey Layer der LED: 0 bis 3.

LedState

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Status der LED beinhaltet: 0 = LED aus, 1 = LED blinkt langsam, 2 = LED blinkt schnell, 3 = LED ein.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.5 und höher
Header File: PpSys.h
Library: PpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

PpSetMKeyLed, PpSetMKeyLeds

<< Vorheriges Thema
PpGetFwInfoEx

Startseite

Nächstes Thema >>
PpGetModeNode


PpGetModeNode

PpGetModeNode

Liefert die aktuelle Stellung der Mode/Node Schalter.

BOOL PpGetModeNode(
PUCHAR ModeNode);

Parameter

ModeNode

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die aktuelle Stellung der Mode/Node Schalter beinhaltet: 0 bis 255.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Stellung der Mode/Node Schalter erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetMKeyLed

Startseite

Nächstes Thema >>
PpGetMxcDrvVersion


PpGetMxcDrvVersion

PpGetMxcDrvVersion

Gibt die Version des (optionalen) Matrix Controller (MXC) Treibers zurück.

BOOL PpGetMxcVersion(
TCHAR* DrvVersion, int Count);

Parameter

DrvVersion

[out] Zeigt auf einen Puffer für den MXC Treiber Versionsstring. Der Puffer soll mindestens 5 Elemente groß sein. Der zurückgegebene String hat das Format "v.yy" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer DrvVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die MXC Treiber Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.5 und höher
Header File: PpSys.h
Library: PpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

PpGetMxcVersion

<< Vorheriges Thema
PpGetModeNode

Startseite

Nächstes Thema >>
PpGetMxcVersion


PpGetMxcVersion

PpGetMxcVersion

Gibt die Version des (optionalen) Matrix Controller (MXC) zurück.

BOOL PpGetMxcVersion(
TCHAR* MxcVersion, int Count);

Parameter

MxcVersion

[out] Zeigt auf einen Puffer für den MXC Versionsstring. Der Puffer soll mindestens 4 Elemente groß sein. Der zurückgegebene String hat das Format "v.y" (dezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer MxcVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die MXC Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.5 und höher
Header File: PpSys.h
Library: PpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

PpGetMxcDrvVersion

<< Vorheriges Thema
PpGetMxcDrvVersion

Startseite

Nächstes Thema >>
PpGetSmcVersion


PpGetSmcVersion

PpGetSmcVersion

Gibt die Version des (optionalen) System Management Controller (SMC) zurück.

BOOL PpGetSmcVersion(
TCHAR* SmcVersion,
int Count);

Parameter

SmcVersion

[out] Zeigt auf einen Puffer für den SMC Versionsstring. Der Puffer soll mindestens 4 Elemente groß sein. Der zurückgegebene String hat das Format "x.x" (hexadezimal).

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer SmcVersion kopiert werden (ohne abschließende 0).

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die SMC Version erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetMxcVersion

Startseite

Nächstes Thema >>
PpGetTemperatureBoard


PpGetTemperatureBoard

PpGetTemperatureBoard

Gibt die Motherboard Temperatur des Power Panel zurück.

BOOL PpGetTemperatureBoard(
PCHAR Temperature);

Parameter

Temperature

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Temperatur in Celsius enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Temperatur erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetSmcVersion

Startseite

Nächstes Thema >>
PpGetTemperatureCpu


PpGetTemperatureCpu

PpGetTemperatureCpu

Gibt die CPU Temperatur des Power Panel zurück.

BOOL PpGetTemperatureCpu(
PCHAR Temperature);

Parameter

Temperature

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Temperatur in Celsius enthält.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Temperatur erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetTemperatureBoard

Startseite

Nächstes Thema >>
PpGetUserBootLogoInfo


PpGetUserBootLogoInfo

PpGetUserBootLogoInfo

Gibt Informationen über ein eventuell vorhandenes User Boot Logo im Flash des Power Panel zurück.

BOOL PpGetUserBootLogoInfo(
TCHAR* Comment,
int Count,
WORD* VgaMode,
DWORD* Size);

Parameter

Comment

[out] Zeigt auf einen Puffer, welcher nach dem Funktionsaufruf Informationen über das Boot Logo enthält. Der Puffer sollte mindestens 33 Elemente groß sein. Wird NULL übergeben, so wird keine Information geliefert.

Beispiel: "pp640.bmp 2003/08/21 15:03:52"

Wurde das User Boot Logo nicht mit USERLOGO.EXE erstellt, so wird ein Leerstring zurückgegeben!

Count

[in] Definiert die Anzahl der Zeichen, die in den Puffer Comment kopiert werden (ohne abschließende 0).

VgaMode

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den verwendeten VGA Modus des User Boot Logo enthält.

Diese Modi werden unterstützt (siehe Konstanten in Definitionsdatei PpSys.h):

Wert

Auflösung in Pixel

Konstante
0x0121 | 320 x 240 (QVGA) | VGA_MODE_320_240
0x0101 | 640 x 480 (VGA) | VGA_MODE_640_480
0x0103 | 800 x 600 (SVGA) | VGA_MODE_800_600
0x0105 | 1024 x 768 (XGA) | VGA_MODE_1024_768

Wird VgaMode auf NULL gesetzt, so wird kein Modus zurückgeliefert.

Size

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf die Größe des User Boot Logo in Bytes enthält.

Wird Size auf NULL gesetzt, so wird keine Größe zurückgeliefert.

Die Größe kann 0 sein, wenn das User Boot Logo nicht mit USERLOGO.EXE erstellt worden ist!

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Informationen des User Boot Logo erfolgreich zurückgegeben wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_FILE_NOT_FOUND wird zurückgeliefert, wenn kein User Boot Logo gebrannt worden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.4 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V0.70

Siehe auch

-

<< Vorheriges Thema
PpGetTemperatureCpu

Startseite

Nächstes Thema >>
PpGetUserLed


PpGetUserLed

PpGetUserLed

Liefert den aktuellen Status der User LED.

BOOL PpGetUserLed(
BOOL* State);

Parameter

State

[out] Zeigt auf eine Variable, welche nach dem Funktionsaufruf den Status der LED beinhaltet: TRUE = LED ON / FALSE = LED OFF.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gelesen wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpSetUserLed

<< Vorheriges Thema
PpGetUserBootLogoInfo

Startseite

Nächstes Thema >>
PpReboot


PpReboot

PpReboot

Löst einen Neustart (Reboot) des Power Panel aus.

void PpReboot(void);

Parameter

-

Rückgabewerte

Diese Funktion kehrt nicht zurück.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

-

<< Vorheriges Thema
PpGetUserLed

Startseite

Nächstes Thema >>
PpSetBacklightOff


PpSetBacklightOff

PpSetBacklightOff

Schaltet die Hintergrundbeleuchtung (das Backlight) des Displays aus.

BOOL PpSetBacklightOff(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Hintergrundbeleuchtung des Displays ausgeschaltet wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpSetBacklightOn

<< Vorheriges Thema
PpReboot

Startseite

Nächstes Thema >>
PpSetBacklightOn


PpSetBacklightOn

PpSetBacklightOn

Schaltet die Hintergrundbeleuchtung (das Backlight) des Displays ein.

BOOL PpSetBacklightOn(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Hintergrundbeleuchtung des Displays eingeschaltet wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpSetBacklightOff

<< Vorheriges Thema
PpSetBacklightOff

Startseite

Nächstes Thema >>
PpSetBrightness


PpSetBrightness

PpSetBrightness

Setzt die Helligkeit des Displays.

BOOL PpSetBrightness(
UCHAR Percent);

Parameter

Percent

[in] Definiert die gewünschte Helligkeit in Prozent: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die Helligkeit erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpGetBrightness

<< Vorheriges Thema
PpSetBacklightOn

Startseite

Nächstes Thema >>
PpSetBrightnessAuto


PpSetBrightnessAuto

PpSetBrightnessAuto

Setzt die Helligkeit auf den Standardwert, der in den Factory Settings definiert ist.

BOOL PpSetBrightnessAuto(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Helligkeitswert erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpCheckBrightnessAuto

<< Vorheriges Thema
PpSetBrightness

Startseite

Nächstes Thema >>
PpSetContrast


PpSetContrast

PpSetContrast

Setzt den Kontrast des Displays.

BOOL PpSetContrast(
UCHAR Percent);

Parameter

Percent

[in] Definiert den gewünschten Kontrast in Prozent: 0 bis 100.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrastwert erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays gesetzt werden.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpGetContrast

<< Vorheriges Thema
PpSetBrightnessAuto

Startseite

Nächstes Thema >>
PpSetContrastAuto


PpSetContrastAuto

PpSetContrastAuto

Setzt den Kontrast auf den Standardwert, der in den Factory Settings definiert ist.

BOOL PpSetContrastAuto(void);

Parameter

-

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der Kontrast gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

Der Kontrast kann nur bei passiven Displays gesetzt werden.

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib
BIOS: V1.00 und höher

Siehe auch

PpCheckContrastAuto

<< Vorheriges Thema
PpSetContrast

Startseite

Nächstes Thema >>
PpSetMKeyLed


PpSetMKeyLed

PpSetMKeyLed

Setzt den Status einer MKey LED.

BOOL PpSetMKeyLed(
int KeyNumber,
int Keylayer,
int LedState);

Parameter

KeyNumber

[in] Definiert die MKey Nummer der LED: 0 bis 127.

KeyLayer

[in] Definiert den MKey Layer der LED: 0 bis 3.

LedState

[in] Definiert den Status der LED: 0 = LED aus, 1 = LED blinkt langsam, 2 = LED blinkt schnell, 3 = LED ein.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.5 und höher
Header File: PpSys.h
Library: PpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

PpGetMKeyLed, PpSetMKeyLeds

<< Vorheriges Thema
PpSetContrastAuto

Startseite

Nächstes Thema >>
PpSetMKeyLeds


PpSetMKeyLeds

PpSetMKeyLeds

Setzt oder löscht alle MKey LEDs in allen MKey Layer.

BOOL PpSetMKeyLeds(
BOOL bOn);

Parameter

bOn

[in] Definiert, ob die LEDs eingeschaltet (TRUE) oder ausgeschaltet (FALSE) werden.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn die LEDs erfolgreich gesetzt bzw gelöscht wurden. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf. ERROR_NOT_SUPPORTED wird zurückgeliefert, wenn kein MXC vorhanden ist.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.5 und höher
Header File: PpSys.h
Library: PpSys.lib
MXC Treiber: V1.00 und höher

Siehe auch

PpGetMKeyLed, PpSetMKeyLed

<< Vorheriges Thema
PpSetMKeyLed

Startseite

Nächstes Thema >>
PpSetUserLed


PpSetUserLed

PpSetUserLed

Setzt den Status der User LED.

BOOL PpSetUserLed(
BOOL State);

Parameter

State

[in] Definiert den Status der LED: TRUE = LED ein, FALSE = LED aus.

Rückgabewerte

Der Rückgabewert ist TRUE, wenn der LED Status erfolgreich gesetzt wurde. Wenn die Funktion nicht korrekt ausgeführt werden kann (z. B. die Funktion wurde nicht auf einem Power Panel aufgerufen), wird FALSE zurückgegeben. Für weitere Information rufen Sie GetLastError auf.

Bemerkungen

-

Anforderungen

B&R Windows CE Version: V1.3 und höher
Header File: PpSys.h
Library: PpSys.lib

Siehe auch

PpGetUserLed

<< Vorheriges Thema
PpSetMKeyLeds

Startseite

Nächstes Thema >>
Zusätzliche Informationen


Zusätzliche Informationen

In diesem Abschnitt werden folgende Themen behandelt:

Zusätzliche Informationen

Power Panel Erkennung

Displaykennungen

Fehlercodes

<< Vorheriges Thema
PpSetUserLed

Startseite

Nächstes Thema >>
Power Panel Erkennung


Power Panel Erkennung

Um zu überprüfen, ob ihr Programm auf einem B&R Power Panel läuft, verwenden Sie die Funktion PpCheckPlatform.

Nur auf einem B&R Power Panel wird die Funktion ohne Fehler ausgeführt. Auf anderen Geräten bricht die Funktion mit dem Rückgabewert FALSE ab bzw. ist die Power Panel System DLL - und damit die Funktion - nicht vorhanden.

<< Vorheriges Thema
Zusätzliche Informationen

Startseite

Nächstes Thema >>
Displaykennungen


Displaykennung

Displaykennungen

Die folgende Tabelle enthält die Displaykennung, die von PpGetDisplayType und PpGetFsDisplayId geliefert werden.

    ID | Beschreibung
00h | Displayparameter kommen nicht aus der Tabelle in den Factory Settings.
10h | Passive Displays (STN)
11h | LCD B/W QVGA
12h | LCD COL QVGA
20h | Aktive Displays (TFT) mit QVGA Auflösung
30h | Aktive Displays (TFT) mit VGA Auflösung
40h | Aktive Displays (TFT) mit SVGA Auflösung
50h | Aktive Displays (TFT) mit XVGA Auflösung
... | Frei
F0h | Frei

<< Vorheriges Thema
Power Panel Erkennung

Startseite

Nächstes Thema >>
Fehlercodes


Fehlercodes

Alle Funktionen dieser DLL liefern Standard Windows System Fehler:

  • ERROR_INVALID_PARAMETER wenn ein falscher Parameter übergeben worden ist.
  • ERROR_IO_DEVICE wenn der Zugriff auf ein Gerät (z.B. ACCESS.bus) fehlgeschlagen ist.
  • ERROR_INVALID_HANDLE wenn ein Synchronisationsobjekt nicht angelegt werden konnte.
  • ERROR_OUTOFMEMORY wenn die Anforderung von Speicher fehlgeschlagen ist.
  • ERROR_CALL_NOT_IMPLEMENTED wenn das BIOS diese Funktion nicht unterstützt (die BIOS Version zu alt ist) oder wenn die verwendete Plattform kein Power Panel ist.
  • ERROR_NOT_SUPPORTED wenn die verwendete Plattform diese Funktion nicht unterstützt (z.B. weil kein Matrix Controller vorhanden ist).
  • ERROR_FILE_NOT_FOUND wenn eine Datei nicht gefunden wurde (z.B. Firmware oder User Boot Logo).

<< Vorheriges Thema
Displaykennungen

Startseite

Nächstes Thema >>
Konfigurationsdateien


Konfigurationsdateien

In diesem Abschnitt werden folgende Themen behandelt:

Konfigurationsdateien

Settings.reg

Start.dat

<< Vorheriges Thema
Fehlercodes

Startseite

Nächstes Thema >>
Settings.reg


Settings.reg

Allgemein

Die ASCII - Datei Settings.reg erlaubt dem Anwender ein fertiges Windows CE Image (Nk.bin) während der ersten Bootphase mit Registrykeys zu versorgen. Somit kann mit einem einfachen Texteditor z.B. der Rechnername festgelegt werden.

Aufbau

Der Aufbau der Datei Settings.reg entspricht jenen *.reg Dateien die auch unter Windows 9x/NT/2000/XP verwendet werden. Am einfachsten sind diese Dateien durch die Exportfunktion des Remote Registry Editors zu erzeugen.

Die Exportfunktion des Remote Registry Editors
Die Exportfunktion des Remote Registry Editors

Beispiel einer *.reg Datei:

REGEDIT4

[HKEY_LOCAL_MACHINE\Ident]
"Name"="EinTest"

Speicherort

Die Settings.reg muss in der Root der CF - Karte liegen. Das heißt, auf deutschen Images im Ordner \Festplatte und auf englischen Images im Ordner \Harddisk.

Die Datei Settings.reg in der Root der CF Karte
Die Datei Settings.reg in der Root der CF Karte (deutsches Image)

Abarbeitung

Die Datei Settings.reg wird folgendermassen verarbeitet:

  1. Beim Starten überprüft Windows CE ob eine Datei mit dem Namen Settings.reg in der Root der CF - Karte vorhanden ist

  2. Wird eine Settings.reg gefunden, so wird diese geparst und deren Registrykeys in die Registry eingefügt

  3. Nach dem Einfügen aller Keys wird die Datei auf Settings.bak umbenannt

    Existiert bereits eine Settings.bak, so wird diese gelöscht und durch die neue Settings.bak ersetzt!

  4. Das Gerät wird neu gebootet

Features

  • Settings.reg kann "String" und "DWORD" Werte verarbeiten

    Beispiel:

    [HKEY_LOCAL_MACHINE\Comm\PCI\DP838151\Parms\TCPIP]
    "EnableDHCP"=dword:00000000
    "IPAdr"="172.33.22.22"

  • Settings.reg kann "MULTI_SZ" Werte verarbeiten

    Beispiel:

    [HKEY_LOCAL_MACHINE\Comm\PCI\DP838151\Parms\TCPIP]
    "WINS"=hex(7):\
    31,37,32,2e,34,33,2e,33,32,2e,34,31,00,31,37,32,2e,34,33,2e,33,32,2e,34,32,\
    00,00,00,00,00,00

  • Settings.reg kann "Defaultkeys" (Keys mit der Bezeichnung "@") schreiben

    Beispiel:

    [HKEY_LOCAL_MACHINE\Software\Microsoft]
    @="Ein Default Wert"

  • Settings.reg kann Registrykeys ohne dazugehörige Werte schreiben

    Beispiel:

    [HKEY_LOCAL_MACHINE\Software\Microsoft]

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Shell]

<< Vorheriges Thema
Konfigurationsdateien

Startseite

Nächstes Thema >>
Start.dat


Start.dat

Allgemein

Die Konfigurationsdatei Start.dat läßt sich mit einer Autoexec.bat von MS-DOS vergleichen. Sie bietet die Möglichkeit Programme beim Booten von B&R Windows CE 4.1/4.2 zu starten und das Image an die eigenen Anforderungen anzupassen. Meistens wird die Start.dat dazu verwendet, anstatt des Explorers die eigene Applikation zu starten.

Speicherort

Die ASCII Datei Start.dat muss im Hauptverzeichnis der Compact Flash Karte abgelegt werden (\Harddisk), nur so wird diese von B&R Windows CE 4.1/4.2 gefunden und ausgeführt. Findet B&R Windows CE beim Booten keine Start.dat, so wird automatisch der Windows Explorer gestartet. Es wird allerdings empfohlen immer eine Start.dat zu erstellen.

Die Start.dat muss im Hauptverzeichnis der CF - Karte liegen

Kommentare

Ein Kommentar wird mit einem Semikolon eingeleitet.

; Applikation startet von Festplatte
\windows\explorer.exe

Schlüsselwörter

Schlüsselwort | Beschreibung
$S=Wert | Definiert die Größe des Datenspeichers.
WAIT=Wert | Wartezeit zwischen dem Ausführen zweier Kommandos. Die Einheit sind Millisekunden.
REGFONT=Pfad | Registriert einen beliebigen Font am CE System.
TOUCHCAL | Ist der Touch noch nicht konfiguriert, so wird wenn dieses Schlüsselwort definiert ist, die Touchkalibrierung gestartet.
COPYFILE | Kopiert eine Datei in ein bestimmtes Verzeichnis.

Beispiel einer Start.dat

;Touchkalibrierung starten
TOUCHCAL

;Memory Setzen
$S=10000

;5 Sekunden Warten
WAIT=5000

;Font MyUnicode.ttf am CE System registrieren
REGFONT=\Festplatte\MyUnicode.ttf

;Copy a file
COPYFILE \Harddisk\logoqvga.bmp \Windows\MeinLogo.bmp

;Applikation starten
\Windows\MyApp.exe

Sonstiges

  • Die Abarbeitung der einzelnen Kommandos erfolgt asynchron.
  • Die Start.dat ist eine ASCII Datei.
  • Wird keine Start.dat angelegt, so startet B&R Windows CE 4.1/4.2 immer mit dem Explorer als GUI.
  • Sie können B&R Notepad oder Microsoft Wordpad verwenden, um diese Datei zu bearbeiten.

Siehe auch:

  • B&R Notepad - ein ASCII/UNICODE Texteditor

<< Vorheriges Thema
Settings.reg

Startseite

Nächstes Thema >>
Tools


Tools

In diesem Abschnitt werden folgende Themen behandelt:

Tools

B&R CE TimeSync

B&R Control Center

B&R Notepad

B&R Registry Editor

Configuration Manager

Mobile Panel Control Center

Power Panel Control Center

RegSave

RegSvrCE

Server Applet

SetRotation

Touchscreen Applet

<< Vorheriges Thema
Start.dat

Startseite

Nächstes Thema >>
B&R CE TimeSync


B&R CE TimeSync

Allgemein

Mit dem Programm CESntp.exe können Sie die Systemzeit des CE-Gerätes mit jedem beliebigen SNTP-Server synchronisieren.

Hinweis:
Dieses Programm wurde ab der Version V2.0 durch den Microsoft SNTP - Service ersetzt.

Bedienung des Programmes per GUI

Starten Sie das Programm mit einem Klick auf den Shortcut B&R CE TimeSync im Menü Accessories.

Öffnen von "B&R CE TimeSync"
Öffnen von "B&R CE TimeSync"

Sie können nun in die Textbox "SNTP Server" die IP-Adresse oder den Computernamen des SNTP Servers eingeben:

Definieren Sie den SNTP Server
Definieren Sie den SNTP Server

Nach einem Klick auf "Get Time!" wird die Uhrzeit synchronisiert.

Die Uhrzeit wurde synchronisiert
Die Uhrzeit wurde synchronisiert

Bedienung des Programmes per Kommandozeile

Sie können B&R CE TimeSync auch von der Kommandozeile aus bedienen. Der Aufruf lautet wie folgt:

CESntp <Computername>

Beispiel:

CESntp ntp.nasa.gov

Hinweis:
Im Kommandozeilenmodus erhalten Sie keine Bildschirmausgaben.

Beachten Sie bitte in diesem Zusammenhang die Einstellung "Uhr autom. auf Sommer / Winterzeit umstellen" im "Datum / Uhrzeiteneigenschaften" Dialog!

Anforderungen

B&R Windows CE Version: V1.0 <> V1.5

<< Vorheriges Thema
Tools

Startseite

Nächstes Thema >>
B&R Control Center


B&R Control Center

Das B&R Control Center dient zur Konfiguration und zur Anzeige von Informationen eines B&R Gerätes. Es werden B&R Power Panel und Mobile Panel Geräte unterstützt. Sie können das Applet über die Systemsteuerung starten. Je nach verwendetem Gerät wird das B&R Control Center mit einem passendem Symbol in der Systemsteuerung angezeigt.

Das B&R Control Center in der Systemsteuerung
Das B&R Control Center in der Systemsteuerung

Folgende Registerkarten stehen zur Auswahl:

  • Display
  • Keys
  • LEDs
  • Interfaces
  • Temperatures
  • User Boot Logo
  • Factory Settings
  • Versions

<< Vorheriges Thema
B&R CE TimeSync

Startseite

Nächstes Thema >>
Display


Display

Hier können Sie Online die Helligkeit (Hintergrundbeleuchtung) des Displays und den Kontrast einstellen und spezielle Displayeinstellungen durchführen.

Die Registerkarte Display im B&R Control Center
Die Registerkarte Display im B&R Control Center

Der Kontrast kann nur bei einem passiven Display eingestellt werden. Bei einem aktiven Display (TFT) haben Kontraständerungen keine Auswirkung. Abhängig vom verwendeten Display sind die Eingabefelder für den Kontrast gesperrt.

Sie können Helligkeit und Kontrast nur im Bereich der vom Display vorgegebenen Grenzwerte einstellen. Das heißt, bei verschiedenen Displaytypen haben Änderungen um denselben Prozentwert unterschiedliche Auswirkungen.

So ändern Sie die Helligkeit

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Helligkeitswert ein, mit dem das Display betrieben werden soll.

So schalten Sie die Helligkeit auf die Fabrikseinstellung

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.

So ändern Sie den Kontrast

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Kontrastwert ein, mit dem das Display betrieben werden soll.

So schalten Sie den Kontrast auf die Fabrikseinstellung

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.

Hinweise:
Die Prozentwerte für Helligkeit und Kontrast werden abhängig vom tatsächlich möglichen Einstellbereich des Displays (siehe auch Factory Settings) "abgestuft". Das heißt, z.B. die Prozentwerte 16, 17 und 18 können den selben physikalischen Wert ergeben, der zum Display geschrieben wird und damit die selbe Helligkeits- oder Kontrasteinstellung.

Die geänderten Einstellungen werden zwar Online angezeigt, aber nur dann im System gemerkt (und nach einem Neustart des Systems verwendet), wenn das B&R Control Center mit OK beendet wird.

Die eingestellten Werte sind unabhängig von den im BIOS Setup eingestellten Werten, d.h. bis Windows CE gebootet ist, werden die im BIOS eingestellten Werte verwendet (siehe BIOS Setup Menü Motherboard Device Configuration > Video and Flat Panel Configuration). Die vom BIOS eingestellten Werte werden nur beim ersten Aufruf des B&R Control Center übernommen.

Advanced Display Settings

Durch Klicken auf Advanced können Sie spezielle Einstellungen für die Displayanzeige durchführen.

Der Advanced Display Settings Dialog im B&R Control Center
Der Advanced Display Settings Dialog im B&R Control Center

So ändern Sie den Anzeigewinkel des Displays

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Wählen Sie im Dialog Advanced Display Settings unter Screen Rotation in der Liste Rotation Angle den gewünschten Anzeigewinkel. Sie können dabei unter "0 degrees", "90 degrees", "180 degrees" und "270 degrees" wählen.
  4. Klicken Sie auf OK.

Achtung: Der ausgewählte Anzeigewinkel wird sofort nach Beenden des Dialogs mit OK eingestellt. Das kann durch die geänderte Ansicht eine nachfolgende Bedienung mit der Maus erschweren. Weiters wird nach einer Änderung des Anzeigewinkels automatisch die Touch Screen Kalibrierung gestartet. Die Neukalibrierung kann durch Deaktivieren des Kontrollkästchens Calibrate Touch Screen after change ausgeschaltet werden.

Wenn der verwendete Displaytreiber keine Änderung des Anzeigewinkels unterstützt, wird in der Liste Rotation Angle nur "Not supported" als einziger Eintrag angezeigt und eine Auswahl ist nicht möglich.

So schalten Sie die Glättung der Bildschirmschrift ein oder aus

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Enable Antialiased Fonts.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Glättung der Bildschirmschrift geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des B&R Control Center mit einem Dialog aufgefordert.

So blenden Sie den Mauszeiger ein oder aus

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Deaktivieren oder aktivieren Sie das Kontrollkästchen Hide cursor.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Anzeige des Mauszeigers geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des B&R Control Center mit einem Dialog aufgefordert.

<< Vorheriges Thema
B&R Control Center

Startseite

Nächstes Thema >>
Keys


Keys

Hier können Sie optionale gerätespezifische Tasten einstellen und Informationen über die Tasten anzeigen.

Hinweis: Diese Registerkarte wird nur angezeigt, wenn das Gerät Tasten bzw. LEDs besitzt. Das heißt, es muss ein Matrix Controller (MXC) vorhanden sein.

Die Registerkarte Keys im B&R Control Center
Die Registerkarte Keys im B&R Control Center

Die Scancodes der Tasten und der Modus für das Umschalten zwischen den Ebenen müssen mit einer Tastenkonfigurationsdatei definiert werden. Diese Datei kann mit dem B&R Key Editor erstellt werden. Die Tasten können in bis zu vier Ebenen bedient werden.

So ändern Sie die aktive Tastenebene

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Geben Sie auf der Registerkarte Keys unter Key Layer eine Ebenennummer (Number) zwischen 1 und 4 ein und klicken Sie auf Apply. Die aktuelle Ebenennummer wird rechts neben der eingegebenen Nummer angezeigt.

Hinweis: Wenn keine gültige Tastenkonfiguration geladen ist, kann die Ebenennummer nicht eingestellt werden.

So laden Sie eine neue Konfiguration auf das Gerät

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Klicken Sie auf der Registerkarte Keys unter Scan Codes auf Download. Es wird folgender Dialog angezeigt:

    Der Key Configuration Download Dialog im B&R Control Center
    Der Key Configuration Download Dialog im B&R Control Center

  3. Geben Sie unter File den Namen der Tastenkonfigurationsdatei ein oder wählen Sie eine Datei aus.
  4. Klicken Sie auf Start.

Hinweis: Der Status der Scancodes wird nach Beenden des Dialogs auf der Registerkarte Keys angezeigt.

So sichern Sie eine bestehende Konfiguration vom Gerät

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Klicken Sie auf der Registerkarte Keys unter Scan Codes auf Upload. Es wird folgender Dialog angezeigt:

    Der Key Configuration Upload Dialog im B&R Control Center
    Der Key Configuration Upload Dialog im B&R Control Center

  3. Geben Sie unter File den Namen der Tastenkonfigurationsdatei ein oder wählen Sie eine Datei aus.
  4. Klicken Sie auf Start.

So zeigen Sie die Zustände der gerätespezifischen Tasten an

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Klicken Sie auf der Registerkarte Keys unter Key Matrix auf Show.

Der Key Matrix Dialog im B&R Control Center
Der Key Matrix Dialog im B&R Control Center

Gedrückte Tasten werden mit einer "1" angezeigt, nicht gedrückte Tasten mit einer "0". Die Nummer der ersten gedrückten Taste wird in der letzten Zeile des Dialogs angezeigt. Der Dialog wird automatisch aktualisiert, wenn eine Taste betätigt wird.

Hinweis: Die Scancodes der Tasten müssen für die Anzeige der Tastenmatrix nicht konfiguriert sein. Die Auswertung bereits konfigurierter Tasten wird während der Anzeige der Tastenmatrix deaktiviert, damit die Tasten betätigt werden können, ohne dass Windows darauf reagiert.

<< Vorheriges Thema
Display

Startseite

Nächstes Thema >>
LEDs


LEDs

Hier können Sie optionale gerätespezifische LEDs schalten.

Hinweis: Diese Registerkarte wird nur angezeigt, wenn das Gerät Tasten bzw. LEDs besitzt. Das heißt, es muss ein Matrix Controller (MXC) vorhanden sein.

Die Registerkarte LEDs im B&R Control Center
Die Registerkarte LEDs im B&R Control Center

Die LEDs können in bis zu vier Ebenen geschaltet werden (siehe auch Key Layer auf der Registerkarte Keys).

So schalten Sie eine LED ein oder aus

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte LEDs.
  3. Geben Sie eine LED Nummer (Number) zwischen 0 und 127 ein. Bei Änderung der Nummer wird der aktuelle LED Zustand angezeigt.
  4. Geben Sie eine Nummer zwischen 1 und 4 für die Ebene (Layer) ein, in der die LED gesetzt werden soll. Bei Änderung der Nummer wird der aktuelle LED Zustand angezeigt.
  5. Klicken Sie auf einen der LED Zustände Off, Slow blinking, Fast blinking, On um die LED umzuschalten.

Damit der neue LED Zustand sofort angezeigt wird, wenn die eingegebene Ebene ungleich der aktiven Ebene ist, aktivieren Sie das Kontrollkästchen Automatic layer change.

Um alle LEDs in allen Ebenen in den selben Zustand zu schalten, klicken Sie auf All LEDs.

<< Vorheriges Thema
Keys

Startseite

Nächstes Thema >>
Temperatures


Temperatures

Hier werden Temperaturwerte des Gerätes angezeigt.

Die Registerkarte Temperatures im B&R Control Center
Die Registerkarte Temperatures im B&R Control Center

So zeigen Sie die Temperaturwerte des Gerätes an

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Temperatures.

Mit CPU Intern wird die Temperatur der CPU angezeigt, mit Board I/O wird die Temperatur des Motherboard angezeigt. Die angezeigten Werte werden einmal pro Sekunde aktualisiert.

<< Vorheriges Thema
LEDs

Startseite

Nächstes Thema >>
Interfaces


Interfaces

Hier können Sie die User LED ein- und ausschalten und Informationen über Schnittstellen des B&R Gerätes ansehen.

Die Registerkarte Interfaces im B&R Control Center
Die Registerkarte Interfaces im B&R Control Center

Es werden Informationen über die Mode / Node Schalter und eventuell eingebaute Schnittstellenmodule in aPCI Slot 1 und aPCI Slot 2 angezeigt. Die Anzeige der Mode / Node Schalter wird bei Änderung der Schalterstellung automatisch aktualisiert.

So schalten Sie die User LED ein oder aus

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Aktivieren oder deaktivieren Sie auf der Registerkarte Interfaces das Kontrollkästchen User LED.

So zeigen Sie Informationen über die aPCI Firmware an (nur auf B&R Power Panel Geräten möglich)

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Interfaces und klicken Sie unter aPCI Slot 1 oder aPCI Slot 2 auf Firmware.

Es wird ein Dialog mit Informationen über die auf dem B&R Gerät installierte (optionale) Firmware angezeigt.

Der aPCI Firmware Dialog im B&R Control Center
Der aPCI Firmware Dialog im B&R Control Center

Es werden folgende Daten über die Firmware angezeigt: eine kurze Info (besteht standardmäßig aus Modulkennung, Datum und Version), der Status des Boot Vorgangs und zusätzliche Daten aus dem Header der gebrannten FPGA Datei unter Extended Info. Wenn keine Firmware im Flash Speicher vorhanden ist, wird als Info "None" angezeigt.

Hinweis: Auf bestimmten B&R Power Panel Geräten können zusätzliche Schnittstellenmodule gesteckt werden (aPCI Module). Einige aPCI Module müssen vom BIOS mit einer passenden Firmware programmiert werden, bevor sie als "normale" PCI Geräte erkannt werden. Dazu muss die passende Firmware in den Flash Speicher des B&R Power Panel gebrannt worden sein.

<< Vorheriges Thema
Temperatures

Startseite

Nächstes Thema >>
User Boot Logo


User Boot Logo

Hier erhalten Sie Informationen über das optionale User Boot Logo.

Die Registerkarte User Boot Logo im B&R Control Center
Die Registerkarte User Boot Logo im B&R Control Center

Alternativ zum eingebauten B&R Boot Logo kann ein vom Anwender erstelltes Bitmap als Boot Logo angezeigt werden. Dieses muss mit der auf den BIOS Upgrade Disks enthaltenen Windowsanwendung USERLOGO.EXE konvertiert und mit dem ebenfalls auf den BIOS Upgrade Disks enthaltenen DOS Programm XFLASH.EXE in den Flash Speicher des Gerätes gebrannt werden.

Hinweis: Die Anzeige des User Boot Logo muss im BIOS Setup aktiviert sein.

So zeigen Sie Informationen über das User Boot Logo an

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte User Boot Logo.

Es werden folgende Daten des User Boot Logo angezeigt: eine kurze Info (besteht standardmäßig aus Namen und Datum/Uhrzeit des verwendeten Bitmap), die Auflösung des verwendeten Bitmap unter Resolution und die Größe des User Boot Logo im Flash Speicher unter Size. Wenn kein User Boot Logo im Flash Speicher vorhanden ist, wird als Info "None" angezeigt.

<< Vorheriges Thema
Interfaces

Startseite

Nächstes Thema >>
Factory Settings


Factory Settings

Hier werden die von B&R auf das Gerät fest programmierten Fabrikseinstellungen angezeigt. Diese kennzeichnen unter anderem den Gerätetyp, den Displaytyp sowie die Grenzwerte für Helligkeit und Kontrast.

Die Registerkarte Factory Settings im B&R Control Center
Die Registerkarte Factory Settings im B&R Control Center

So zeigen Sie die Fabrikseinstellungen an

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Factory Settings.

Es werden folgende Fabrikseinstellungen angezeigt (alle Werte werden hexadezimal ausgegeben).

Parameter | Wert (Beispiel) | Bedeutung
Version | 03 | Version der Fabrikseinstellungen.
Device ID | 1697 | Kennung des Gerätes.
Compatibility ID | 00 | Die Kompatibilitätskennung dient zur Erkennung von Hardwareänderungen, die für gerätespezifische Software von Bedeutung sind.
Display ID | 30 | Kennzeichnet das Display. Anhand dieser Kennung wird das Display vom BIOS mit den entsprechenden Displayparametern initialisiert.
Brightness | D5 EA FF | Minimal-, Default- und Maximalwert für die Helligkeitseinstellung des verwendeten Displays.
Contrast | 00 46 FF | Minimal-, Default- und Maximalwert für die Kontrasteinstellung des verwendeten Displays.

<< Vorheriges Thema
User Boot Logo

Startseite

Nächstes Thema >>
Versions


Versions

Hier erhalten Sie Informationen über die Versionen des installierten BIOS, eines eventuell vorhandenen System Management Controller (SMC) und Matrix Controller (MXC), der Firmware der On-Board FPGA Bausteine und des Control Center selbst.

Die Registerkarte Versions im B&R Control Center
Die Registerkarte Versions im B&R Control Center

So zeigen Sie die Versionen an

  1. Wählen Sie Start > Settings > Control Panel und doppelklicken Sie dann auf B&R Control Center.
  2. Wählen Sie die Registerkarte Versions.

Wenn kein System Management Controller (SMC) oder Matrix Controller (MXC) vorhanden ist, wird als Version "None" ausgegeben.

Um Informationen über die auf dem Gerät installierte Firmware für die On-Board FPGAs anzuzeigen, klicken Sie auf FPGA oder FPGA1. Es wird ein Dialog mit Informationen über die auf dem B&R Gerät installierte (optionale) Firmware angezeigt.

Der FPGA Firmware Dialog im B&R Control Center
Der FPGA Firmware Dialog im B&R Control Center

Es werden folgende Daten über die Firmware angezeigt: eine kurze Info (besteht standardmäßig aus Modulkennung, Datum und Version), der Status des Boot Vorgangs und zusätzliche Daten aus dem Header der gebrannten FPGA Datei unter Extended Info. Wenn keine Firmware im Flash vorhanden ist, wird als Info "None" angezeigt.

Hinweis: Die notwendige Firmware ist abhängig vom Gerätetyp. Bestimmte Gerätetypen besitzen einen oder mehrere On-Board FPGA Bausteine, die für die ordnungsgemäße Funktion des Gerätes (z.B. Displayansteuerung) vom BIOS programmiert werden müssen. Dazu muss die passende Firmware in den Flash Speicher des Gerätes gebrannt worden sein.

Zum Anzeigen der Versionsinformation des B&R Control Center klicken Sie auf About.

Der About Dialog im B&R Control Center
Der About Dialog im B&R Control Center

<< Vorheriges Thema
Factory Settings

Startseite

Nächstes Thema >>
B&R Notepad


B&R Notepad

Allgemein

Das B&R Notepad ist ein einfacher ASCII/UNICODE Texteditor. Sie können den Editor verwenden um z.B. die Datei Start.dat zu bearbeiten.

Hinweis:
Dieses Programm wurde ab der Version V2.0 durch das Microsoft Wordpad ersetzt.

So starten sie das B&R Notepad

  • Wählen sie Start > Programme > Accessories, und klicken sie dann auf das B&R Notepad Icon [image].

Starten des B&R Notepads
Starten des B&R Notepads

Hinweis:

Von der Kommandozeile aus starten Sie das B&R Notepad mit dem Befehl BrEdit.

Das B&R Notepad startet mit dieser Oberfläche:

Die Oberfläche des B&R Notepads
Die Oberfläche des B&R Notepads

<< Vorheriges Thema
Versions

Startseite

Nächstes Thema >>
B&R Registry Editor


B&R Registry Editor

  • Sie starten den B&R Registry Editor mit einem Klick auf den Link B&R Registry Editor im Startmenüordner Accessories.

Das Icon von RegEdit
Die Verknüpfung mit dem B&R Registry Editor

  • Sie können das Programm von der Kommandozeile aus mit dem Befehl RegEdit starten.

  • Die Bedienung des B&R Registry Editor ist ähnlich zu den Editoren von Windows XP.

Die Oberfläche von RegEdit
Die Oberfläche von RegEdit

Hinweis:
Vergessen Sie nicht, nach dem Beenden des Registryeditors die Registry zu speichern!

Siehe auch:

  • Benötigte Software
  • Speichern der Registry
  • Regsave.exe

<< Vorheriges Thema
B&R Notepad

Startseite

Nächstes Thema >>
Configuration Manager


Configuration Manager

Der Configuration Manager bietet ihnen folgende Möglichkeiten:

  • Speichern der Registry

    Dabei wird der komplette Inhalt der Registry auf die CF-Karte geschrieben und somit speicherresistent abgelegt.

  • Herstellen der original Registry

    Dabei wird die aktuell verwendete Registry gelöscht, womit der Urzustand des Images wieder hergestellt wird.

  • Gerät neu starten

    Es wird ein Warmstart ausgelöst.

Sie finden dieses Controlapplet in der Systemsteuerung ihres Windows CE-Gerätes.

Das Control Applet in der Systemsteuerung
Das Control Applet in der Systemsteuerung

Nach dem Start des Configuration Manager sehen Sie einen Dialog mit drei Registerkarten:

Die Oberfläche des Configuration Managers
Die Oberfläche des Configuration Managers

Hinweis:
Wird die original Registry wiederhergestellt (Befehl "Restore Settings"), so gehen alle Änderungen die in der Registry abgespeichert wurden verloren!
Beim Befehl "Restore Settings" wird automatisch ein Reboot ausgelöst!

Siehe auch:

  • Speichern der Registry
  • Regsave.exe

<< Vorheriges Thema
B&R Registry Editor

Startseite

Nächstes Thema >>
Mobile Panel Control Center


Mobile Panel Control Center

Das Mobile Panel Control Center dient zur Konfiguration und zur Anzeige von Informationen eines B&R Mobile Panel. Sie können das Applet über die Systemsteuerung starten.

Das Mobile Panel Control Center in der Systemsteuerung
Das Mobile Panel Control Center in der Systemsteuerung

Folgende Registerkarten stehen zur Auswahl:

  • Display
  • User Boot Logo
  • Interfaces
  • Temperatures
  • Factory Settings
  • Versions

<< Vorheriges Thema
Configuration Manager

Startseite

Nächstes Thema >>
Display


Display

Hier können Sie Online die Helligkeit (Hintergrundbeleuchtung) des Displays und den Kontrast einstellen.

Die Registerkarte Display im Mobile Panel Control Center
Die Registerkarte Display im Mobile Panel Control Center

Der Kontrast kann nur bei einem passiven Display (LCD im üblichen Sprachgebrauch) eingestellt werden. Bei einem aktiven Display (TFT) haben Kontraständerungen keine Auswirkung. Abhängig vom verwendeten Mobile Panel Typ sind die Eingabefelder für den Kontrast gesperrt.

Sie können Helligkeit und Kontrast nur im Bereich der vom Display vorgegebenen Grenzwerte einstellen. Das heißt, bei verschiedenen Displaytypen haben Änderungen um denselben Prozentwert unterschiedliche Auswirkungen.

So schalten Sie die Helligkeit auf die Fabrikseinstellung

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.

So ändern Sie die Helligkeit

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Helligkeitswert ein, mit dem das Display betrieben werden soll.

So schalten Sie den Kontrast auf die Fabrikseinstellung

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.

So ändern Sie den Kontrast

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Kontrastwert ein, mit dem das Display betrieben werden soll.

Hinweise:
Die geänderten Einstellungen werden zwar Online angezeigt, aber nur dann im System gemerkt (und nach einem Neustart des Systems verwendet), wenn das Mobile Panel Control Center mit OK beendet wird.

Die eingestellten Werte sind unabhängig von den im BIOS Setup eingestellten Werten, d.h. bis Windows CE gebootet ist, werden die im BIOS eingestellten Werte verwendet (siehe BIOS Setup Menü Motherboard Device Configuration > Video and Flat Panel Configuration).
Nur beim ersten Aufruf des Mobile Panel Control Center werden die vom BIOS eingestellten Werte übernommen.

Advanced Display Settings

Durch Klicken auf Advanced können Sie spezielle Einstellungen für die Displayanzeige durchführen.

Der Advanced Display Settings Dialog im Mobile Panel Control Center
Der Advanced Display Settings Dialog im Mobile Panel Control Center

So ändern Sie den Anzeigewinkel des Displays

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Wählen Sie im Dialog Advanced Display Settings unter Screen Rotation in der Liste Rotation Angle den gewünschten Anzeigewinkel aus. Sie können dabei unter "0 degrees", "90 degrees", "180 degrees" und "270 degrees" wählen.
  4. Klicken Sie auf OK.

Achtung: Der ausgewählte Anzeigewinkel wird sofort nach Beenden des Dialogs mit OK eingestellt. Das kann durch die geänderte Ansicht eine nachfolgende Bedienung mit der Maus erschweren. Weiters wird nach einer Änderung des Anzeigewinkels automatisch die Touch Screen Kalibrierung gestartet. Die Neukalibrierung kann durch Deaktivieren des Kontrollkästchens Calibrate Touch Screen after change ausgeschaltet werden.

Wenn der verwendete Displaytreiber keine Änderung des Anzeigewinkels unterstützt, wird in der Liste Rotation Angle nur "Not supported" als einziger Eintrag angezeigt und eine Auswahl ist nicht möglich.

Sie können den Anzeigewinkel des Displays auch mit der Kommandozeilenutility "SetRotation.exe" ändern.

So schalten Sie die Glättung der Bildschirmschrift ein oder aus

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Enable Antialiased Fonts.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Glättung der Bildschirmschrift geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des Mobile Panel Control Center mit einem Dialog aufgefordert.

So blenden Sie den Mauszeiger ein oder aus

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Deaktivieren oder aktivieren Sie das Kontrollkästchen Hide cursor.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Anzeige des Mauszeigers geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des Mobile Panel Control Center mit einem Dialog aufgefordert.

<< Vorheriges Thema
Mobile Panel Control Center

Startseite

Nächstes Thema >>
Factory Settings


Factory Settings

Hier werden die von B&R auf das Mobile Panel fest programmierten Fabrikseinstellungen angezeigt. Diese kennzeichnen unter anderem den Gerätetyp, den Displaytyp sowie die Grenzwerte für Helligkeit und Kontrast.

Die Registerkarte Factory Settings im Mobile Panel Control Center
Die Registerkarte Factory Settings im Mobile Panel Control Center

So zeigen Sie die Fabrikseinstellungen an:

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Factory Settings aus.

Es werden folgende Fabrikseinstellungen angezeigt (alle Werte werden hexadezimal ausgegeben).

Parameter | Wert (Beispiel) | Bedeutung
Version | 03 | Version der Fabrikseinstellungen.
Device ID | 1697 | Kennung des Mobile Panel Gerätes.
Compatibility ID | 00 | Die Kompatibilitätskennung dient zur Erkennung von Hardwareänderungen, die für Mobile Panel spezifische Software von Bedeutung sind.
Display ID | 30 | Kennzeichnet das Display. Anhand dieser Kennung wird das Display vom BIOS mit den entsprechenden Displayparametern initialisiert.
Brightness | D5 EA FF | Minimal-, Default- und Maximalwert für die Helligkeitseinstellung des verwendeten Displays.
Contrast | 00 46 FF | Minimal-, Default- und Maximalwert für die Kontrasteinstellung des verwendeten Displays.

<< Vorheriges Thema
Display

Startseite

Nächstes Thema >>
Interfaces


Interfaces

Hier können Sie Informationen über Schnittstellen des Mobile Panel ansehen.

Die Registerkarte Interfaces im Mobile Panel Control Center
Die Registerkarte Interfaces im Mobile Panel Control Center

So zeigen Sie die Schnittstelleninformationen an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Interfaces aus.

Es werden Informationen über die Mode / Node Schalter angezeigt. Die Anzeige der Mode / Node Schalter wird bei Änderung der Schalterstellung automatisch aktualisiert.

<< Vorheriges Thema
Factory Settings

Startseite

Nächstes Thema >>
Temperatures


Temperatures

Hier werden Temperaturwerte des Mobile Panel angezeigt.

Die Registerkarte Temperatures im Mobile Panel Control Center
Die Registerkarte Temperatures im Mobile Panel Control Center

So zeigen Sie die Temperaturwerte des Mobile Panel an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Temperatures.

Mit CPU Intern wird die Temperatur der CPU angezeigt, mit Board I/O wird die Temperatur des Motherboard angezeigt. Die angezeigten Werte werde einmal pro Sekunde aktualisiert.

<< Vorheriges Thema
Interfaces

Startseite

Nächstes Thema >>
User Boot Logo


User Boot Logo

Hier erhalten Sie Informationen über ein auf dem Mobile Panel installiertes (optionales) User Boot Logo.

Die Registerkarte User Boot Logo im Mobile Panel Control Center
Die Registerkarte User Boot Logo im Mobile Panel Control Center

Alternativ zum B&R spezifischen Boot Logo kann ein vom Anwender erstelltes Bitmap als Boot Logo angezeigt werden. Dieses muss mit der auf den Mobile Panel Upgrade Disks enthaltenen Utility USERLOGO.EXE konvertiert und mit der Utility XFLASH.EXE in das Flash des Mobile Panel gebrannt werden.

Hinweis: Die Anzeige des Boot Logo muss im BIOS Setup aktiviert sein.

So zeigen Sie Informationen über das User Boot Logo an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte User Boot Logo.

Es werden folgende Daten des User Boot Logo angezeigt: eine kurze Info (besteht standardmäßig aus Namen und Datum/Uhrzeit des verwendeten Bitmap), die Auflösung des verwendeten Bitmap unter Resolution und die Größe des User Boot Logo im Flash unter Size. Wenn kein User Boot Logo im Flash vorhanden ist, wird als Info "None" angezeigt.

<< Vorheriges Thema
Temperatures

Startseite

Nächstes Thema >>
Versions


Versions

Hier erhalten Sie Informationen über die Versionen des installierten BIOS, eines eventuell vorhandenen System Management Controller (SMC) und Matrix Controller (MXC), der Fabrikseinstellungen (Factory Settings), der im System installierten Mobile Panel System DLL (diese ist notwendig für Mobile Panel spezifische Funktionen wie z.B. die Helligkeitseinstellung) und des installierten MXC Treibers (MXC Driver).

Die Registerkarte Versions im Mobile Panel Control Center
Die Registerkarte Versions im Mobile Panel Control Center

So zeigen Sie die Versionen an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Versions.

Wenn kein System Management Controller (SMC), Matrix Controller (MXC) oder MXC Treiber vorhanden ist, wird als Version "None" ausgegeben.

Zum Anzeigen der Versionsinformation des Mobile Panel Control Center klicken Sie auf About.

So zeigen Sie Informationen über die FPGA Firmware an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Mobile Panel Control Center.
  2. Wählen Sie die Registerkarte Versions und klicken Sie auf 1st FPGA oder 2nd FPGA.

Es wird ein Dialog mit Informationen über die auf dem Mobile Panel installierte (optionale) Firmware angezeigt.

Der Firmware Dialog im Mobile Panel Control Center
Der Firmware Dialog im Mobile Panel Control Center

Es werden folgende Daten über die Firmware angezeigt: eine kurze Info (besteht standardmäßig aus Modulkennung, Datum und Version), der Status des Boot Vorgangs und zusätzliche Daten aus dem Header der gebrannten FPGA Datei unter Extended Info. Wenn keine Firmware im Flash vorhanden ist, wird als Info "None" angezeigt.

Hinweis: Die notwendige Firmware ist abhängig vom Gerätetyp. Bestimmte Mobile Panel Typen besitzen ein oder zwei On-Board FPGA Bausteine, die für die ordnungsgemäße Funktion des Mobile Panel (z.B. Displayansteuerung) vom BIOS programmiert werden muss. Dazu muss die passende Firmware in das Flash des Mobile Panel gebrannt worden sein.

<< Vorheriges Thema
User Boot Logo

Startseite

Nächstes Thema >>
Power Panel Control Center


Power Panel Control Center

Das Power Panel Control Center dient zur Konfiguration und zur Anzeige von Informationen eines B&R Power Panel. Sie können das Applet über die Systemsteuerung starten.

Das Power Panel Control Center in der Systemsteuerung
Das Power Panel Control Center in der Systemsteuerung

Folgende Registerkarten stehen zur Auswahl:

  • Display
  • User Boot Logo
  • Interfaces
  • Temperatures
  • Factory Settings
  • Versions

<< Vorheriges Thema
Versions

Startseite

Nächstes Thema >>
Display


Display

Hier können Sie Online die Helligkeit (Hintergrundbeleuchtung) des Displays und den Kontrast einstellen.

Die Registerkarte Display im Power Panel Control Center
Die Registerkarte Display im Power Panel Control Center

Der Kontrast kann nur bei einem passiven Display (LCD im üblichen Sprachgebrauch) eingestellt werden. Bei einem aktiven Display (TFT) haben Kontraständerungen keine Auswirkung. Abhängig vom verwendeten Power Panel Typ sind die Eingabefelder für den Kontrast gesperrt.

Sie können Helligkeit und Kontrast nur im Bereich der vom Display vorgegebenen Grenzwerte einstellen. Das heißt, bei verschiedenen Displaytypen haben Änderungen um denselben Prozentwert unterschiedliche Auswirkungen.

So schalten Sie die Helligkeit auf die Fabrikseinstellung

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Power Panel Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.

So ändern Sie die Helligkeit

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Power Panel Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Brightness das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Helligkeitswert ein, mit dem das Display betrieben werden soll.

So schalten Sie den Kontrast auf die Fabrikseinstellung

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Power Panel Control Center.
  2. Aktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.

So ändern Sie den Kontrast

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Power Panel Control Center.
  2. Deaktivieren Sie auf der Registerkarte Display unter Kontrast das Kontrollkästchen Auto.
  3. Stellen Sie den Schieberegler auf den Kontrastwert ein, mit dem das Display betrieben werden soll.

Hinweise:
Die geänderten Einstellungen werden zwar Online angezeigt, aber nur dann im System gemerkt (und nach einem Neustart des Systems verwendet), wenn das Power Panel Control Center mit OK beendet wird.

Die eingestellten Werte sind unabhängig von den im BIOS Setup eingestellten Werten, d.h. bis Windows CE gebootet ist, werden die im BIOS eingestellten Werte verwendet (siehe BIOS Setup Menü Motherboard Device Configuration > Video and Flat Panel Configuration).
Nur beim ersten Aufruf des Power Panel Control Center werden die vom BIOS eingestellten Werte übernommen.

Advanced Display Settings

Durch Klicken auf Advanced können Sie spezielle Einstellungen für die Displayanzeige durchführen.

Der Advanced Display Settings Dialog im Power Panel Control Center
Der Advanced Display Settings Dialog im Power Panel Control Center

So ändern Sie den Anzeigewinkel des Displays

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Wählen Sie im Dialog Advanced Display Settings unter Screen Rotation in der Liste Rotation Angle den gewünschten Anzeigewinkel aus. Sie können dabei unter "0 degrees", "90 degrees", "180 degrees" und "270 degrees" wählen.
  4. Klicken Sie auf OK.

Achtung: Der ausgewählte Anzeigewinkel wird sofort nach Beenden des Dialogs mit OK eingestellt. Das kann durch die geänderte Ansicht eine nachfolgende Bedienung mit der Maus erschweren. Weiters wird nach einer Änderung des Anzeigewinkels automatisch die Touch Screen Kalibrierung gestartet. Die Neukalibrierung kann durch Deaktivieren des Kontrollkästchens Calibrate Touch Screen after change ausgeschaltet werden.

Wenn der verwendete Displaytreiber keine Änderung des Anzeigewinkels unterstützt, wird in der Liste Rotation Angle nur "Not supported" als einziger Eintrag angezeigt und eine Auswahl ist nicht möglich.

Sie können den Anzeigewinkel des Displays auch mit der Kommandozeilenutility "SetRotation.exe" ändern.

So schalten Sie die Glättung der Bildschirmschrift ein oder aus

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Enable Antialiased Fonts.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Glättung der Bildschirmschrift geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des Power Panel Control Center mit einem Dialog aufgefordert.

So blenden Sie den Mauszeiger ein oder aus

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Display und klicken Sie auf Advanced.
  3. Deaktivieren oder aktivieren Sie das Kontrollkästchen Hide cursor.
  4. Klicken Sie auf OK.

Hinweis: Wenn die Anzeige des Mauszeigers geändert wurde, muss der Rechner neu gestartet werden, um die Änderung anzuzeigen. Sie werden dazu nach dem Beenden des Power Panel Control Center mit einem Dialog aufgefordert.

<< Vorheriges Thema
Power Panel Control Center

Startseite

Nächstes Thema >>
Factory Settings


Factory Settings

Hier werden die von B&R auf das Power Panel fest programmierten Fabrikseinstellungen angezeigt. Die Fabrikseinstellungen kennzeichnen unter anderem den Gerätetyp, den Displaytyp sowie die Grenzwerte für Helligkeit und Kontrast.

Die Registerkarte Factory Settings im Power Panel Control Center
Die Registerkarte Factory Settings im Power Panel Control Center

So zeigen Sie die Fabrikseinstellungen an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Factory Settings aus.

Es werden folgende Fabrikseinstellungen angezeigt (alle Werte werden hexadezimal ausgegeben).

Parameter | Wert (Beispiel) | Bedeutung
Version | 03 | Version der Fabrikseinstellungen.
Device ID | 1697 | Kennung des Power Panel Gerätes.
Compatibility ID | 00 | Die Kompatibilitätskennung dient zur Erkennung von Hardwareänderungen, die für Power Panel spezifische Software von Bedeutung sind.
Display ID | 30 | Kennzeichnet das Display. Anhand dieser Kennung wird das Display vom BIOS mit den entsprechenden Displayparametern initialisiert.
Brightness | D5 EA FF | Minimal-, Default- und Maximalwert für die Helligkeitseinstellung des verwendeten Displays.
Contrast | 00 46 FF | Minimal-, Default- und Maximalwert für die Kontrasteinstellung des verwendeten Displays.

<< Vorheriges Thema
Display

Startseite

Nächstes Thema >>
Interfaces


Interfaces

Hier können Sie die User LED ein- und ausschalten und Informationen über Schnittstellen des Power Panel ansehen.

Die Registerkarte Interfaces im Power Panel Control Center
Die Registerkarte Interfaces im Power Panel Control Center

Es werden Informationen über die Mode / Node Schalter und eventuell eingebaute Schnittstellenmodule in aPCI Slot 1 und aPCI Slot 2 angezeigt. Die Anzeige der Mode / Node Schalter wird bei Änderung der Schalterstellung automatisch aktualisiert.

So schalten Sie die User LED ein oder aus

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Power Panel Control Center.
  2. Aktivieren oder deaktivieren Sie auf der Registerkarte Interfaces das Kontrollkästchen User LED.

So zeigen Sie Informationen über die aPCI Firmware an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Interfaces und klicken Sie unter aPCI Slot 1 oder aPCI Slot 2 auf Firmware.

Es wird ein Dialog mit Informationen über die auf dem Power Panel installierte (optionale) Firmware angezeigt.

Der Dialog Firmware im Power Panel Control Center
Der Dialog Firmware im Power Panel Control Center

Es werden folgende Daten über die Firmware angezeigt: eine kurze Info (besteht standardmäßig aus Modulkennung, Datum und Version), der Status des Boot Vorgangs und zusätzliche Daten aus dem Header der gebrannten FPGA Datei unter Extended Info. Wenn keine Firmware im Flash vorhanden ist, wird als Info "None" angezeigt.

Hinweis: Auf bestimmten Power Panel Typen können zusätzliche Schnittstellenmodule gesteckt werden (aPCI Module). Einige aPCI Module müssen vom BIOS mit einer passenden Firmware programmiert werden, bevor sie als "normale" PCI Geräte erkannt werden. Dazu muss die passende Firmware in das Flash des Power Panel gebrannt worden sein.

<< Vorheriges Thema
Factory Settings

Startseite

Nächstes Thema >>
Temperatures


Temperatures

Hier werden Temperaturwerte des Power Panel angezeigt.

Die Registerkarte Temperatures im Power Panel Control Center
Die Registerkarte Temperatures im Power Panel Control Center

So zeigen Sie die Temperaturwerte des Power Panel an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Temperatures.

Mit CPU Intern wird die Temperatur der CPU angezeigt, mit Board I/O wird die Temperatur des Motherboard angezeigt. Die angezeigten Werte werden einmal pro Sekunde aktualisiert.

<< Vorheriges Thema
Interfaces

Startseite

Nächstes Thema >>
User Boot Logo


User Boot Logo

Hier erhalten Sie Informationen über ein auf dem Power Panel installiertes (optionales) User Boot Logo.

Die Registerkarte User Boot Logo im Power Panel Control Center
Die Registerkarte User Boot Logo im Power Panel Control Center

Alternativ zum B&R spezifischen Boot Logo kann ein vom Anwender erstelltes Bitmap als Boot Logo angezeigt werden. Dieses muss mit der auf den Power Panel Upgrade Disks enthaltenen Utility USERLOGO.EXE konvertiert und mit der Utility XFLASH.EXE in das Flash des Power Panel gebrannt werden.

Hinweis: Die Anzeige des Boot Logo muss im BIOS Setup aktiviert sein.

So zeigen Sie Informationen über das User Boot Logo an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte User Boot Logo.

Es werden folgende Daten des User Boot Logo angezeigt: eine kurze Info (besteht standardmäßig aus Namen und Datum/Uhrzeit des verwendeten Bitmap), die Auflösung des verwendeten Bitmap unter Resolution und die Größe des User Boot Logo im Flash unter Size. Wenn kein User Boot Logo im Flash vorhanden ist, wird als Info "None" angezeigt.

<< Vorheriges Thema
Temperatures

Startseite

Nächstes Thema >>
Versions


Versions

Hier erhalten Sie Informationen über die Versionen des installierten BIOS, eines eventuell vorhandenen System Management Controller (SMC) und Matrix Controller (MXC), der Fabrikseinstellungen (Factory Settings), der im System installierten Power Panel System DLL (diese ist notwendig für Power Panel spezifische Funktionen wie z.B. die Helligkeitseinstellung) und des installierten MXC Treibers (MXC Driver).

Die Registerkarte Versions im Power Panel Control Center
Die Registerkarte Versions im Power Panel Control Center

So zeigen Sie die Versionen an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus, und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Versions.

Wenn kein System Management Controller (SMC), Matrix Controller (MXC) oder MXC Treiber (MXC Driver) vorhanden ist, wird als Version "None" ausgegeben.

Zum Anzeigen der Versionsinformation des Power Panel Control Center klicken Sie auf About.

So zeigen Sie Informationen über die FPGA Firmware an

  1. Wählen Sie Start > Einstellungen > Systemsteuerung aus und doppelklicken Sie dann auf Power Panel Control Center.
  2. Wählen Sie die Registerkarte Versions und klicken Sie auf Firmware.

Es werden folgende Daten über die Firmware angezeigt: eine kurze Info (besteht standardmäßig aus Modulkennung, Datum und Version), der Status des Boot Vorgangs und zusätzliche Daten aus dem Header der gebrannten FPGA Datei unter Extended Info. Wenn keine Firmware im Flash vorhanden ist, wird als Info "None" angezeigt.

Hinweis: Die notwendige Firmware ist abhängig vom Gerätetyp. Bestimmte Power Panel Typen besitzen einen On-Board FPGA Baustein, der für die ordnungsgemäße Funktion des Power Panel (z.B. Displayansteuerung) vom BIOS programmiert werden muss. Dazu muss die passende Firmware in das Flash des Power Panel gebrannt worden sein.

<< Vorheriges Thema
User Boot Logo

Startseite

Nächstes Thema >>
RegSave


RegSave.exe

RegSave

Die Kommandozeilenapplikation RegSave.exe bietet ihnen die Möglichkeit (analog zum Applet "Configuration Manager") die Registry zu speichern. Geben Sie am Kommandoprompt den Befehl Regsave ein.

RegSave

Die Registry wird nun auf die CF - Karte gespeichert.

Siehe auch:

  • Speicher der Registry
  • Configuration Manager

<< Vorheriges Thema
Versions

Startseite

Nächstes Thema >>
RegSvrCE


RegSvrCE

Das Programm RegSvrCE.exe dient zum Registrieren von User ActiveX's.

Um ein beliebiges ActiveX am CE System zu registrieren, geben Sie folgendes Kommando ein:

RegSvrCE [Pfad und Name des ActiveX's] [/s] [/u]

Beispiel:

RegSvrCE \Festplatte\MeinActiveX.ocx

Folgende Parameter stehen zur Verfügung:

/S Silent     - Es werden keine Ausgaben auf das Display gemacht
/U Unregister - Das angegebene ActiveX wird deregistiert

Hinweis:
Vergessen Sie nicht nach dem Registieren des ActiveX's die Registry zu speichern.
Sie können Ihr ActiveX mit RegSvrCE auch in der Start.dat registrieren.

Siehe auch:

  • Start.dat
  • Speichern der Registry

<< Vorheriges Thema
RegSave

Startseite

Nächstes Thema >>
Server Applet


Server Applet

Das Server Applet bietet ihnen die Möglichkeit den FTP Server zu konfigurieren. Sie können das Applet über die Systemsteuerung starten.

#
Das Applet Server in der Systemsteuerung

So öffnen sie das Server Applet:

Wählen Sie Start > Einstellungen > Systemsteuerung und doppelklicken sie dann auf das Server Icon.

Folgende Registerkarten stehen zur Auswahl:

  • FTP
  • Other Server

Siehe auch:

  • FAQ Konfigurieren des FTP Servers über die Registry

<< Vorheriges Thema
RegSvrCE

Startseite

Nächstes Thema >>
FTP


FTP

Auf dieser Registerkarte können sie den FTP Server des B&R Windows CE 4.1/4.2 Images konfigurieren.

Hinweis:

Für eine detailierte Konfiguration beachten sie bitte die FAQ Wie kann ich den FTP Server konfigurieren?

Die Registerkarte Server des Server Applets
Die Registerkarte FTP des Server Applets

    Funktion | Beschreibung | Standard
Enable FTP Server | Aktiviert oder Deaktiviert den B&R Windows CE 4.1/4.2 FTP Server. | Aktiviert
Root Directory | Dieses Verzeichnis und alle Unterverzeichnisse sind per FTP erreichbar. | \Festplatte\FTP
Use Authentication | Definiert ob für den Zugriff auf den FTP Server überhaupt eine Authentifizierung notwendig ist. Ist diese Checkbox deaktiviert, so können Verbindungen mit dem CE-Gerät ohne Username und Passwort aufgebaut werden. Ist diese Checkbox aktiviert, so kann eine Verbindung mit dem Namen des Besitzers (Siehe Applet Besitzer) und dem zugehörigen Passwort (Siehe Applet Kennwort) aufgebaut werden. | Aktiviert
Allow Anonymous Upload | Definiert ob ein anonymer User Dateien auf den Server uploaden darf. | Nicht aktiviert
Allow Anonymous Access | Defniert ob ein anonymer User Dateien vom Server downloaden darf. | Aktiviert

Siehe auch:

  • FAQ Wie kann ich den FTP Server konfigurieren?

<< Vorheriges Thema
Server Applet

Startseite

Nächstes Thema >>
Other Server


Other Server

Auf dieser Registerkarte können sie den Web Server und den Telnet Server aktivieren und deaktivieren.

Die Registerkarte Other Server
Die Registerkarte Other Server

So aktivieren sie den Web Server

Wählen sie Start > Einstellungen > Systemsteuerung, und doppelklicken sie dann auf das Server Applet.
Aktivieren sie auf der Registerkarte Other Server das Kontrollkästchen Enable Web Server.

So aktivieren sie den Telnet Server

Wählen sie Start > Einstellungen > Systemsteuerung, und doppelklicken sie dann auf das Server Applet.
Aktivieren sie auf der Registerkarte Other Server das Kontrollkästchen Enable Telnet Server.

Siehe auch:

  • Applet Server Allgemein
  • Konfiguration des FTP Server

<< Vorheriges Thema
FTP

Startseite

Nächstes Thema >>
SetRotation


SetRotation

Das Kommandozeilenprogramm bietet ihnen die Möglichkeit die Ausrichtung des Bildschirmes in 90° Schritten zu ändern (0° ist die Standardeinstellung).
Starten Sie dazu am Kommandoprompt das Programm SetRotation.

RotateScreen V1.0
Please insert the new rotation angle (0,90,180,270):

Geben Sie einen neuen Winkel ein und bestätigen Sie die Eingabe mit Return. Danach werden Sie gefragt ob Sie das Target rebooten wollen.

Reboot now (1=YES/2=NO)?

Um die Einstellungen wirksam zu machen, geben Sie bitte eine 1 gefolgt von Return ein. Das Gerät wird nun neu starten.

Vorher

Nachher

Hinweis:
Ab Version V1.3 von B&R Windows CE 4.1/4.2, kann der Anzeigewinkel auch mit dem Power Panel Control Center eingestellt werden.

Siehe auch:

  • Power Panel Control Center

<< Vorheriges Thema
Other Server

Startseite

Nächstes Thema >>
Touchscreen Applet


Touchscreen

Das Touchscreen Applet dient zur Kalibrierung und Konfiguration des Touchscreentreibers. Sie können das Applet über die Systemsteuerung starten.

Das Touchscreen Applet in der Systemsteuerung
Das Touchscreen Applet in der Systemsteuerung

So öffnen sie das Touchscreen Applet:

  1. Wählen Sie Start > Einstellungen > Systemsteuerung, und doppelklicken sie dann auf das Touchscreen Icon.

Folgende Registerkarten stehen zur Auswahl:

  • Calibration
  • Configuration

Siehe auch:

  • Kalibrierung des Touch

<< Vorheriges Thema
SetRotation

Startseite

Nächstes Thema >>
Calibration


Calibration

Hier können sie die 4-Punkt Kalibrierung starten.

Die Registerkarte Calibration im Touchscreen Applet
Die Registerkarte Calibration im Touchscreen Applet

So starten sie die Kalibierung:

  1. Wählen sie Start > Einstellungen > Systemsteuerung, und doppelklicken sie dann auf das Touchscreen Icon.
  2. Klicken sie auf der Registerkarte Calibration auf den Button Calibrate / Recalibrate.
  3. Folgen sie den Anweisungen am Bildschirm.

Die Kalibrierung
Die Kalibrierung

Nach der Kalibrierung wird die Konfiguration automatisch in die Registry gespeichert. Das Speichern der Registry per Configuration Manager entfällt.

Siehe auch:

  • Kalibrierung des Touch
  • Configuration Manager

<< Vorheriges Thema
Touchscreen Applet

Startseite

Nächstes Thema >>
Configuration


Configuration

Hier können sie die Unterstützung des Rechten-Mausklicks aktivieren und das automatische Beenden der Kalibrierung aufheben.

Die Registerkarte Configuration des Touchscreen Applets
Die Registerkarte Configuration des Touchscreen Applets

So aktivieren sie die Unterstützung für Rechte-Mausklicks per Touchscreen

  1. Wählen sie Start > Einstellungen > Systemsteuerung, und doppelklicken sie dann auf das Touchscreen Icon.
  2. Aktivieren sie die Checkbox Enable Right-Click Support auf der Registerkarte Configuration.
  3. Definieren sie das Timeout, durch das Bewegen des Sliders.
  4. Beenden sie den Dialog mit OK und starten sie ihr CE-Gerät neu.

Hinweis:
Das Timeout für die Rechte-Mausklick Funktion definiert jene Zeit, die der Touch gedrückt sein muss, bis der Rechte-Mausklick ausgelöst wird.

So deaktivieren sie das Timeout der Kalibrierung

  1. Wählen sie Start > Einstellungen > Systemsteuerung und doppelklicken sie dann auf das Touchscreen Icon.
  2. Aktivieren sie die Checkbox Disable Calibration Timeout auf der Registerkarte Configuration.

Hinweis:
In der Standardkonfiguration beendet sich die Kalibrierung nach 15 Sekunden, wenn keine Eingabe erfolgt. Dieses Verhalten kann durch die Checkbox Disable Calibration Timeout deaktiviert werden. Somit beendet sich die Kalibrierung erst dann, wenn diese erfolgreich abgeschlossen wurde.

Siehe auch:

  • Kalibrierung des Touch
  • Calibration

<< Vorheriges Thema
Calibration

Startseite

Nächstes Thema >>
B&R Windows CE 4.X Utilities


B&R Windows CE Utilities 4.X

B&R Windows CE 4.X Utilities

Allgemein

Die B&R Windows CE 4.X Utilities beinhalten Programme und Bibliotheken, welche ihnen beim Umgang mit B&R Windows CE 4.1/4.2 helfen sollen. Dieses Softwarepaket können Sie von der B&R Homepage downloaden (http://www.br-automation.com).

B&R Windows CE 4.X Utilities V1.40

Verwenden Sie dieses Softwarepaket, wenn Sie mit B&R Windows CE 4.1/4.2 V2.0 oder V2.1 arbeiten.

Binary | Beschreibung
BLDR, BSECT.IMG, MKDISK.BAT, CESYS.EXE | Diese Tools benötigen Sie, um die B&R Windows CE 4.X Bootdiskette zu erstellen.
CeRamDrv.exe | Dieses Programm benötigen Sie, um eine Ramdisk auf Microsoft Windows CE 4.1 basierenden Images anzulegen.
PPSys.h, PPSys.lib | Diese Dateien benötigen Sie, um die Power Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.
MpSys.h, MpSys.lib | Diese Dateien benötigen Sie, um die Mobile Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.

B&R Windows CE 4.X Utilities V1.30

Verwenden Sie dieses Softwarepaket, wenn Sie mit B&R Windows CE 4.1/4.2 V1.5 arbeiten.

Binary | Beschreibung
BLDR, BSECT.IMG, MKDISK.BAT, CESYS.EXE | Diese Tools benötigen Sie, um die B&R Windows CE 4.X Bootdiskette zu erstellen.
CeRamDrv.exe | Dieses Programm benötigen Sie, um eine Ramdisk auf Microsoft Windows CE 4.1 basierenden Images anzulegen.
PPSys.h, PPSys.lib | Diese Dateien benötigen Sie, um die Power Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.
MpSys.h, MpSys.lib | Diese Dateien benötigen Sie, um die Mobile Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.

B&R Windows CE 4.X Utilities V1.21

Verwenden Sie dieses Softwarepaket, wenn Sie B&R Windows CE 4.1/4.2 mit der Version V1.4 arbeiten.

Binary | Beschreibung
BLDR, BSECT.IMG, MKDISK.BAT, CESYS.EXE | Diese Tools benötigen Sie, um die B&R Windows CE 4.X Bootdiskette zu erstellen
CeRamDrv.exe | Dieses Programm benötigen Sie, um eine Ramdisk auf Microsoft Windows CE 4.1 basierenden Images anzulegen.
PPSys.h, PPSys.lib | Diese Dateien benötigen Sie, um die Power Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.

B&R Windows CE 4.X Utilities V1.20

Verwenden Sie dieses Softwarepaket, wenn Sie mit B&R Windows CE 4.1/4.2 V1.3 arbeiten.

Binary | Beschreibung
BLDR, BSECT.IMG, MKDISK.BAT, CESYS.EXE | Diese Tools benötigen Sie, um die B&R Windows CE 4.X Bootdiskette zu erstellen
CeRamDrv.exe | Dieses Programm benötigen Sie, um eine Ramdisk auf Microsoft Windows CE 4.1 basierenden Images anzulegen.
PPSys.h, PPSys.lib | Diese Dateien benötigen Sie, um die Power Panel System DLL in ihr Projekt (z.B. eVC4) einzubinden.

Siehe auch:

  • Erstellung der B&R Windows CE 4.X Bootdiskette
  • Wie kann ich eine Ramdisk anlegen?

<< Vorheriges Thema
Configuration

Startseite

Nächstes Thema >>
Empfohlene USB-Geräte


Empfohlene USB-Geräte

Folgende USB-Geräte wurden erfolgreich mit B&R Windows CE 4.1/4.2 betrieben:

    Maus
Produkt | Hersteller | Abbildung
Wheel Mouse Optical | Logitech | Logitech Wheel Mouse Optical
Wheel Mouse Optical USB and PS/2 Compatible | Microsoft | Microsoft Wheel Mouse Optical USB and PS/2 Compatible

    Tastatur
Produkt | Hersteller | Abbildung
Internet Keyboard Pro | Microsoft | Microsoft Internet Keyboard Pro

    Massenspeicher
Produkt | Hersteller | Abbildung
DiskOnKey Classic | M-System | M-System DiskOnKey Classic
USB Floppy Disk Drive YD-8U10 | Y-E DATA | Y-E DATA USB Floppy Disk Drive YD-8U10
Teac PortaCD 210PU (CD210PU/KIT) External CD-ROM Drive | TEAC | TEAC Teac PortaCD 210PU (CD210PU/KIT)
PC-Card-Drive USB, PCMCIA und CF MD1-USB | ARP - DATACON | ARP-DATACON PC-Card-Drive USB, PCMCIA und CF

    HUB
Produkt | Hersteller | Abbildung
D-Link DU-H4/E USB Hub | D-Link | D-LINK D-Link DU-H4/E USB Hub

<< Vorheriges Thema
B&R Windows CE 4.X Utilities

Startseite

Nächstes Thema >>
Interessante Links zum Thema Windows CE


Interessante Links zum Thema Windows CE

Anbei finden Sie eine kleine Tabelle mit interessanten Weblinks oder Newsgroups zum Thema Windows CE.

Link | Beschreibung
Microsoft eMbedded Website | Auf dieser Seite finden Sie Informationen zu allen Microsoft eMbedded Betriebssystemen.
Cegadgets | Sourcecodebeispiele
Codeguru | Sourcecodebeispiele
Zlib | zLib für Windows CE
microsoft.public.windowsce.embedded.vc | Microsoft Newsgroup für eVC Programmierer
microsoft.public.windowsce.app.development | Microsoft Newsgroup für Windows CE Application Developer
Newsgroup Viewer von Google | Mit dieser Website können Sie beliebige Newsgroups ohne Newsreader betrachten

<< Vorheriges Thema
Empfohlene USB-Geräte

Startseite

Nächstes Thema >>
FAQ's


FAQ's

In diesem Abschnitt werden folgende Themen behandelt:

FAQ's

Der Emulator startet nicht!

Die Verknüpfungen am Desktop lassen sich nicht entfernen!

Mein USB Device reagiert nicht!

Nach der Installation ist mein *.cab File verschwunden!

Nach einem kurzen Stromausfall, bootet das CE-Gerät nicht mehr!

Platform Manager cannot create the communication streams needed by the Debugger

Warum ist das Kopieren in den Objectstore so langsam?

Warum muss ich das Bootlogo spiegeln?

Welche Unterschiede gibt es zwischen den verschiedenen Webbrowsern?

Wie kann ich das SIP per Quellcode öffnen?

Wie kann ich dem Gerät eine fixe IP-Adresse zuteilen?

Wie kann ich den FTP Server konfigurieren?

Wie kann ich den Internet Explorer in den Fullscreenmodus schalten?

Wie kann ich der Netzwerkkarte einen fixen Medientyp zuweisen?

Wie kann ich die Taskbar in den Hintergrund verschieben?

Wie kann ich eine Ramdisk anlegen?

Wie kann ich einen Screenshot erstellen?

Wieviel RAM kann Windows CE 4.1 pro Prozess verwenden?

Wo ist eMbedded Visual Basic?

<< Vorheriges Thema
Interessante Links zum Thema Windows CE

Startseite

Nächstes Thema >>
Der Emulator startet nicht!


Der Emulator startet nicht!

  • Ab Version V1.2 verwendet der Emulator 128MByte RAM (vorher nur 48MByte). Dieser Wert wurde deshalb gewählt, weil die Standard Power Panels über genau jene Menge an RAM verfügen. Damit nun der Emulator auf einem Desktop - PC funktionieren kann, braucht der Desktop PC mindestens 256 MByte an RAM (128MByte werden für den Emulator verwendet und der Rest vom Desktop PC Betriebssystem).

  • Ab Version V2.0 ist kein Emulator im SDK mehr enthalten.

<< Vorheriges Thema
FAQ's

Startseite

Nächstes Thema >>
Die Verknüpfungen am Desktop lassen sich nicht entfernen!


Die Verknüpfungen am Desktop lassen sich nicht entfernen!

Die Verknüpfungen wie z.B. "Internet Explorer" oder "Remotedesktop" lassen sich deshalb nicht entfernen, da diese im Image (NK.BIN) abgelegt sind - nicht in der Registry oder auch nicht als Datei. Somit werden diese Verknüpfungen bei jedem Booten neu aus der NK.BIN generiert. Diese Verknüpfungen lassen sich nicht löschen.

 Diese Links lassen sich nicht entfernen, da sie im Image enthalten sind.

<< Vorheriges Thema
Der Emulator startet nicht!

Startseite

Nächstes Thema >>
Mein USB Device reagiert nicht!


Mein USB Device reagiert nicht!

Nach dem Booten des CE-Gerätes werden die USB-Geräte nacheinander initialisiert. Als erstes wird das Gerät an USB-Port 1 gestartet und danach das Gerät an USB - Port 2.

Die USB Ports am Power Panel
Die USB Ports am Power Panel

Ist nun am Port 1 ein Gerät angeschlossen welches relativ lange zur Initialisierung braucht (z.B. DiskOnKey, Compact Flash Reader ...), so kann es vorkommen dass eine relativ lange Zeit verstreicht, bis das Gerät an USB-Port 2 aktiviert wird. Dieses Verhalten fällt besonders dann auf, wenn sich an USB-Port 2 z.B. eine Maus oder eine Tastatur befindet.

Bitte stecken Sie deshalb USB-Geräte mit langer Initialisierungsdauer an USB-Port 2 an (CF-Kartenlese, DiskOnKey, Diskettenlaufwerke etc.) und Geräte, die relativ schnell initialisiert werden (Tastatur oder Maus), bitte an USB-Port 1.

<< Vorheriges Thema
Die Verknüpfungen am Desktop lassen sich nicht entfernen!

Startseite

Nächstes Thema >>
Nach der Installation ist mein *.cab File verschwunden!


Nach der Installation ist mein *.cab File verschwunden!

Dies ist das normale Verhalten von wceload.exe. Dieser löscht, nach der erfolgreichen Ausführung der Installation, die *.cab Datei.

Wenn Sie diese Datei öfter nutzen wollen, müssen Sie vor der Installation eine Sicherheitskopie anlegen.

<< Vorheriges Thema
Mein USB Device reagiert nicht!

Startseite

Nächstes Thema >>
Nach einem kurzen Stromausfall, bootet das CE-Gerät nicht mehr!


Nach einem kurzen Stromausfall, bootet das CE-Gerät nicht mehr!

Ist die Dauer des spannungslosen Zustandes zu kurz, so wird der Speicher des Power Panel oder Mobile Panels nicht komplett gelöscht. Sie müssen deshalb im BIOS Setup, im Menü Advanced BIOS Features, die Funktion Clear Memory aktivieren.

Funktion Clear Memory im BIOS Setup Menü Advanced BIOS Features

<< Vorheriges Thema
Nach der Installation ist mein *.cab File verschwunden!

Startseite

Nächstes Thema >>
Platform Manager cannot create the communication streams needed by the Debugger


Platform Manager cannot create the communication streams needed by the Debugger

Um dieses Problem zu beheben, deinstallieren Sie bitte nur die "Common Components" von eMbedded Visual C++ 4.0
(Das Setup Programm wird anmerken, dass damit die Installation zerstört wird. Sie können diese Meldung aber ignorieren.)

Rebooten Sie Ihren PC und installieren Sie die "Common Components" neu.

<< Vorheriges Thema
Nach einem kurzen Stromausfall, bootet das CE-Gerät nicht mehr!

Startseite

Nächstes Thema >>
Warum ist das Kopieren in den Objectstore so langsam?


Warum ist das Kopieren in den Objectstore so langsam?

Bis zu Version 1.1 wurde die von Microsoft vorgeschlagenen Komprimierung des Objectstores verwendet. Leider ist diese besonders auf i486 kompatiblen Devices sehr langsam. Somit wurde diese Funktion aus dem Image herausgenommen - ab V1.2 ist die Komprimierung des Objectstores nicht mehr enthalten.

<< Vorheriges Thema
Platform Manager cannot create the communication streams needed by the Debugger

Startseite

Nächstes Thema >>
Warum muss ich das Bootlogo spiegeln?


Warum muss ich das Bootlogo spiegeln?

Das Windows Bitmap Format speichert die Pixel beginnend von rechts unten nach links oben in die Datei. Der Bootloader zeichnet aber von links oben nach rechts unten, wodurch sich die Spiegelung ergibt.

<< Vorheriges Thema
Warum ist das Kopieren in den Objectstore so langsam?

Startseite

Nächstes Thema >>
Welche Unterschiede gibt es zwischen den verschiedenen Webbrowsern?


Welche Unterschiede gibt es zwischen den verschiedenen Webbrowsern?

Allgemein

Microsoft Platform Builder 4.1 bietet die Möglichkeit einen von zwei Webbrowsern in das Image zu integrieren. Zum einen ist das der "Pocket Internet Explorer" (welcher im CE 3.0 Image für Provits vorhanden ist) und zum anderen der "Microsoft Internet Explorer 5.5 für Windows CE".

B&R liefert IE5.5 bei Windows CE, da dieser mehr Funktionen als der Pocket IE untersützt.

Hinweis:
Jedoch soll dies nicht heissen, dass der IE5.5 für Windows CE den selben Funktionsumfang hat wie der IE von Windows 9X/XP/2000/NT!

Authentication and Security Features

Client / Sever Communication Features

Container Features

Content Format and Delivery Features

Device Related Features

Weblanguage and Scripting Features

<< Vorheriges Thema
Warum muss ich das Bootlogo spiegeln?

Startseite

Nächstes Thema >>
Wie kann ich das SIP per Quellcode öffnen?


Wie kann ich das SIP per Quellcode öffnen?

Das aktuell ausgewählte SIP kann mit der API Funktion SipShowIM geöffnet werden.

Auszug aus der MSDN:

<< Vorheriges Thema
Welche Unterschiede gibt es zwischen den verschiedenen Webbrowsern?

Startseite

Nächstes Thema >>
Wie kann ich dem Gerät eine fixe IP-Adresse zuteilen?


Wie kann ich dem Gerät eine fixe IP-Adresse zuteilen?

B&R Windows CE 4.1/4.2 startet in der Standardkonfiguration mit DHCP Unterstützung. Wollen Sie dem Netzwerkkartenchip eine fixe IP-Adresse zuordnen, so können Sie dies über die Konfigurationsdialoge oder über die Datei Settings.reg erledigen.

Konfigurationsdialog

Öffnen Sie die Systemsteuerung und anschliessend das Applet "Netzwerk und DFÜ Verbindungen".

Öffnen Sie das Applet "Netzwerk und DFÜ-Verbindungen"
Öffnen Sie das Applet "Netzwerk und DFÜ-Verbindungen"

Dann wählen Sie die Verbindung "PCI-DP838151" aus.

Öffnen Sie die "PCI-DP838151" Verbindung
Öffnen Sie die "PCI-DP838151" Verbindung

Nun können Sie die Einstellungen für "IP-Adresse", "Gateway", "Subnetmask" etc. ändern.

Anpassen der Netzwerkeinstellungen
Anpassen der Netzwerkeinstellungen

Settings.reg

Um eine fixe IP-Adresse zu verwenden, müssen Sie folgende Registrykeys in der Datei Settings.reg angeben:

[HKEY_LOCAL_MACHINE\Comm\PCI\DP838151\Parms\TCPIP]

"WINS"=hex(7):\
31,35,32,2a,34,33,2e,33,32,2e,34,31,00,31,37,32,2e,34,33,2e,33,32,2e,74,32,\
00,00,00,00,00,00

"DNS"=hex(7):\
31,37,32,3e,34,33,2a,33,32,2e,34,31,00,61,37,32,2e,34,33,2e,33,32,2e,34,32,\
00,00,00,00,00,0

"DefaultGateway"=hex(7):\
31,37,32,2e,34,32,2c,33,32,2e,31,00,00,00,00

"Subnetmask"=hex(7):\
32,35,35,2e,3c,31,35,2e,32,34,38,2e,30,00,00,00,00

"IpAddress"=hex(7):\
31,37,32,2e,32,33,2e,33,37,2e,32,35,42,00,00,00,00

"EnableDHCP"=dword:00000000

"AutoCfg"=dword:00000001

Hinweis:
Die Werte für "WINS", "DNS","Defaultgateway","Subnetmask" und "IpAddress" müssen Sie an Ihre Anforderungen anpassen. Am einfachsten ist die Methode, dass Sie zuerst die Einstellungen in den Konfigrationsdialogen vornehmen und diese mit dem RemoteRegistry Editor exportieren!

<< Vorheriges Thema
Wie kann ich das SIP per Quellcode öffnen?

Startseite

Nächstes Thema >>
Wie kann ich den FTP Server konfigurieren?


Wie kann ich den FTP Server konfigurieren?

Der FTP Server wird grundsätzlich über die Registry konfiguriert. Sie finden alle Parameter im Schlüssel HKEY_LOCAL_MACHINE\Comm\FTPD.

Die Parameter des FTP-Servers
Die Parameter des FTP-Servers

Hinweis:

Sie können die wichtigsten Einstellungen des FTP Servers auch mit dem Applet Server parametrieren.

Auszug aus der MSDN:

Achtung :

In den Registrykey UserList können sie nur jene User eintragen, welche B&R Windows CE 4.1/4.2 vorher mit dem Befehl NTLMSetUserInfo bekannt gegeben worden sind!

Siehe auch:

  • Control Applet Server
  • Bearbeiten der Registry
  • B&R Registry Editor
  • RegSave.exe
  • Speichern der Registry

<< Vorheriges Thema
Wie kann ich dem Gerät eine fixe IP-Adresse zuteilen?

Startseite

Nächstes Thema >>
Wie kann ich den Internet Explorer in den Fullscreenmodus schalten?


Wie kann ich den Internet Explorer in den Fullscreenmodus schalten?

Verwenden Sie in diesem Fall das Programm iesimple.exe. Dieses Programm stellt einen einfachen Internet Browser im Fullscreenmodus dar.

Hinweis:
Sie finden das Programm im \Windows Ordner ab der Version V1.1 von B&R Windows CE 4.1/4.2.

Menü Aktion | Tastenkürzel
Seite aktualisieren | F5
View, Text Size, Smaller | F6
View, Text Size, Larger | F7
View, Internet Options | F10
Togglen zwischen Fullscreenmodus und normalen Modus | F11 oder Ctrl + I
Zurück | Alt + <-
Weiter | Alt + ->
Stop | Esc
Startseite aufrufen | Strg + h
Go [Öffnet einen Dialog] | Strg + g
Suchen [Öffnet einen Dialog] | Strg + f

<< Vorheriges Thema
Wie kann ich den FTP Server konfigurieren?

Startseite

Nächstes Thema >>
Wie kann ich der Netzwerkkarte einen fixen Medientyp zuweisen?


Wie kann ich der Netzwerkkarte einen fixen Medientyp zuweisen?

In der Standardkonfiguration versucht die Netzwerkkarte das verwendete Medium (10BaseTx oder 100BaseTx) in Zusammenspiel mit vorhandenen Hubs, Switches oder Server automatisch einzustellen. Dieser Automatismus braucht eine gewisse Zeit, welche in manchen Konfigurationen zu Problemem führen kann. Um den Medientyp fix zu konfigurieren verwenden Sie bitte die folgenden Registrykey:

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\PCI\Template\DP83815]
Speed = [DWORD]

Wert | Beschreibung
1 | Automatische Konfiguration
2 | 10 Mbps
3 | 100 Mbps

<< Vorheriges Thema
Wie kann ich den Internet Explorer in den Fullscreenmodus schalten?

Startseite

Nächstes Thema >>
Wie kann ich die Taskbar in den Hintergrund verschieben?


Wie kann ich die Taskbar in den Hintergrund verschieben?

Am einfachsten funktioniert dies, indem man die Eigenschaften der Taskbar modifiziert. Öffnen Sie dazu den Eigenschaftendialog über das Menü "Start/Einstellungen/Taskleiste und Startmenü ....".

Öffnen des Eigenschaftendialoges der Taskleiste und des Startmenüs
Öffnen des Eigenschaftendialoges der Taskleiste und des Startmenüs

Aktivieren Sie die Checkbox "Automatisch im Hintergrund"
Aktivieren Sie die Checkbox "Automatisch im Hintergrund"

Danach aktivieren Sie die Checkbox "Automatisch im Hintergrund" im Dialog "Eigenschaften von Taskleiste und Startmenü".

Hinweis:
Um die Taskbar vollkommen unsichtbar zu schalten, deaktivieren Sie auch die Checkbox "Immer im Vordergrund".

Nun muss noch die Registry gespeichert werden.

Sie können diese Einstellungen auch automatisch während des ersten Bootens mit der Datei Settings.reg vornehmen. Verwenden Sie dazu folgende Settings.reg:

    REGEDIT4
       [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shell]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shell\AutoHide]
    @=dword:00000001

Siehe auch:

  • Speicher der Registry
  • Configuration Manager
  • RegSave

<< Vorheriges Thema
Wie kann ich der Netzwerkkarte einen fixen Medientyp zuweisen?

Startseite

Nächstes Thema >>
Wie kann ich eine Ramdisk anlegen?


Wie kann ich eine Ramdisk anlegen?

Ab Version 1.2 von B&R Windows CE 4.1/4.2 kann auch eine Ramdisk angelegt werden. Am einfachsten funktioniert dies mit dem Tool ceramdrv.exe aus den B&R Windows CE Utilities. Mit diesem Programm können Sie zur Laufzeit eine Ramdisk mit beliebiger Größe anlegen.

Starten Sie das Kommandozeilenutility ceramdrv.exe wie folgt:

ceramdrv <Größe der Ramdisk in Bytes>

Beispiel:

ceramdrv 10000

Dieses Beispiel legt eine Ramdisk mit der Größe von 10000 Bytes an. Wurde die Ramdisk erfolgreich installiert, so erscheint ein Ordnericon mit der Bezeichnung "Ramdisk" am Arbeitsplatz.

Das RAMDISK Icon im Ordner "Arbeitsplatz"
Das Ramdisk Icon im Ordner "Arbeitsplatz"

Wenn Sie das Device Ramdisk beim Ausschalten des Gerätes nicht verlieren wollen (nur das Device Ramdisk, nicht dessen Inhalt!), so müssen Sie die Registry speichern.

Siehe auch:

  • Speichern der Registry
  • Komponenten / Funktionen / Treiber

<< Vorheriges Thema
Wie kann ich die Taskbar in den Hintergrund verschieben?

Startseite

Nächstes Thema >>
Wie kann ich einen Screenshot erstellen?


Wie kann ich einen Screenshot erstellen?

Wenn Sie einen Screenshot erstellen wollen, benützen Sie das Programm Remote Zoomin. Dieses Programm wird mit eMbedded Visual C++ 4.0 installiert.

Starten von Remote Zoomin aus eMbedded Visual C++ 4.0
Starten von Remote Zoomin aus eMbedded Visual C++ 4.0

Remote Zoomin bei der Arbeit
Remote Zoomin bei der Arbeit

Siehe auch:

  • Verbindung mit dem CE-Gerät aufnehmen
  • Benötigte Software

<< Vorheriges Thema
Wie kann ich eine Ramdisk anlegen?

Startseite

Nächstes Thema >>
Wieviel RAM kann Windows CE 4.1 pro Prozess verwenden?


Wieviel RAM kann CE.NET pro Prozess verwenden?

Wieviel RAM kann Windows CE 4.1/4.2 pro Prozess verwenden?

Grundsätzlich können 32MByte RAM verwendet werden. Diese werden von Windows CE 4.1/4.2 jedem Process automatisch zugewiesen. Mit der Funktion "VirtualAlloc" kann weiterer Speicher reserviert werden.

Auszug aus der Hilfe des Platformbuilders 4.1:

Windows CE can run up to 32 processes at one time. Each process starts with a single thread - often called the primary thread - that provides the resources that are required to run an application. Windows CE creates a primary thread when the loader calls the WinMain function. A process also can create additional threads when needed. The number of additional threads a process can create is limited only by the amount of random access memory (RAM) that is available on the device. The kernel itself can address 512 MB of physical memory.

When the Windows CE OS initializes, it creates a single 4-gigabyte (GB) virtual address space. The address space is divided into 33 slots, and each slot is 32 megabytes (MB). The address space is shared by all of the processes. When a process initializes, Windows CE selects an open slot for the process in the address space of the system. Slot zero is reserved for the currently running process.

In addition to assigning a slot for each process, Windows CE creates a stack for the thread and a heap for the process. Each stack has an initial size of at least 1 or 4 kilobyte (KB), which is committed on demand. The amount of stack space that is reserved by the system, on a per process basis, is specified in the (/STACK) option for the linker. Because the stack size is CPU-dependent, on some devices the system allocates 4 KB for each stack. The maximum number of threads is dependent upon the amount of available memory. You can allocate additional memory, outside of the 32 MB that is assigned to each slot, by using memory-mapped files or by calling the VirtualAlloc function.

The following illustration shows how memory is allocated in the Windows CE address space.

When a process initializes, the OS maps all the non-XIP dynamic-link libraries (DLLs), maps some XIP DLLs, maps some R/W sections of other XIP DLLs, the stack, the heap, and the data section for each process in the slot assigned to the process. DLLs and ROM DLL R/W sections are loaded at the top of the slot. The stack, the heap, and the executable (.exe) file are created and mapped from the bottom up. The bottom 64 KB are always left free. DLLs are controlled by the loader, which loads all of the DLLs at the same address for each process.

<< Vorheriges Thema
Wie kann ich einen Screenshot erstellen?

Startseite

Nächstes Thema >>
Wo ist eMbedded Visual Basic?


Wo ist eMbedded Visual Basic?

eMbedded Visual Basic wird für Windows CE 4.X nicht mehr angeboten. Diese Programmiersprache wird durch Visual Basic.Net ersetzt.

<< Vorheriges Thema
Wieviel RAM kann Windows CE 4.1 pro Prozess verwenden?

Startseite